Contribute
Register

RX 580 FCPX video rendering issues

Status
Not open for further replies.
Joined
Aug 9, 2011
Messages
27
Motherboard
Gigabyte Z370n
CPU
8700k
Graphics
5700 XT
Thanks for the reply Gigamaxx. I am attaching my config - i did try inject intel = false + no igplatformid, still no luck.
Its as if a power management issue that causes the slowdown (my usb wifi also goes down at times, the moment I turn wifi off and on again, I know the graphics performance will degrade too).

Doyou have inject Intel and Fake ID 0x59120003? Have you tried inject Intel = false, and no ID 0X59120003, BUT USE IG PLATFORM ID 0X59120003? Switch the ID for ig and Inject Intel + false. See if you get KBLgraphics instead of HD 630.
 

Attachments

  • config.plist
    10.5 KB · Views: 303

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,380
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
@mythamp, please update your profile (personal details) with your Motherboard or Make/Model, CPU and Graphics Card.
The Rules said:
Profiles need to contain at least your primary system to assist others with helping you.
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,570
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
config-4.plist.zip. try this, change the name to config.plist first. Keep a copy of your old one, I thought you had a kabylake 0x5912, nut i5 6500 is 0x1912 ID.
 

Attachments

  • config-4.plist.zip
    2.8 KB · Views: 155
Joined
Oct 25, 2017
Messages
115
Motherboard
Gigabyte Z690i AORUS
CPU
i7-12700K
Graphics
RX 6600 XT
Mac
  1. iMac
  2. Mac Pro
Thanks for the reply Gigamaxx. I am attaching my config - i did try inject intel = false + no igplatformid, still no luck.
Its as if a power management issue that causes the slowdown (my usb wifi also goes down at times, the moment I turn wifi off and on again, I know the graphics performance will degrade too).

Hey again, lets make sure you followed the steps:

DSDT Patch: GFX0->IGPU

Try Devices->Add Properties:
Device: IntelGFX Key: AAPL,GfxYTile Value: 0AAAAA00 Type: DATA

Graphics: Inject Intel + ig-platform-id : 0x59120003

Kexts:
IntelGraphicsFixup.kext
Lilu.kext
WhateverGreen.kext

EDIT:
make sure you have the -disablegfxfirmware argument enabled
 
Last edited:
Joined
Aug 9, 2011
Messages
27
Motherboard
Gigabyte Z370n
CPU
8700k
Graphics
5700 XT
Hey again, lets make sure you followed the steps:

DSDT Patch: GFX0->IGPU

Try Devices->Add Properties:
Device: IntelGFX Key: AAPL,GfxYTile Value: 0AAAAA00 Type: DATA

Graphics: Inject Intel + ig-platform-id : 0x59120003

Kexts:
IntelGraphicsFixup.kext
Lilu.kext
WhateverGreen.kext

This worked finally and I also had to turn on EmuVariableUEFI as my mobo did not support nvram natively! But its all working great now! Thanks MatiCohen & Gigamaxx!!
 
Joined
Jan 8, 2011
Messages
16
Motherboard
Gigabyte Aorus Z270X K5
CPU
I7 7700K
Graphics
Sapphire Nitro+ Radeon RX 580
Mobile Phone
  1. iOS
Don't give up my friend, i've had the exact same problem, as soon as you play a video the degradation begins, u lose x3 of the performance.

this is the only thing that fixed it for me, you have to boot igpu with the rx580, make sure you have igpu memory allocation of 64MB, if you can't control that, try IntelGraphicsDVMTFixup kext.

i've uploaded my config.plist
Hi,

Thanks for your tip. I had the some problem, I check your config and it Worked!!!

Thanks!!
 
Joined
Sep 26, 2013
Messages
2
Motherboard
asrock z370 Gaming ITX/ac
CPU
i7-8770k
Graphics
Gigabyte Aorus RX580
Hi mythamp. I wrote a lengthy reply to your question but don't know why my reply it was pending moderator review. After that, it was deleted. But glad you solved it. Merry Christmas :)
 
Joined
Dec 15, 2017
Messages
1
Motherboard
Asus Prime H270M Plus
CPU
i7 7700
Graphics
Gigabytes Aorus RX580 8GB
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Hey again, lets make sure you followed the steps:

DSDT Patch: GFX0->IGPU

Try Devices->Add Properties:
Device: IntelGFX Key: AAPL,GfxYTile Value: 0AAAAA00 Type: DATA

Graphics: Inject Intel + ig-platform-id : 0x59120003

Kexts:
IntelGraphicsFixup.kext
Lilu.kext
WhateverGreen.kext

Thank you so much, I had the same FCPX glitching issue,as well as performance degrade, and it drove me nuts. After followed your steps, it works. Only thing is I had to use -disablegfxfirmware upon booting, otherwise I would have a long booting time, a -v boot shows it has "Hash data from ME never returned, status = 1, doing retry #" error after I enabled iGPU.
 
Joined
Dec 18, 2017
Messages
5
Motherboard
ROG STRIX Z370-F GAMING
CPU
i7-8700K
Graphics
Sapphire RX 580 PULSE 8GB
Hi,

I recently done my first hackintosh project using Sapphire Pulse RX580.

System works fine, not tested with any applications.
I am using this machine for photo and video editing (PS + FCP X)

I will be testing FCPX in this system next week, any advice ?

Thank`s in advance
Happy New Year`s Eve
 
Status
Not open for further replies.
Top