Contribute
Register

Solved > RX 560 very high fan speed after wake from sleep on 10.14.4 (solved by 10.14.5 beta 2)

Joined
May 11, 2014
Messages
88
Motherboard
ASUS ROG STRIX Z370-G Gaming (WIFI-AC)
CPU
Intel i5-8600K
Graphics
Radeon RX580 8G - 1920x1200
Mac
MacBook Pro, Mac mini
Mobile Phone
Android, iOS
I can't get my MSI RX 560 LP to do anything lower than 2800rpm.

It boots into Mojave there and stays there unless really taxed and then it will ramp higher.

Super frustrating
Is that new after 10.14.4 update?
 
Joined
Jan 4, 2015
Messages
167
Motherboard
GA Z97X-UD3H
CPU
i7 4790
Graphics
RX 580
At least mine (MSI Aero RX560) stays in the 1300RPM. Should be noisy with 2800RPM!
 
Joined
Nov 12, 2012
Messages
8
Motherboard
Gigabyte EP45-DS3L
CPU
C2Q Q9500
Graphics
GeForce 650 Ti
Same here, RX560, fan kicks in all the time, was completely silence before 10.14.4.

Edit: Seems to be fixed in latest beta indeed.
 
Last edited:
Joined
Feb 8, 2017
Messages
20
Motherboard
ASRock X99E-ITX Micro ITX
CPU
i7-5820K
Graphics
RX 570
I believe the issue is macos runs the card at a constant higher frequency. My card (Shapphire RX570 itx) does 300-1240 mhz, but I havent seen it go below 700mhz in macos idling.

Can everybody run this command to check if their card idles at the minimum frequency/power?

ioreg -l |grep \"PerformanceStatistics\" | cut -d '{' -f 2 | tr '|' ',' | tr -d '}' | tr ',' '\n'|grep 'Temp\|Fan\|Power\|Clock\|Utilization'

Code:
$ ioreg -l |grep \"PerformanceStatistics\" | cut -d '{' -f 2 | tr '|' ',' | tr -d '}' | tr ',' '\n'|grep 'Temp\|Fan\|Power\|Clock\|Utilization'
"Device Utilization %"=4
"Fan Speed(%)"=0
"Core Clock(MHz)"=733
"Memory Clock(MHz)"=1000
"Fan Speed(RPM)"=0
"Temperature(C)"=52
"Total Power(W)"=61
$ ioreg -l |grep \"PerformanceStatistics\" | cut -d '{' -f 2 | tr '|' ',' | tr -d '}' | tr ',' '\n'|grep 'Temp\|Fan\|Power\|Clock\|Utilization'
"Device Utilization %"=20
"Fan Speed(%)"=0
"Core Clock(MHz)"=1144
"Memory Clock(MHz)"=1500
"Fan Speed(RPM)"=0
"Temperature(C)"=53
"Total Power(W)"=75
 
Joined
Jan 4, 2015
Messages
167
Motherboard
GA Z97X-UD3H
CPU
i7 4790
Graphics
RX 580
EDIT: macOS 10.14.5 beta 2 (18F108f) fixed the fan speed issue after wakeup from sleep, it is confirmed with Sapphire RX 470 Nitro 4GB.
Unfortunately for me, replacing the kexts with the ones from 10.14.5 beta 2 gives some purple lines on the boot screen. However, it solves the fan bug...

Will try a clone of 10.14.4 updated to the latest beta...
 
Joined
Oct 26, 2013
Messages
937
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
I believe the issue is macos runs the card at a constant higher frequency. My card (Shapphire RX570 itx) does 300-1240 mhz, but I havent seen it go below 700mhz in macos idling.

Can everybody run this command to check if their card idles at the minimum frequency/power?

ioreg -l |grep \"PerformanceStatistics\" | cut -d '{' -f 2 | tr '|' ',' | tr -d '}' | tr ',' '\n'|grep 'Temp\|Fan\|Power\|Clock\|Utilization'

Code:
$ ioreg -l |grep \"PerformanceStatistics\" | cut -d '{' -f 2 | tr '|' ',' | tr -d '}' | tr ',' '\n'|grep 'Temp\|Fan\|Power\|Clock\|Utilization'
"Device Utilization %"=4
"Fan Speed(%)"=0
"Core Clock(MHz)"=733
"Memory Clock(MHz)"=1000
"Fan Speed(RPM)"=0
"Temperature(C)"=52
"Total Power(W)"=61
$ ioreg -l |grep \"PerformanceStatistics\" | cut -d '{' -f 2 | tr '|' ',' | tr -d '}' | tr ',' '\n'|grep 'Temp\|Fan\|Power\|Clock\|Utilization'
"Device Utilization %"=20
"Fan Speed(%)"=0
"Core Clock(MHz)"=1144
"Memory Clock(MHz)"=1500
"Fan Speed(RPM)"=0
"Temperature(C)"=53
"Total Power(W)"=75
Same card Shapphire RX570 itx on 10.14.5 beta 2
401048
 
Joined
Feb 8, 2017
Messages
20
Motherboard
ASRock X99E-ITX Micro ITX
CPU
i7-5820K
Graphics
RX 570
Same card Shapphire RX570 itx on 10.14.5 beta 2
View attachment 401048
I've installed 1.14.5 beta 2 and my clock speeds still definitely dont go below 1000mhz. Would you mind sharing with me your EFI folder? I'm sure it must be a config issue. For starters I'm using the MacPro6,1 SMBIOS while you seem to be using the iMacPro1,1

EDIT: Also, does your card go up to 55 degrees while idling with the fan off, and then turns on the fan until temp reaches 45, again and again?
 
Last edited:
Top