Contribute
Register

Solved > RX 560 very high fan speed after wake from sleep on 10.14.4 (solved by 10.14.5 beta 2)

Joined
Nov 3, 2018
Messages
305
Motherboard
ASRock B360-HDV
CPU
i5-8400
Graphics
RX 470
Mobile Phone
iOS
So, this issue never happened before 10.14.4, I have RX 560, Z77, 1230 v2 and 16GB RAM, I installed 10.14.4 for GPU video decode and encode, both of which worked great with iMacPro 1,1 SMBIOS, but it brings anther issue that after wake from sleep, if i try to use the GPU very hard, such as playing multiple streaming video in adobe flash format, the GPU fan could go to 2500 RPM and up, making a lot of noise. this only happens on 10.14.4 and only after wake from sleep. so i tried to locate the issue via log. here is what i found:

1. first sleep the computer and wake by clicking mouse, check the log, system wake up at 2019-02-21 05:43:41
Code:
log show --last 4m | grep -i -E "wake reason"
2019-02-21 05:43:34.896762+0800 0x241 Default 0x0 56 0 powerd: [powerd:sleepWake] Wake reason: "<private>" identity: "<private>"​
2019-02-21 05:43:41.410698+0800 0x74 Default 0x0 0 0 kernel: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: GLAN EH02 EH01​
2019-02-21 05:43:41.410709+0800 0x74 Default 0x0 0 0 kernel: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: GLAN EH02 EH01​
2. check gpu related log:

Code:
log show --last 4m | grep -i -E "amd|radeon|gfx0"
2019-02-21 05:43:47.049909+0800 0x5f5 Default 0x0 0 0 kernel: (AMDFramebuffer) CRITICAL ERROR : VUPDATE interrupt has not been generated in time!​

as you can see there is an error massage: kernel: (AMDFramebuffer) CRITICAL ERROR : VUPDATE interrupt has not been generated in time!

tried to google around, but nothing helps.

any idea?

EDIT: this issue still exists on 10.14.5 beta1 and beta 2. Workaround cable method solved this issue perfectly. see post #10 and #37.

EDIT: macOS 10.14.5 beta 2 (18F108f) fixed the fan speed issue after wakeup from sleep, it is confirmed with Sapphire RX 470 Nitro 4GB.
 
Last edited:
Joined
Nov 3, 2018
Messages
305
Motherboard
ASRock B360-HDV
CPU
i5-8400
Graphics
RX 470
Mobile Phone
iOS
more logs doing sleep and wake up:

Code:
2019-02-21 13:11:00.861709+0800 0x253      Default     0x0                  0      0    kernel: (IOSurface) IOSurfaceRootUserClient::set_gpu_policy_dict prop: <private>
2019-02-21 13:11:00.863808+0800 0x253      Default     0x0                  92     0    loginwindow: (Metal) apply_selection_policy_once: avoid use of removable GPUs (via com.apple.loginwindow:GPUSelectionPolicy->avoidRemovable)
2019-02-21 13:11:01.498144+0800 0x58c      Default     0x0                  0      0    kernel: (AMDFramebuffer) --> IOP: FB:0 has been busy for 121 cycles with 0x51 transactions, busy? 1.
2019-02-21 13:11:29.046067+0800 0x58c      Default     0x0                  0      0    kernel: (AMDFramebuffer) CRITICAL ERROR : VUPDATE interrupt has not been generated in time!
 
Joined
Nov 3, 2018
Messages
305
Motherboard
ASRock B360-HDV
CPU
i5-8400
Graphics
RX 470
Mobile Phone
iOS
it turns out that my vbios has a max rpm of 3300, this is mad, even RX 580 8GB gets only max rpm 2280.

is there a way to modify this max rpm without breaking the UEFI GOP of the rom? tried Polaris BIOS Editor, that one can do the job but it needs CSM to be enabled.

Code:
$ ./atitool-mac-amd64  show Sapphire.RX560D.4096.170929.rom
----------------------------------------
ROM
----------------------------------------
VendorID: 0x5249
DeviceID: 0x1002
SubID: 0xe348
SubVendorID: 0x1da2
Firmware signature: 0x4d4f5441
HIT!!!!: �

----------------------------------------
Powerplay
----------------------------------------
Max GPU freq (Mhz): 1800
Max memory freq (Mhz): 2000
Power control limit (%%): 75

----------------------------------------
Powertune
----------------------------------------
TDP (W): 46
TDC (A): 52
Max Power Limit (W): 48
Max Temp. (C): 85
Shutdown Temp. (C): 94
Hotspot Temp. (C): 105

----------------------------------------
Fan
----------------------------------------
Temp. Hysteresis: 3
Min Temp. (C): 40
Med Temp. (C): 65
High Temp. (C): 85
Max Temp. (C): 109
Legacy or Fuzzy Fan Mode: 1
Min PWM (%): 20
Med PWM (%): 40
High PWM (%): 60
Max PWM (%): 1
Max RPM: 3300
Sensitivity: 4836
Acoustic Limit (MHz): 1226

----------------------------------------
GPU
----------------------------------------
214 mV: 715 Mhz
387 mV: 65282 Mhz
843 mV: 65283 Mhz
995 mV: 65284 Mhz
1062 mV: 65285 Mhz
1108 mV: 65286 Mhz
1149 mV: 65287 Mhz
1226 mV: 65288 Mhz

----------------------------------------
VRAM
----------------------------------------
Part num: MT51J256M3
VendorID: 0xf
Size (MB): 4096
Density: 0x63
Type: GDDR5
 
Joined
Nov 3, 2018
Messages
305
Motherboard
ASRock B360-HDV
CPU
i5-8400
Graphics
RX 470
Mobile Phone
iOS
I found that on macOS 10.14.4 the AGPM has changed, that's the reason why i got this high fan speed problem, found a app to generate correct AGPM kext, problem solved perfectly. thank god!

Code:
https://github.com/Pavo-IM/AGPMInjector
 
Joined
May 25, 2013
Messages
7
Motherboard
Aorus Z370 Gaming 5
CPU
i7-8700K
Graphics
RX 580
Hi, I have the same problem, but unfortunately that AGPMInjector doesn’t solves the issue, which is very annoying. Could you upload your efi folder?
 
Joined
Nov 3, 2018
Messages
305
Motherboard
ASRock B360-HDV
CPU
i5-8400
Graphics
RX 470
Mobile Phone
iOS
Hi, I have the same problem, but unfortunately that AGPMInjector doesn’t solves the issue, which is very annoying. Could you upload your efi folder?

In deed, that kext only make it a little bit better, it does not fix this problem. I’ve already switched to RX 470, it has 2 cooling tube, 2200rpm max fan speed, thought wake from sleep sometimes can get 1500rpm fan speed but the temp lowers down much quicker, several seconds the fan goes to 0 rpm. Rx 470/570/480/580 has fan stop feature as long as the temp of gpu goes below 50c. much better,
 
Last edited:
Joined
May 25, 2013
Messages
7
Motherboard
Aorus Z370 Gaming 5
CPU
i7-8700K
Graphics
RX 580
With 10.14.3 the computer was so silent... now with every page scroll I hear the fans. Sad.
 

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
2,177
Motherboard
Gigabyte Z370M D3H
CPU
i3-8350K
Graphics
RX 560
Mac
iMac, Mac mini
Classic Mac
eMac, iBook
Mobile Phone
iOS
Most Gigabyte motherboards suffered from this problem before a certain BIOS. One check you can easily make is to flash with the latest. For the older motherboards this might or might not be a solution. For me this occurred around BIOS F4 to F5.

I do not have any new GPU problems with the 10.14.4 update. All works fine, as before.

:)
 
Last edited:
Joined
Nov 3, 2018
Messages
305
Motherboard
ASRock B360-HDV
CPU
i5-8400
Graphics
RX 470
Mobile Phone
iOS
Most Gigabyte motherboards suffered from this problem before a certain BIOS. One check you can easily make is to flash with the latest. For the older motherboards this might or might not be a solution. For me this occurred around BIOS F4 to F5.

:thumbup:
I'm now using Asrock B360M-HDV, still the same problem even on RX 470. but RX 470 has much batter cooling and the default max fan speed settings in the vbios rom is only 2200rpm, there is only a few seconds of high fan speed (around 1500rpm) while scrolling web pages. it is OKAY i think.

This is absolutely a macOS problem.

there is work around way to this issue: buy a Sys_Fan to GPU_Fan cable, connect the GPU Fan to Sys_Fan connector on your motherboard, set the motherboard to use PWM to control the gpu fan, this way the GPU will be always cool, most of the time, it will be less than 35c
 
Joined
Nov 3, 2018
Messages
305
Motherboard
ASRock B360-HDV
CPU
i5-8400
Graphics
RX 470
Mobile Phone
iOS
like for example, i just connected my RX 470's fan connector to Chassis Fan 2, with "4pin GPU Fan to SYS_FAN Cable" and then i customize the fan speed as attached, monitor source will be motherboard, now when it is cool (below 34.99˚) in my room (or inside the case), the GPU fan will always be 15% which is around 820 RPM. with these settings, the GPU temperature will always be around 35˚ to 40˚ (get higher while encoding video, cools down after job done), and there is no noise no matter when (normal boot or wake from sleep), since the GPU's fan is now not controlled by the GPU vBIOS, instead, it is controlled by motherboard.

This method works so well that i will not bother anymore, always quiet!
 

Attachments

Top