Running Hackintosh with BIOS on RAID (XHD) mode

Discussion in 'Mountain Lion Desktop Support' started by Alejandro00, Dec 9, 2012.

  1. Alejandro00

    Alejandro00

    Joined:
    Dec 1, 2012
    Messages:
    6
    Mobo:
    GA-Z68M-D2H F6
    CPU:
    i7-3770k
    Graphics:
    GTX 660 Ti
    Classic Mac:
    iMac
    Mobile Phone:
    Android
    Dec 9, 2012 at 7:03 PM #1
    Alejandro00

    Alejandro00

    Joined:
    Dec 1, 2012
    Messages:
    6
    Mobo:
    GA-Z68M-D2H F6
    CPU:
    i7-3770k
    Graphics:
    GTX 660 Ti
    Classic Mac:
    iMac
    Mobile Phone:
    Android
    Hi Forum!

    For easy reading, let's just go straight to the point:

    I'm trying to run Windows 8 Pro on a RAID 0 and Mountain Lion on a 3rd drive.
    I can boot Windows if I change BIOS to RAID (XHD) mode (It's a z68 gigabyte motherboard; GA-z68M-D2H F6) and can run Hackintosh if set to AHCI.
    So, both OS are installed and working, but I can't figure out how to run Hackintosh in RAID (XHD) mode instead of AHCI.

    I found this: http://legacy.tonymacx86.com/viewtopic.php?f=7&t=2311

    It didn't help and actually my problem is Hackintosh not booting, Windows works just fine on RAID mode.

    I will take a screenshot of how I configured multibeast later, maybe that helps... (I'm on Windows right now)

    Thanks for your help and let me please say that this forum is great! It's incredible how much support from users to users there is.
    Greetings from Chile!
     
  2. Going Bald

    Going Bald Moderator

    Joined:
    Aug 14, 2010
    Messages:
    20,122
    Mobo:
    GA-X58A-UD7 Rev.1 BIOS F7
    CPU:
    i7-920
    Graphics:
    Sapphire HD5770
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    iMac
    Dec 9, 2012 at 10:10 PM #2
    Going Bald

    Going Bald Moderator

    Joined:
    Aug 14, 2010
    Messages:
    20,122
    Mobo:
    GA-X58A-UD7 Rev.1 BIOS F7
    CPU:
    i7-920
    Graphics:
    Sapphire HD5770
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    iMac
    You will never get this to work using the mainboard ports. The ONLY way to have Windows on RAID dual booting with OS X without having to boot to BIOS and change it every time you change OS is to use a RAID controller card for the Windows drives - assuming you want OS X to see the Windows RAID. And OS X will not "see" the RAID array. It will "see" individual drives if you use the mainboard SATA ports.
     
  3. Alejandro00

    Alejandro00

    Joined:
    Dec 1, 2012
    Messages:
    6
    Mobo:
    GA-Z68M-D2H F6
    CPU:
    i7-3770k
    Graphics:
    GTX 660 Ti
    Classic Mac:
    iMac
    Mobile Phone:
    Android
    Dec 9, 2012 at 10:28 PM #3
    Alejandro00

    Alejandro00

    Joined:
    Dec 1, 2012
    Messages:
    6
    Mobo:
    GA-Z68M-D2H F6
    CPU:
    i7-3770k
    Graphics:
    GTX 660 Ti
    Classic Mac:
    iMac
    Mobile Phone:
    Android
    Running Hackintosh with BIOS on RAID mode

    Oh, I see. Thanks for your help, is there a specific Raid controller you recommend maybe?

    For now I guess I will just leave it as it is, as I usually use Windows more than MAC OS.

    Greetings!
     
  4. Alejandro00

    Alejandro00

    Joined:
    Dec 1, 2012
    Messages:
    6
    Mobo:
    GA-Z68M-D2H F6
    CPU:
    i7-3770k
    Graphics:
    GTX 660 Ti
    Classic Mac:
    iMac
    Mobile Phone:
    Android
    Dec 9, 2012 at 10:47 PM #4
    Alejandro00

    Alejandro00

    Joined:
    Dec 1, 2012
    Messages:
    6
    Mobo:
    GA-Z68M-D2H F6
    CPU:
    i7-3770k
    Graphics:
    GTX 660 Ti
    Classic Mac:
    iMac
    Mobile Phone:
    Android
    I have been reading about configuring RAID 0 for Windows with BIOS set to AHCI (With Software, as in MAC OS). It says it has some "punishment" on the CPU, but as I have a i7-3770K I don't think that should be a problem. That would theoretically work!

    I will be trying it next week as I don't have more time now, will be posting updates though.
     
  5. Alejandro00

    Alejandro00

    Joined:
    Dec 1, 2012
    Messages:
    6
    Mobo:
    GA-Z68M-D2H F6
    CPU:
    i7-3770k
    Graphics:
    GTX 660 Ti
    Classic Mac:
    iMac
    Mobile Phone:
    Android
    Dec 9, 2012 at 11:11 PM #5
    Alejandro00

    Alejandro00

    Joined:
    Dec 1, 2012
    Messages:
    6
    Mobo:
    GA-Z68M-D2H F6
    CPU:
    i7-3770k
    Graphics:
    GTX 660 Ti
    Classic Mac:
    iMac
    Mobile Phone:
    Android

Share This Page