Contribute
Register

[ROUGH GUIDE] Fix for Finder Preview not working on Mojave 10.14.1+

Joined
Jul 9, 2013
Messages
2
Motherboard
Asus B85M-E/BR
CPU
i3 > See Rules
Graphics
RX 560
Mobile Phone
  1. Android
Thanks a lot! It worked great on my hack Mojave 10.14.6. It was missing to be complete. :)
 
Joined
Feb 28, 2011
Messages
6
Motherboard
Gigabyte Z77X-UD5H
CPU
i7-3770K
Graphics
HD 4000 + HD 5670
Mobile Phone
  1. Android
Thanks! worked for me too after a lot of search :)
 
Joined
Sep 14, 2012
Messages
10
Motherboard
Gigabyte Aorus Xtreme
CPU
i9-9900k
Graphics
Vega 56
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
I finally decided to bite the bullet and replaced my nVidia card for an AMD so I could upgrade to Mojave. The upgrade went smoothly, but I quickly ran into the "Preview not working" problem. Your fix worked perfectly. Everything is working again. Thank you.
 
Joined
Oct 26, 2016
Messages
6
Motherboard
ASUS Z170M-PLUS - Intel Z170
CPU
i5-6600K Skylake
Graphics
RX 570
Mac
  1. iMac
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Worked for me tooo :) Thank you very much!!!
 
Joined
Sep 4, 2016
Messages
10
Motherboard
Gigabyte Z170MX Gaming 5
CPU
Intel i5 6600K
Graphics
AMD RX 480
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
This also worked for me. What I did was try to change definitions, following other solutions on YouTube Their approaches were seemingly innocuous; safe and easy. Dabbling with lines of code always scares me. So, I had a bunch of Board IDs there. Wasted half a day following those.

What I did was to delete everything, all Board IDs.

Thanks, man. Back with a stable and reliable build.
 
Joined
Feb 13, 2013
Messages
48
Motherboard
MS-7752
CPU
i7
Graphics
GTX 770
Mac
  1. iMac
  2. MacBook
Mobile Phone
  1. Android
I don't have a Board ID in my SMBIOS information. What's the best approach to resolve? The Product Model is showing as iMac14,2. Everything apart from preview is working.
 
Joined
Aug 28, 2016
Messages
133
Motherboard
Gigabyte Z390 Gaming SLI
CPU
i7-8700
Graphics
Vega 56
Mobile Phone
  1. Android
  2. iOS
I have the same situation but I've found 3 of them,

The first at line 86:

<key>Mac-27ADBB7B4CEE8E61</key>
<dict>
<key>forceOfflineRenderer</key>
<true/>
<key>jpeg</key>
<true/>
</dict>

But there are other 2 at the end. Around line 299

<key>Mac-FA842E06C61E91C5</key>
<dict>
<key>forceOfflineRenderer</key>
<true/>
<key>jpeg</key>
<true/>
</dict>
<key>Mac-FC02E91DDD3FA6A4</key>
<dict>
<key>forceOfflineRenderer</key>
<true/>
</dict>

I've oppened it with BBEdit (downloaded directly from the website) and if I want to save the file, I get this error:

"You do not have sufficient privileges to perform this operation (macOS error code: -5000)."

Any Idea?
 

Attachments

  • Info.plist
    5.9 KB · Views: 74
Joined
Dec 22, 2018
Messages
14
Motherboard
ASUS ROG STRIX Z390-F Gaming
CPU
i7-8700
Graphics
RX 580
Mac
  1. MacBook Air
  2. Mac mini
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Dude, that is an epic simple solution to a freaky weird problem.
I am using almost no clover modifs, and selected imac 18.3 figured out the BoardId and just changed the true to false saved the file rebooted and tadaaa all my previews work again.
 
Top