Contribute
Register

Restart instead of shutdown (sometimes)

Joined
Jan 14, 2016
Messages
7
Motherboard
Asus H97M-E
CPU
i7 4790
Graphics
HD 4600
Mac
  1. iMac
Mobile Phone
  1. Android

Attachments

  • Hany’s iMac.ioreg
    2.5 MB · Views: 37
Joined
Nov 17, 2016
Messages
4
I was having this issue as well with Sierra 10.12.1. I saw a suggestion in another thread to add darkwake=0 to fix the "display doesn't wake up from sleep" issue, but it ended up fixing the shutdown -> immediate restart issue as well. The only thing I changed was adding darkwave=0 to my config.plist.
 
Joined
Jan 14, 2016
Messages
7
Motherboard
Asus H97M-E
CPU
i7 4790
Graphics
HD 4600
Mac
  1. iMac
Mobile Phone
  1. Android
I was having this issue as well with Sierra 10.12.1. I saw a suggestion in another thread to add darkwake=0 to fix the "display doesn't wake up from sleep" issue, but it ended up fixing the shutdown -> immediate restart issue as well. The only thing I changed was adding darkwave=0 to my config.plist.
Hey dude,
Thanks for your comments, where did you add it? in config.plist in boot in custom flags?
 
Joined
Nov 17, 2016
Messages
4
I used clover configurator to do it, but it looks like what it did was add the flag here in config.plist:

<key>Boot</key>
<dict>
<key>Arguments</key>
<string>dart=0 darkwake=0</string>
<key>Debug</key>
<false/>
<key>DefaultVolume</key>
<string>Sierra</string>
<key>Legacy</key>
<string>PBR</string>
<key>Secure</key>
<false/>
<key>Timeout</key>
<integer>3</integer>
<key>XMPDetection</key>
<false/>
</dict>
 
Joined
Jan 14, 2016
Messages
7
Motherboard
Asus H97M-E
CPU
i7 4790
Graphics
HD 4600
Mac
  1. iMac
Mobile Phone
  1. Android
I used clover configurator to do it, but it looks like what it did was add the flag here in config.plist:

<key>Boot</key>
<dict>
<key>Arguments</key>
<string>dart=0 darkwake=0</string>
<key>Debug</key>
<false/>
<key>DefaultVolume</key>
<string>Sierra</string>
<key>Legacy</key>
<string>PBR</string>
<key>Secure</key>
<false/>
<key>Timeout</key>
<integer>3</integer>
<key>XMPDetection</key>
<false/>
</dict>
I added, but still have the issue. The problem is some times the computer restarts after shutdown not always. Also it seems the shutdown time takes long.
 
Joined
Jan 14, 2016
Messages
7
Motherboard
Asus H97M-E
CPU
i7 4790
Graphics
HD 4600
Mac
  1. iMac
Mobile Phone
  1. Android
it seems issue is gone by updating clover to the latest.
:headbang::D
 
Top