Contribute
Register

[REPORT] issue with clover 4586 - MacOS 10.13.5

Status
Not open for further replies.
Joined
Sep 12, 2011
Messages
4
Motherboard
Gigabyte Z370N WIFI
CPU
Intel Core I5 8400
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. Android
  2. iOS
@ukulele01 you saved my bacon! I was in a nightmare of black screens and failed boots, and your fix got me through the High Sierra install. You are the hero of the hour. Now however I'm not sure what I should do about a more permanent fix.

I used OsxAptioFix2Drv-64.EFI because I was leapfrogging from El Cap directly to HS. It worked! However, I'm now very confused by all the high-level expert discussions about the various versions of AptioMemoryFix. There are scary warnings about BIOS compatibility and all kinds of other jargon that goes right over my head. So I'm really not sure whether to just stick with Fix2 which is working for me, or whether I should dread some kind of NVRAM disaster if I stick with it; it seems like I should install the "most popular" AptioMemoryFix.efi but dunno if the dire warnings apply to me...

My mobo is an Asus Maximus GENE VIII. I have an NVIDIA GTX970. What should I do, stick twist or bust?

You really should update to the new versions! Why? Because clover changed its driver names. When you next update clover you run into the same issue. Worse you have two drivers in your clover drivers64UEFI directory.
When you followed my post what can go wrong? You are able to handle problems now with clover itself...
When you are on MacOS start a terminal.
Code:
diskutil list

Now you should see a list of all partitions. Guess your EFI partition is on disk0s1.
Code:
sudo diskutil mount disk0s1

Now you should see the EFI partition in your finder. Check the EFI/CLOVER/drivers64UEFI Directory.
You can also do a backup of whatever you want to backup.

Update Clover again and have a look at the drivers during install.
After update look again at EFI/CLOVER/drivers64UEFI Directory. Delete the old OsxAptioFix2Drv-64.EFI and check that the new AptioMemoryFix-64.efi is present.

Now reboot and enjoy...

Note
I have no experience with NVIDIA cards and what could happen with their web drivers.
 
Joined
Aug 31, 2016
Messages
194
Motherboard
Asus MAXIMUS XI HERO
CPU
i7-8700K
Graphics
RX5700 XT
Mac
  1. iMac
Classic Mac
  1. iMac
Mobile Phone
  1. Android
OK.... I mount my EFI partition with EFI Mounter... and then I run Clover Configurator (recent version) and I choose "Install/Update Clover" and it checks version numbers and tells me that my version is up to date! It does nothing else. No drivers get updated.

However I do see another page for installing individual drivers, with 2 columns of buttons; and here there is a button for AptioMemoryFix -- so I tried installing it. Got a success message. Googled a little further and saw that AptioInputFix was also recommended, so I selected that one also. Success.

So just "update Clover" did not do the trick for me, I had to select these drivers manually. Now about to try a reboot (yikes)... [time goes by] ... well, I still boot OK so all is well. Thanks ukulele01.
 
Joined
Oct 26, 2015
Messages
5
Motherboard
I still didn't read
CPU
the RULES
Graphics
so ignore me
I ran into the same issue by not changing options in clover install. Normally all is ok but with this version clover seems to change one efi file and does not replace with new one. Like @Lundli mentioned, it's the AptioMemoryFix you have to choose. I forgot that and I couldn't boot from any of my USB sticks or anything else. Boot stops at End Randomseed++++.

Here's a solution how to fix it:

1. Press an arrow key when clover comes up so you stop counting down to boot mac os.
2. Choose Clover Shell and hit Enter.
3. Now you should see some FSX: drives (use PgUp/PgDown to view).
4. You can mount a drive with map FSX (where X is the number of the drive you want to mount)
5. Step by step mount the drives. You can go to a drive by typing e.g. FS0:
To change a directory use cd [dir]
List files with ls and use command help to show all commands.
6. One drive should be the EFI drive and one drive with your macos install. Clover does a backup before install (thanks god :)) in the root folder of your macos partition.
7. So go to the backup folder in CLOVER\drivers64UEFI\ and copy the file OsxAptioFix3Drv-64.efi to the same directory in your EFI drive with command cp src dst (src=path to OsxAptioFix3Drv-64.efi; dst=path to destination directory on EFI drive).
8. After that type exit.
9. YOU MUST REBOOT NOW!
10. Now all is fine and be careful at next clover install... like me :banghead:;)

Hope this helps someone...

Update
After that procedure and you install clover 4586 again (with AptioMemoryFix-64 enabled!) or next update check out your EFI drive. When you see AptioMemoryFix-64.efi just delete the old OsxAptioFix3Drv-64.efi
You should do that before reboot!

Update 2
When you install clover 4586 again (or later updates) you should also enable ApfsDriverLoader-64. After that delete apfs.efi in ..\drivers64UEFI folder on your EFI partition. Also check for new AptioInputFix-64 or others you enabled. After install You should always have a look at your efi folder before reboot and check for older versions.
This guide is only to fix boot and get back to mac os.
(Thanks to @MysticalOS and @remanifest for pointing this out)


both shift keys not working to type colon symbol : in FS0: don't know why and this is not hardware problem :( :(
 
Joined
Jan 24, 2016
Messages
96
Motherboard
z170i
CPU
6700K
Graphics
Radeon 580
Mac
  1. MacBook Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
both shift keys not working to type colon symbol : in FS0: don't know why and this is not hardware problem :( :(

I had the same exact issue with the shift keys. Tried multiple USB keyboards to no avail. Luckily I have a SATA to usb cable and just pulled the drive and plugged it into my laptop and moved the missing file to the EFI partition.

Thank you ukulele01 for the fix!
 
Joined
Mar 8, 2016
Messages
29
Motherboard
Gigabyte GA-Z97-HD3
CPU
Core i5-4460
Graphics
EVGA GeForce GTX 960 SC
Mac
  1. Mac Pro
THANK YOU @ukulele01

You helped me fix my work computer / hackintosh! Really appreciate this forum! :thumbup:
 
Joined
Sep 6, 2014
Messages
4
Mac
Classic Mac
Mobile Phone
This should be pinned. Saved my bacon :clap:

I ran into the same issue by not changing options in clover install. Normally all is ok but with this version clover seems to change one efi file and does not replace with new one. Like @Lundli mentioned, it's the AptioMemoryFix you have to choose. I forgot that and I couldn't boot from any of my USB sticks or anything else. Boot stops at End Randomseed++++.

Here's a solution how to fix it:

1. Press an arrow key when clover comes up so you stop counting down to boot mac os.
2. Choose Clover Shell and hit Enter.
3. Now you should see some FSX: drives (use PgUp/PgDown to view).
4. You can mount a drive with map FSX (where X is the number of the drive you want to mount)
5. Step by step mount the drives. You can go to a drive by typing e.g. FS0:
To change a directory use cd [dir]
List files with ls and use command help to show all commands.
6. One drive should be the EFI drive and one drive with your macos install. Clover does a backup before install (thanks god :)) in the root folder of your macos partition.
7. So go to the backup folder in CLOVER\drivers64UEFI\ and copy the file OsxAptioFix3Drv-64.efi to the same directory in your EFI drive with command cp src dst (src=path to OsxAptioFix3Drv-64.efi; dst=path to destination directory on EFI drive).
8. After that type exit.
9. YOU MUST REBOOT NOW!
10. Now all is fine and be careful at next clover install... like me :banghead:;)

Hope this helps someone...

Update
After that procedure and you install clover 4586 again (with AptioMemoryFix-64 enabled!) or next update check out your EFI drive. When you see AptioMemoryFix-64.efi just delete the old OsxAptioFix3Drv-64.efi
You should do that before reboot!

Update 2
When you install clover 4586 again (or later updates) you should also enable ApfsDriverLoader-64. After that delete apfs.efi in ..\drivers64UEFI folder on your EFI partition. Also check for new AptioInputFix-64 or others you enabled. After install You should always have a look at your efi folder before reboot and check for older versions.
This guide is only to fix boot and get back to mac os.
(Thanks to @MysticalOS and @remanifest for pointing this out)
 
Joined
Dec 6, 2016
Messages
8
Motherboard
GA-Z170X-UD3 Ultra
CPU
Intel Core i7 6700K 4.00 GHz
Graphics
GeForce GTX 980
I ran into the same issue by not changing options in clover install. Normally all is ok but with this version clover seems to change one efi file and does not replace with new one. Like @Lundli mentioned, it's the AptioMemoryFix you have to choose. I forgot that and I couldn't boot from any of my USB sticks or anything else. Boot stops at End Randomseed++++.

Here's a solution how to fix it:

1. Press an arrow key when clover comes up so you stop counting down to boot mac os.
2. Choose Clover Shell and hit Enter.
3. Now you should see some FSX: drives (use PgUp/PgDown to view).
4. You can mount a drive with map FSX (where X is the number of the drive you want to mount)
5. Step by step mount the drives. You can go to a drive by typing e.g. FS0:
To change a directory use cd [dir]
List files with ls and use command help to show all commands.
6. One drive should be the EFI drive and one drive with your macos install. Clover does a backup before install (thanks god :)) in the root folder of your macos partition.
7. So go to the backup folder in CLOVER\drivers64UEFI\ and copy the file OsxAptioFix3Drv-64.efi to the same directory in your EFI drive with command cp src dst (src=path to OsxAptioFix3Drv-64.efi; dst=path to destination directory on EFI drive).
8. After that type exit.
9. YOU MUST REBOOT NOW!
10. Now all is fine and be careful at next clover install... like me :banghead:;)

Hope this helps someone...

Update
After that procedure and you install clover 4586 again (with AptioMemoryFix-64 enabled!) or next update check out your EFI drive. When you see AptioMemoryFix-64.efi just delete the old OsxAptioFix3Drv-64.efi
You should do that before reboot!

Update 2
When you install clover 4586 again (or later updates) you should also enable ApfsDriverLoader-64. After that delete apfs.efi in ..\drivers64UEFI folder on your EFI partition. Also check for new AptioInputFix-64 or others you enabled. After install You should always have a look at your efi folder before reboot and check for older versions.
This guide is only to fix boot and get back to mac os.
(Thanks to @MysticalOS and @remanifest for pointing this out)

This was super helpful, thanks! One thing I missed was you have to go into the drives that you mount by typing "FS[X]:<Enter>" then you can find the files mentioned.
 
Joined
Feb 7, 2019
Messages
9
Motherboard
Prime z270-a
CPU
i7-6700k
Graphics
EVGA 1060
Mobile Phone
  1. iOS
I ran into the same issue by not changing options in clover install. Normally all is ok but with this version clover seems to change one efi file and does not replace with new one. Like @Lundli mentioned, it's the AptioMemoryFix you have to choose. I forgot that and I couldn't boot from any of my USB sticks or anything else. Boot stops at End Randomseed++++.

Here's a solution how to fix it:

  1. Press an arrow key when clover comes up so you stop counting down to boot mac os.
  2. Choose Clover Shell and hit Enter.
  3. Now you should see some FSX: drives (use PgUp/PgDown to view).
  4. You can mount a drive with map FSX (where X is the number of the drive you want to mount)
  5. Step by step mount the drives. You can go to a drive by typing e.g. FS0:
To change a directory use cd [dir]
List files with ls and use command help to show all commands.
  1. One drive should be the EFI drive and one drive with your macos install. Clover does a backup before install (thanks god :)) in the root folder of your macos partition.
  2. So go to the backup folder in CLOVER\drivers64UEFI\ and copy the file OsxAptioFix3Drv-64.efi to the same directory in your EFI drive with command cp src dst (src=path to OsxAptioFix3Drv-64.efi; dst=path to destination directory on EFI drive).
  3. After that type exit.
  4. YOU MUST REBOOT NOW!
  5. Now all is fine and be careful at next clover install... like me :banghead:;)

Hope this helps someone...

Update
After that procedure and you install clover 4586 again (with AptioMemoryFix-64 enabled!) or next update check out your EFI drive. When you see AptioMemoryFix-64.efi just delete the old OsxAptioFix3Drv-64.efi
You should do that before reboot!

Update 2
When you install clover 4586 again (or later updates) you should also enable ApfsDriverLoader-64. After that delete apfs.efi in ..\drivers64UEFI folder on your EFI partition. Also check for new AptioInputFix-64 or others you enabled. After install You should always have a look at your efi folder before reboot and check for older versions.
This guide is only to fix boot and get back to mac os.
(Thanks to @MysticalOS and @remanifest for pointing this out)


hello, I too have fallen victim to this update... I am caught up on step 6 as well. I can't get it to copy, i don't understand what to type specifically as the command, i can direct it and everything but am very confused... i've been working tirelessly trying to figure out the commands but alas, i am a noob. Any help that anyone would be able to give me would be incredible. I really appreciate it. Thank you.
 
Status
Not open for further replies.
Top