Contribute
Register

[Release] Hackintool v3.x.x

Joined
Mar 15, 2019
Messages
16
Motherboard
Gigabyte Designare Z390
CPU
i7-9700
Graphics
UHD 630
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. iOS
I am using Hackintool v2.1.8, and using CaseySJ's post at [GUIDE] General Framebuffer Patching Guide (HDMI Black Screen Problem), do I the following:

Framebuffer menu -> check macOS 10.13.6
Patch menu -> Apply Current Patches
Patch -> System Configs -> Gigabyte -> H370N WIFI [CFL]

Then in the Hackintool window, under Intel, I have checked the following:
In the Patch suntab, under General, the following are checked: Devices / Properties, Connectors, VRAM, Auto Detect Changes.

Under Advanced, the following are checked: Hotplug Reboot Fix, VRAM 2048 MB, Enable HDMI20 (4K), Device ID: 0x3E9B: Intel UHD Graphics 630

When I click the "Generator Patch" button, the only output I get is the following:

========
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Devices</key>
<dict>
<key>Properties</key>
<dict/>
</dict>
</dict>
</plist>
========

Shouldn't there be more than this?

Prana
 
Joined
Aug 31, 2018
Messages
1,446
Motherboard
Asus ROG Strix Z390 I-Gaming
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook
Classic Mac
  1. 512K
  2. iMac
Mobile Phone
  1. iOS
If you install 10.14.4 you don't need to inject your platform ID. I suggest you download my IGPU-EFI and copy it to a FAT32 formatted USB drive and then boot from it.

You would also need to remove any Hackintosh kexts you have in /library/extensions. If everything runs well, DELETE the old EFI folder on your drive and copy the one from the USB to it.

It will take you 15 minutes tops and your machine should run perfectly. Let me know how it works out!
 
Joined
Mar 15, 2019
Messages
16
Motherboard
Gigabyte Designare Z390
CPU
i7-9700
Graphics
UHD 630
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. iOS
If you install 10.14.4 you don't need to inject your platform ID. I suggest you download my IGPU-EFI and copy it to a FAT32 formatted USB drive and then boot from it.

You would also need to remove any Hackintosh kexts you have in /library/extensions. If everything runs well, DELETE the old EFI folder on your drive and copy the one from the USB to it.

It will take you 15 minutes tops and your machine should run perfectly. Let me know how it works out!

Thanks ModMike. I have been avoiding going to Mojave, as my 2011 Mac mini and MacBook are only running Sierra, and making the jump to High Sierra was a bit more than I wanted. But my H370N WIFI and CPU are newer than what was available in High Sierra, and I read that Mojave has native support of the UHD 630.

I have downloaded your IGUP-EFI.zip, and will start the long download (my internet is slow) of a Mojave. I have a feeling this may be the fastest way to go, but also I feel so close with High Sierra. The only things that doesn't work is my graphics only shows 7MB of RAM, plus I suppose I am not using accelerated graphics since I get flashing and Safari tabs leave mouse trails when I move the mouse over them.

Thanks for your help.
 
Joined
Aug 31, 2018
Messages
1,446
Motherboard
Asus ROG Strix Z390 I-Gaming
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook
Classic Mac
  1. 512K
  2. iMac
Mobile Phone
  1. iOS
@headkaze I am having one niggling problem. I ran the rename check and applied all the patches. There is one Hackintool can't seem to make stick, however. Any idea why?

396242


396243
v
 
Joined
Jun 20, 2014
Messages
1,017
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070
Shouldn't there be more than this?

Yes, there should be. I'm guessing the issue is with getting the IGPU PCI path. This can be a bit of a chicken-egg thing so what I've done in Hackintool v2.1.9 is use the generic Intel IGPU PCI path instead of failing if it can't find it. Hopefully this can help users who haven't got a working IGPU config yet.
 
Joined
Jun 20, 2014
Messages
1,017
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070
@headkaze I am having one niggling problem. I ran the rename check and applied all the patches. There is one Hackintool can't seem to make stick, however. Any idea why?
Is the rename being successfully added to your config.plist? If so it could be that PEGP is being renamed to GFX0. I don't think it will rename twice but I'm not sure?
 
Joined
Jun 20, 2014
Messages
1,017
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070
Hackintool v2.1.9 Released
- Added Github kext downloading. The download version may be older than the source version. Also due to Github API rate limits it will store the latest download urls.
- Added Install kext(s) function
- Added Rebuild KextCache and Repair Permissions function
- Buy me a Beer button added if you want to support my craft beer habit (and continued work on Hackintool) :)

HackintoolInstalled2.png
 
Last edited:
Top