Contribute
Register

[Release] Hackintool v2.8.6

Joined
Jun 20, 2014
Messages
978
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070 Max-Q / 4K
Ok so there's nothing in terminal after clicking "generating patch" in hackintool window that opened via terminal. Just the exact same stuff as when launched, no additions
Okay thanks for checking that. Is there a chance your IGPU has not been renamed from GFX0? When you look at Bootloader patches does it have a tick next to "Rename GFX0 to IGPU"?
 

Attachments

Joined
Jun 20, 2014
Messages
978
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070 Max-Q / 4K
I have lilu and whatevergreen installed. But having a tick means it's installed, no ?
No, it means it's not renamed. There are a few ways you can check it's renamed. Check your display in PCI tab and check WhateverGreen is installed under Installed tab.
 

Attachments

Joined
Dec 5, 2013
Messages
162
Motherboard
Z97X-UD5H
CPU
i5 4690
Graphics
GTX 760
Mac
MacBook, MacBook Pro
Mobile Phone
iOS
the display is not as yours, but whatevergreen is installed
412528


412529


And BTW, your screenshot has a ticked box also at gfx0 to igpu, but you told me mine is a mistake, why is that ? sorry for the dumb questions, I try really hard to understand :)
 
Last edited:
Joined
Jun 20, 2014
Messages
978
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070 Max-Q / 4K
the display is not as yours, but whatevergreen is installed
Your display has not been renamed to IGPU (note it's PEG0.GFX0 under IOReg Name). For some reason WhateverGreen has failed to rename it. Add the rename patch.

1. Go to Bootloader tab in Hackintool
2. Put a tick next to Rename GFX0 to IGPU
3. Click the Apply Patch button and select your Clover config.plist to apply the patch
4. Reboot and run Hackintool again to check it's been renamed in the PCI tab
 
Joined
Jun 20, 2014
Messages
978
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070 Max-Q / 4K
It's already ticked ! But done your steps
I just noticed the GFX0 entry is actually an nVidia card. Hackintool is designed to patch IGPU only. So you either disable the dGPU or use a headless platform id and use the nVidia card. Is your IGPU disabled in your BIOS? Unfortunately you won't be able to create a patch using Hackintool without an IGPU entry in your PCI list. This is beyond the scope of this thread so I would suggest starting a new one for this.
 
Last edited:
Top