Contribute
Register

[Release] Hackintool v2.8.0

Joined
Aug 2, 2013
Messages
91
Motherboard
Gigabyte Z97X-UD5H-BK
CPU
i7-4790K
Graphics
Nvidia Geforce GTX 980 TI 6GB
Mac
iMac, MacBook Air, Mac Pro
Mobile Phone
iOS
Joined
Jun 20, 2014
Messages
960
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070 Max-Q / 4K
Hackintool 2.5.4 Released
- Will now output mounting errors

Hackintool 2.5.5 Released
- Added ASRock DeskMini 310 system config
 
Last edited:
Joined
Nov 4, 2011
Messages
522
Motherboard
GA-Z170X-UD3 F23g
CPU
i7-6700K
Graphics
RX-580
Mac
iMac
This is not really the place to post this. Can you please start a thread?
Stability has finally returned. I accomplished that by generating a new patch, as attached, with a later version of Hackintool. Note that the patch in my config.plist file, included in an attachment of my #1058, differs from what I have generated with Hackintool v.2.5.5. The earlier patch dos not include a device-id entry.
Another problem I encounter is that upon completing a reboot, EFI.agent as well as the disk section of Hackintool, is duly populated, however some time later all entries just dissapear with seemingly only a reboot repopulating the respective output screens. Attachments refer.

Greetings
 

Attachments

Joined
Jun 20, 2014
Messages
960
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070 Max-Q / 4K
The earlier patch dos not include a device-id entry.
The "Spoof Video Device ID" patch option is under Advanced Options. Hackintool won't include the device-id unless you have this option enabled.
Another problem I encounter is that upon completing a reboot, EFI.agent as well as the disk section of Hackintool, is duly populated, however some time later all entries just dissapear with seemingly only a reboot repopulating the respective output screens.
Can you please run Hackintool from Terminal (run Hackintool.app/Contents/MacOS/Hackintool) and see if there is any error you can show me. The error is likely to occur when the disk list is not being populated.
 
Joined
Nov 4, 2011
Messages
522
Motherboard
GA-Z170X-UD3 F23g
CPU
i7-6700K
Graphics
RX-580
Mac
iMac
Can you please run Hackintool from Terminal (run Hackintool.app/Contents/MacOS/Hackintool)
Will do and let you know, just rebooted a minute or so ago with everything being fine at present, therefore have to wait until this happens again.

The "Spoof Video Device ID" patch option is under Advanced Options. Hackintool won't include the device-id unless you have this option enabled.
Thanks found it, on this version it is autoset with a tick, may very well not have been autoset on the earlier Hackintool version, hence the omission from the generated patch at that earlier stage. In all fairness I was also unable to relate that spoof choice to what it would actually accomplish when selected. Do know it now though. For me using this great tool comfortably and without configuration errors is presently not possible. Will still have to indulge in a lot of experimentation and reading before I am more comfortable using the tool.

Greetings
 
Joined
Jun 20, 2014
Messages
960
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070 Max-Q / 4K
Thanks found it, on this version it is autoset with a tick, may very well not have been autoset on the earlier Hackintool version, hence the omission from the generated patch at that earlier stage.
Actually it have never been set by default.
In all fairness I was also unable to relate that spoof choice to what it would actually accomplish when selected. Do know it now though.
Unfortunately there are no detailed instructions on the patching section of Hackintool and this is the most complicated and confusing part of the application. Hopefully I can get the time to improve this at some point.
For me using this great tool comfortably and without configuration errors is presently not possible. Will still have to indulge in a lot of experimentation and reading before I am more comfortable using the tool.
There are some guides that can help with Hackintool on the forum such as @jaymonkey's An iDiot's Guide To Lilu and its Plug-ins and @CaseySJ's General Framebuffer Patching Guide using Hackintool. Actually thanks for reminding me to add these to the first post.
 
Last edited:
Joined
May 19, 2019
Messages
5
Motherboard
Microsoft Surface Book 1-Clover
CPU
i5-6300U
Graphics
HD520, GeForce 940M, 3000x2000
Mac
MacBook Pro
Hi headkaze!

I'm experiencing a small burp and was hoping you could help me?

I successfully generate a DisplayEDID-3419-96a2.kext but when I try to update the kextcache with it I get the following error:

sudo kextcache -i /
Can't read info dictionary for /Library/Extensions/DisplayEDID-34a9-96a2.kext: IOCFUnserialize: syntax error near line 56

The line it is talking about is:
<key>target-default-ppmm</key>
<real>10.069930100000001</real>

More specifically it doesn't seem to like the <real> tag. When I change it to <string> it stops complaining. But doesn't work either.

I'm on the latest macOS Mojave 10.14.5.

Any help would be much appreciated!

All the best,
Chris
 
Top