Contribute
Register

Recovery HD partition with El Capitan

Joined
Feb 3, 2017
Messages
38
Motherboard
Gigabyte GA-Z170X-Ultra Gaming
CPU
Intel BX80662I56600K i5-6600K (Skylake) Quad-Core, 3.5
Graphics
Sapphire Vapor-X HD 7950 3G DDR5 SKU 11196-09-40G
Mac
  1. iMac
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Works perfectly on Sierra mobo ga z170x ultragaming. Wifi,eth,help. One question: could you help me fo find my Mac disable every boot?
Update. Find my mac works too, I don't lost in boot ... after bios upgrade.
 
Joined
Feb 3, 2017
Messages
38
Motherboard
Gigabyte GA-Z170X-Ultra Gaming
CPU
Intel BX80662I56600K i5-6600K (Skylake) Quad-Core, 3.5
Graphics
Sapphire Vapor-X HD 7950 3G DDR5 SKU 11196-09-40G
Mac
  1. iMac
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Works perfectly on Sierra mobo ga z170x ultragaming. Wifi,eth,help. One question: could you help me fo find my Mac disable every boot?
Solved view post #23
 
Joined
Apr 30, 2017
Messages
50
Motherboard
GA-H110N Rev 1.0 BIOS F20
CPU
Intel Core i3-6100
Graphics
Zotac NVIDIA GT 710 2MB
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
So.... I have a "Vanilla" install (i.e., no Mult/Unibeast) and all of .kext files are in the /EFI/Clover/kexts/other folder... I just tried to boot into recovery before doing anything and it worked fine. I'm assuming this is a side-effect of the vanilla install - and I can use it like normal?
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,492
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
I just tried to boot into recovery before doing anything and it worked fine. I'm assuming this is a side-effect of the vanilla install - and I can use it like normal?
Yes you can use it like normal :thumbup:
 
Joined
Mar 15, 2014
Messages
21
Motherboard
Z87E-WIFI
CPU
E3-1246v3
Graphics
GT 710 or RX 570
Classic Mac
  1. Performa
Mobile Phone
  1. Android
Finally! I had the same problem on El Capitan (yes, I'm upgrading now, but I wanted to have a complete El Cap system, including the recovery partition, on a USB key before moving on) and Sierra. Deleting and recreating the partition using that famous script did nothing for me. There should be a sticky somewhere about the necessity of copying the prelinkedkernel (which I guess is prelinked to FakeSMC etc) in order for the recovery partition to function. This information should not be as obscure as it is.
Note that even after this the El Cap partition has an image verification error; this does not appear to affect functionality though.
Anyway, thanks OP! This was the last piece of the puzzle.

ED: In case anybody else is having "launchd exited with code" 1 or 255 when trying to boot from Recovery HD, not having a prelinked kernel may be the issue. It was for me.
 
Last edited:
Joined
Nov 6, 2014
Messages
97
Motherboard
FoxConn AT-7330
CPU
i3-3227u
Graphics
HD4000
Mac
Classic Mac
Mobile Phone

Attachments

  • Recovery Mounter .zip
    32 KB · Views: 88
Joined
Oct 26, 2017
Messages
30
Motherboard
GA-Z270X-Ultra Gaming
CPU
i7-7700k
Graphics
RX580
Still works after all these years... works fine on 10.13.2 High Sierra. Tried diskutil and time machine, both appear to work.
 
Top