Contribute
Register

Reboot after waking up from deep sleep

Joined
Mar 2, 2011
Messages
211
Motherboard
GA-Z97X-Gaming 7
CPU
i7-4790K
Graphics
RX 580
Mobile Phone
  1. iOS
Same issue here

2016-11-19 08:58:47 +0100 Failure Darkwake Exit Failure during wake due to 0x34053000000032:
2016-11-25 09:38:55 +0100 Failure Drivers Failure during wake due to 0x04000027:
2016-11-26 10:17:09 +0100 Failure Drivers Failure during wake due to SAT0(AppleAHCI):
2016-11-27 13:01:14 +0100 Failure Drivers Failure during wake due to PEG0(),XHC(XHC),HDEF(),RP05(AppleAHCI),RP06(IOFireWireController),SAT0(AppleAHCI):
2016-11-29 10:41:45 +0100 Failure Drivers Failure during wake due to XHC(XHC),HDEF(),RP05(AppleAHCI),SAT0(AppleAHCI):
2016-12-01 19:43:31 +0100 Failure Drivers Failure during wake due to PEG0(),SAT0(AppleAHCI):

I'm not using DSDT or USB patches

My clover config

darkwake=no / dart=0 / kext_dev_mode=1 / BooterConfig 0x28 / CsrActiveConfig 0x3 / AppleHDA and AppleAHCIPort patches
 
Joined
May 9, 2011
Messages
5,889
Motherboard
GA-Z170X-Gaming 3
CPU
i7-6700
Graphics
Sapphire Pulse RX580 8G / Intel HD Graphics 530
Mac
  1. iMac
Mobile Phone
  1. iOS
Same issue here

I'm not using DSDT or USB patches

My clover config

darkwake=no / dart=0 / kext_dev_mode=1 / BooterConfig 0x28 / CsrActiveConfig 0x3 / AppleHDA and AppleAHCIPort patches

Hi Snowy,

Post your config.plist as a file here.

Please share output of below command

Code:
pmset -g

Then run below command on terminal and as soon as the command executed please put your OS X into sleep.

Code:
logger plec

After the system rebooted while trying for wake up, open terminal and enter below command,

Code:
cp /var/log/system.log ~/Desktop/system.log

Then attach system.log file from your Desktop to here.
 
Joined
Jun 9, 2013
Messages
10,809
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
Same issue here



I'm not using DSDT or USB patches

My clover config

darkwake=no / dart=0 / kext_dev_mode=1 / BooterConfig 0x28 / CsrActiveConfig 0x3 / AppleHDA and AppleAHCIPort patches

ACPI needs patching. XHC requires either a DSDT patch or a SSDT patch. HDEF patch is required. SAT0 needs to be renamed to SATA. Take a look at the config on my Github for SATA patch. https://github.com/VoiletDragon/Z-H97N-WIFI-Patches Attach ioreg [Guide] How to Make a Copy of IOReg | tonymacx86.com
 
Joined
Mar 2, 2011
Messages
211
Motherboard
GA-Z97X-Gaming 7
CPU
i7-4790K
Graphics
RX 580
Mobile Phone
  1. iOS
Hi Jithin

config.plist attached

pmset -g output

System-wide power settings:
Currently in use:
hibernatemode 0
womp 0
networkoversleep 0
sleep 0 (sleep prevented by coreaudiod, iTunes)
Sleep On Power Button 1
ttyskeepawake 1
hibernatefile /var/vm/sleepimage
disksleep 0
displaysleep 0

As for the other 2 commands mind you that this reboot doesn't happen all the time and even now waking Sierra up after a good night sleep it worked. I'm currently using the ON/OFF switch instead of keyboard to wake the system as I've read somewhere that it might help but I highly doubt it.
So I know for sure if I sleep/wake now it'll always work. Most of the time it occurs after a long sleep but now it just worked again.
I've thought about RAM issue since I have 4x8GB and a Gigabyte mobo which tend to be buggy right. Also read about loosening the timings for the RAM (due to stressed CPU memory controller with 4 DIMM)
Thing is lately I've been spending more time trying to fix things then do some actual work on my rig.

Thanks in advance
 

Attachments

  • config.plist.zip
    2.1 KB · Views: 51
Joined
Mar 2, 2011
Messages
211
Motherboard
GA-Z97X-Gaming 7
CPU
i7-4790K
Graphics
RX 580
Mobile Phone
  1. iOS
ACPI needs patching. XHC requires either a DSDT patch or a SSDT patch. HDEF patch is required. SAT0 needs to be renamed to SATA. Take a look at the config on my Github for SATA patch. https://github.com/VoiletDragon/Z-H97N-WIFI-Patches Attach ioreg [Guide] How to Make a Copy of IOReg | tonymacx86.com

Holy smokes that's a lot of tweaking!
I'm surprised my rig is running that well without all these tweaks then ;)
Are you sure Clover doesn't implement these already or are these mobo specific tweaks?
Thanks
 
Joined
Jun 9, 2013
Messages
10,809
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
Holy smokes that's a lot of tweaking!
I'm surprised my rig is running that well without all these tweaks then ;)
Are you sure Clover doesn't implement these already or are these mobo specific tweaks?
Thanks

Nope. Z97/H97 uses the same patches as all other Z97/H97 motherboards. You're desktop isn't running well as OS X & macOS cant talk to you're hardware properly hence why issues with sleep.
 
Joined
Mar 2, 2011
Messages
211
Motherboard
GA-Z97X-Gaming 7
CPU
i7-4790K
Graphics
RX 580
Mobile Phone
  1. iOS
I used a DSDT in the passed (previous mono) but figured I got everything running well except sleep and GPU issue. Guess I was wrong. thanks for the heads-up mate!
I attached a zip containing Clover folder, Extensions/Kext output and ioreg as requested in another thread, maybe you can take a look into this.
Might be time for me to check into using DSDT and do some more patching in clover configurator!
 

Attachments

  • Snowy.zip
    2 MB · Views: 51
Joined
Jun 9, 2013
Messages
10,809
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
I used a DSDT in the passed (previous mono) but figured I got everything running well except sleep and GPU issue. Guess I was wrong. thanks for the heads-up mate!
I attached a zip containing Clover folder, Extensions/Kext output and ioreg as requested in another thread, maybe you can take a look into this.
Might be time for me to check into using DSDT and do some more patching in clover configurator!

You have nothing in EFI/Clover/ACPI/patched not even a SSDT for Powermanagement. Use SSDTs from my Github don't use SSDT-IGPU unless your using onboard IGPU. Use acpi_dsdt_patches.plist to copy patches to you're config don't use Clover configurator use Xcode attach ioreg once youve done you're work. All SSDTs go in EFI/Clover/ACPI/patched. https://github.com/VoiletDragon/Series-9-Patches
 
Joined
Mar 2, 2011
Messages
211
Motherboard
GA-Z97X-Gaming 7
CPU
i7-4790K
Graphics
RX 580
Mobile Phone
  1. iOS
You have nothing in EFI/Clover/ACPI/patched not even a SSDT for Powermanagement. Use SSDTs from my Github don't use SSDT-IGPU unless your using onboard IGPU. Use acpi_dsdt_patches.plist to copy patches to you're config don't use Clover configurator use Xcode attach ioreg once youve done you're work. All SSDTs go in EFI/Clover/ACPI/patched. https://github.com/VoiletDragon/Series-9-Patches

Hey mate, thanks for the help!
So far I've only pasted your acpi_dsdt_patches.plist into my Clover Config file. I'm trying things out on my USB install drive so I won't mess up Clover on my main drive (which I've done lots of times before)
I have extracted DSDT and SSDT's via Clover F4 and converted them to dsl but no idea what to do next. There are 8 SSDT files btw.
I used to be better at this but I must be getting old (and probably tired of fixing things)
Attached the new ioreg
Thanks in advance
 

Attachments

  • Patched Clover Config.ioreg
    3.6 MB · Views: 172
Joined
Jun 9, 2013
Messages
10,809
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
Hey mate, thanks for the help!
So far I've only pasted your acpi_dsdt_patches.plist into my Clover Config file. I'm trying things out on my USB install drive so I won't mess up Clover on my main drive (which I've done lots of times before)
I have extracted DSDT and SSDT's via Clover F4 and converted them to dsl but no idea what to do next. There are 8 SSDT files btw.
I used to be better at this but I must be getting old (and probably tired of fixing things)
Attached the new ioreg
Thanks in advance

No better. X86PlatformPlugin isn't loaded because you haven't implemented native Powermanagement. AppleLPC isn't loaded. SMBUS isn't loaded MCHC isn't loaded. You haven't (injected) XHC with correct properties you are missing SSDT-XHC. You haven't put SSDTs in EFI/Clover/ACPI/patched.
 
Top