Contribute
Register

Realtek ALC1220 (S1220A) Owner Thread

Joined
Aug 20, 2017
Messages
34
Motherboard
Dell Invision 941 SFF
CPU
Intel
Graphics
HD 4400
Edit: EEEEY, I just got sound working natively without USB soundcard :D Just install VoodooHDA 2.8.9 :D :D
Thanks kriss33. That did the trick even with F7 BIOS.
 
Joined
Nov 15, 2017
Messages
12
Motherboard
Asus ROG Strix z370f-gaming
CPU
I7 8700k
Graphics
Gtx 970ti strix
Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
hii... I can't able to get an audio in Mac OS Sierra with voodooHDA 2.8.9
My audio driver is ALCS1220A... Can anyone help me out??
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,206
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
audio in Mac OS Sierra
Remove Voodoo.
300 Series: MultiBeast 10.2+ > Drivers > Audio > RealtekALCxxx √ ALC1220A
plus √ 100 / 200 / 300 Series Audio
plus √ 200 / 300 Series X299 Audio Device ID Patch
 
Joined
Nov 8, 2017
Messages
14
Motherboard
Z270X UD5
CPU
i7 7700K
Graphics
GTX 1070 SC2
OMG! After days trying to understand how to fix this audio issue (my mobo is Z270X UD5) through Toleda's methods, I read this thread and tried the voodooHDA 2.9... it worked! And the HDMI output as well! So much easier... ! Thanks a lot kris33!!
 
Joined
Nov 15, 2017
Messages
12
Motherboard
Asus ROG Strix z370f-gaming
CPU
I7 8700k
Graphics
Gtx 970ti strix
Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Remove Voodoo.
300 Series: MultiBeast 10.2+ > Drivers > Audio > RealtekALCxxx √ ALC1220A
plus √ 100 / 200 / 300 Series Audio
plus √ 200 / 300 Series X299 Audio Device ID Patch
i hd tried this also bt not solution same issue....

some other solution tht i can try..??
 
Joined
Nov 15, 2017
Messages
12
Motherboard
Asus ROG Strix z370f-gaming
CPU
I7 8700k
Graphics
Gtx 970ti strix
Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
OMG! After days trying to understand how to fix this audio issue (my mobo is Z270X UD5) through Toleda's methods, I read this thread and tried the voodooHDA 2.9... it worked! And the HDMI output as well! So much easier... ! Thanks a lot kris33!!
how u hd use jst explain me....
 
Joined
Nov 8, 2017
Messages
14
Motherboard
Z270X UD5
CPU
i7 7700K
Graphics
GTX 1070 SC2
how u hd use jst explain me....

monikmaru111, I guess you may be a simple mac user like me, distant from any programing knowledge, I for instance could not understand the great and complete tutorial Toleda wrote, not because it was too difficult, but probably because I fail to understand simple computing procedures. So, as kris33 suggested, I googled "voodooHDA 2.9", downloaded it (github has it), read and followed the readme file that came with it. Because the procedure was easy I could do it, and it simply worked. But attention: before that, I reinstalled entirely the OS, from scratch, and also followed some procedures to disable SIP (search for disable SIP, it's fairly easy too). Try it!
 
Last edited:
Joined
Aug 20, 2017
Messages
34
Motherboard
Dell Invision 941 SFF
CPU
Intel
Graphics
HD 4400
OMG! After days trying to understand how to fix this audio issue (my mobo is Z270X UD5) through Toleda's methods, I read this thread and tried the voodooHDA 2.9... it worked! And the HDMI output as well! So much easier... ! Thanks a lot kris33!!
I'm going to have to test that with my Z270X UG.
If you have the time, can you boot with verbose enable and see if there is a warning message about iTunes?
 
Joined
Nov 8, 2017
Messages
14
Motherboard
Z270X UD5
CPU
i7 7700K
Graphics
GTX 1070 SC2
Sorry, not for the next weeks... and I'm not sure I understood what you're asking.
 
Joined
Jan 9, 2016
Messages
97
Motherboard
ASUS Z270 Tuf Mark 1
CPU
i7-7700K
Graphics
RX 570
Mac
  1. iMac
Mobile Phone
  1. Android
hi @toleda iam strugling to get audio on my asus z270 tuf mark 1 motherboard which has Alc S1220A when ever i run your script (audio_cloverALC-130_v0.4.command ) it runs fine but not working atlast i just getting an error that says installation failed pls reffer my terminal log below

Volumes/EFI/EFI/CLOVER/kexts/Other/realtekALC.kext Install System/Library/Extensions/AppleHDA.kext/ALC1220A zml files install: /tmp/1220A/Platforms.xml.zlib: No such file or directory install: /tmp/1220A/layout1.xml.zlib: No such file or directory install: /tmp/1220A/layout2.xml.zlib: No such file or directory rm: /tmp/1220A: No such file or directory Error: Installation failure rm: /System/Library/Extensions/AppleHDA.kext/Contents/Resources/*zml.zlib: No such file or directory Original S/L/E/AppleHDA.kext restored To save a Copy of this Terminal session: Terminal/Shell/Export Text As ... logout Saving session... ...copying shared history... ...saving history...truncating history files... ...completed.
 
Top