Contribute
Register

Really Poor Performance

Status
Not open for further replies.
Joined
Aug 26, 2016
Messages
47
Motherboard
Intel S2600CP2J
CPU
2 x Intel Xeon E5-2670
Graphics
AMD Radeon HD7970 GHz Edition
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Hi everyone I'm getting some really bad performance from setup.

I've recently started playing around with Final Cut and iMovie, and videos are extremely jerky with sound popping too. Add to this the fact that I only score around 784/26fps (CPU/GPU) in Cinebench, and I think I'm running into some kind power management settings, keeping my CPU near sleep-states.

Any tips on how best to proceed here? I'm running OS X 10.11.6.

For reference, Windows Cinebench scores are around 1995/80.2.
 

Attachments

  • config.plist
    10.9 KB · Views: 225
Last edited:
Joined
Apr 16, 2017
Messages
22
Motherboard
ASRock EP2C602
CPU
2 x Xeon E5-2670 V1
Graphics
GTX 1080
Mac
  1. Mac Pro
1730/50.43fps

Not sure what the go is with the low fps on my machine, perhaps because i'm using HDMI and limited to 30hz? I donno haha.
 
Joined
Apr 16, 2017
Messages
22
Motherboard
ASRock EP2C602
CPU
2 x Xeon E5-2670 V1
Graphics
GTX 1080
Mac
  1. Mac Pro
Apparently, Cinebench is a poor benchmark for the 100 series cards. But the CPU performance is still pretty good.
 
Joined
Aug 26, 2016
Messages
47
Motherboard
Intel S2600CP2J
CPU
2 x Intel Xeon E5-2670
Graphics
AMD Radeon HD7970 GHz Edition
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
That's still a lot better than what my machine is getting.

I've updated my original post by adding my config.plist file. Hopefully someone can help out with this issue as the machine is unusable for video editing.
 
Joined
Apr 16, 2017
Messages
22
Motherboard
ASRock EP2C602
CPU
2 x Xeon E5-2670 V1
Graphics
GTX 1080
Mac
  1. Mac Pro
Here is my EFI for the USB stick to boot. You have a different Mobo so backup yours and give it a shot.
 

Attachments

  • ASRockC602-E5-2670.zip
    33.6 MB · Views: 167
Joined
Aug 26, 2016
Messages
47
Motherboard
Intel S2600CP2J
CPU
2 x Intel Xeon E5-2670
Graphics
AMD Radeon HD7970 GHz Edition
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
I've just confirmed that it's a power management issue.

When I disabled SpeedStep and C states in the BIOS, all my performance issues in OS X disappeared.

So now the question is: what's preventing OS X from utilising my CPU's SpeedStep functionality? Is it the fact that I'm using a MacPro5,1 SMBIOS? Do I need to patch any power management kexts?
 
Joined
Aug 17, 2012
Messages
45
Motherboard
ASUS UX31LA (clover)
CPU
Core i5 4200u
Graphics
Intel HD graphics 4400, 1920x1080
Mobile Phone
  1. Android
I have the same problem with my i7-5960x. Did you managed to find any solution?
 
Joined
Aug 26, 2016
Messages
47
Motherboard
Intel S2600CP2J
CPU
2 x Intel Xeon E5-2670
Graphics
AMD Radeon HD7970 GHz Edition
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
I have the same problem with my i7-5960x. Did you managed to find any solution?

No solution yet I’m afraid. :(

The only thing I could do was to disable SpeedStep in the BIOS. The problem is that my CPUs are running at 2.6GHz all the tim, regardless of CPU load.
 
Joined
Apr 25, 2016
Messages
208
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Here is my EFI for the USB stick to boot. You have a different Mobo so backup yours and give it a shot.
cman9090, thank you for sharing!
I used your EFI and got 1363/52.63 fps I used to have 1021 for CPU, don't know what was for GPU. It looks like I still have some room for improvements. I have almost the same build as yours.
 
Last edited:
Status
Not open for further replies.
Top