Contribute
Register

[README] Common (some unsolved) Problems in 10.12 Sierra

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,727
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
This patches can be included in the KextsToPatch category using PlistEdit Pro, right?

Yes:
- kext patches go in config.plist/KernelAndKextPatches/KextsToPatch
- a plist editor such as PlistEdit Pro or Xcode is recommended for any edits to config.plist
 
Joined
Apr 16, 2016
Messages
5
Motherboard
Dell
CPU
i7-5500U
Graphics
HD 5500 (1366x768), GeForce 920M (Inactive)
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
This is it!
My u430 with 10.12.4 suffered from this problem (short duration lag after wake and after login).

My u430 has LVDS and a single HDMI.
I use ig-platform-id 0xa260006 with it. 0xa260006 has LVDS, 0105 DP, 0204 DP.
The HDMI is wired to 0204, so I patch that port for HDMI (to enable HDMI audio).
I also use the 'vbo' 9mb cursor bytes patch (even though it is not needed on my particular laptop... it is helpful on others).

So... before 10.12.4, I had these patches for com.apple.driver.AppleIntelFramebufferAzul:

Comment: 0x0a260006 9MB cursor bytes, vbo
Find: <0600260a 01030303 00000002 00003001 00006000>
Replace: <0600260a 01030303 00000002 00003001 00009000>

Comment: HDMI-audio, port 0204, 0x0a260005 0x0a260006
Find: <02040900 00040000 87000000>
Replace: <02040900 00080000 87000000>

Now the 0105 port comes before the 0204 port in the framebuffer, but we don't need the 0105 port as it is not connected to anything (and causing the lags).

So... strategy is to replace 0105 with 0204 and reduce the number of ports from 3 to 2.

We already know that in AppleIntelFramebufferCapri that 0x01660004 has only a single LVDS connector, so we can look to the header of that ig-platform-id data to discover what we need to reduce our ig-platform data in Azul from 3 ports to 2.

From AppleIntelFramebufferCapri 0x01660004:
04006601 01030101

And from AppleIntelFramebufferAzul 0x0a260006:
0600260A 01030303

So, there appears to be two counts at the end related to the number of connectors... plan to change them both...

New set of patches:

Comment: 0x0a260006 9MB cursor bytes (vbo), 2 ports only (RehabMan)
Find: <0600260a 01030303 00000002 00003001 00006000>
Replace: <0600260a 01030202 00000002 00003001 00009000>

Comment: 0x0a260006 disable 0204 port, change 0105 DP port to 0204 HDMI (RehabMan)
Find: <01050900 00040000 87000000 02040900 00040000 87000000>
Replace: <02040900 00080000 87000000 FF000000 01000000 40000000>

Result: No more lag after login and wake from sleep.
Hi Rehab,
I wanted to disable the port that I do not use to avoid this short lag, but I did not understand how to make this patch to my id. Can you help me?
(this copy of ioreg is with the hdmi connected)
 

Attachments

  • Mateus.zip
    554.8 KB · Views: 136

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,727
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi Rehab,
I wanted to disable the port that I do not use to avoid this short lag, but I did not understand how to make this patch to my id. Can you help me?
(this copy of ioreg is with the hdmi connected)

If you change portcount and memorycount to 2, it should eliminate the extra port (@2).
Look at my u430 github config.plist.
 
Joined
Oct 7, 2016
Messages
278
Motherboard
Broadwell, UEFI
CPU
Core i3-5005U
Graphics
Intel HD 5500 (1366 x 768), AMD Radeon R5 M330 2GB
Mobile Phone
  1. Android
  2. iOS
Your ioreg shows laptop display at framebuffer@0, and external @1, which means the @2 connector is unused.

It means you can eliminate the @2 connector by patching the connector count:
Name: AppleIntelBDWGraphicsFramebuffer
Find: <06 00 26 16 01 03 03 03>
Replace: <06 00 26 16 01 03 02 03>
what would be my portcount and memorycount?
 
Joined
Oct 7, 2016
Messages
278
Motherboard
Broadwell, UEFI
CPU
Core i3-5005U
Graphics
Intel HD 5500 (1366 x 768), AMD Radeon R5 M330 2GB
Mobile Phone
  1. Android
  2. iOS
That patch is changing only portcount to 2. memorycount is being left at 3.
like this?
Screenshot 2018-10-16 at 7.13.48 PM.png
 
Joined
Apr 16, 2016
Messages
5
Motherboard
Dell
CPU
i7-5500U
Graphics
HD 5500 (1366x768), GeForce 920M (Inactive)
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
If you change portcount and memorycount to 2, it should eliminate the extra port (@2).
Look at my u430 github config.plist.
did not work :/
 

Attachments

  • Captura de Tela 2018-10-17 às 14.14.55.png
    Captura de Tela 2018-10-17 às 14.14.55.png
    12.4 KB · Views: 74

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,727
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Joined
Apr 16, 2016
Messages
5
Motherboard
Dell
CPU
i7-5500U
Graphics
HD 5500 (1366x768), GeForce 920M (Inactive)
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Top