Contribute
Register

[README] Common (some unsolved) Problems in 10.12 Sierra

Joined
Oct 20, 2017
Messages
2
Motherboard
MSI H81I
CPU
Core-i3 4150/H81
Graphics
HD4400
Mobile Phone
  1. Android
I have been able to remove my login lag just by setting:

<key>VideoPorts</key>
<integer>2</integer>
<key>ig-platform-id</key>
<string>0x0d220003</string>

I'm running 10.13.3
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have been able to remove my login lag just by setting:

<key>VideoPorts</key>
<integer>2</integer>
<key>ig-platform-id</key>
<string>0x0d220003</string>

I'm running 10.13.3

I don't think VideoPorts has any effect with IGPU.
Using a desktop ig-platform-id not advised for laptops.
 
Joined
Oct 20, 2017
Messages
2
Motherboard
MSI H81I
CPU
Core-i3 4150/H81
Graphics
HD4400
Mobile Phone
  1. Android
I don't think VideoPorts has any effect with IGPU.
Using a desktop ig-platform-id not advised for laptops.

I'm on a desktop build, 0x0d220003 seemed appropriate, no adverse effects so far.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I'm on a desktop build, 0x0d220003 seemed appropriate, no adverse effects so far.

Your posts are off-topic.
This forum/thread is for laptops only.
 
Joined
Jan 30, 2017
Messages
15
CPU
Intel Core i3-5005U
Graphics
intel HD 5500 + Nvidia Geforce GT 920M (disable in ssdt)
Mobile Phone
  1. Android
This is it!
My u430 with 10.12.4 suffered from this problem (short duration lag after wake and after login).

My u430 has LVDS and a single HDMI.
I use ig-platform-id 0xa260006 with it. 0xa260006 has LVDS, 0105 DP, 0204 DP.
The HDMI is wired to 0204, so I patch that port for HDMI (to enable HDMI audio).
I also use the 'vbo' 9mb cursor bytes patch (even though it is not needed on my particular laptop... it is helpful on others).

So... before 10.12.4, I had these patches for com.apple.driver.AppleIntelFramebufferAzul:

Comment: 0x0a260006 9MB cursor bytes, vbo
Find: <0600260a 01030303 00000002 00003001 00006000>
Replace: <0600260a 01030303 00000002 00003001 00009000>

Comment: HDMI-audio, port 0204, 0x0a260005 0x0a260006
Find: <02040900 00040000 87000000>
Replace: <02040900 00080000 87000000>

Now the 0105 port comes before the 0204 port in the framebuffer, but we don't need the 0105 port as it is not connected to anything (and causing the lags).

So... strategy is to replace 0105 with 0204 and reduce the number of ports from 3 to 2.

We already know that in AppleIntelFramebufferCapri that 0x01660004 has only a single LVDS connector, so we can look to the header of that ig-platform-id data to discover what we need to reduce our ig-platform data in Azul from 3 ports to 2.

From AppleIntelFramebufferCapri 0x01660004:
04006601 01030101

And from AppleIntelFramebufferAzul 0x0a260006:
0600260A 01030303

So, there appears to be two counts at the end related to the number of connectors... plan to change them both...

New set of patches:

Comment: 0x0a260006 9MB cursor bytes (vbo), 2 ports only (RehabMan)
Find: <0600260a 01030303 00000002 00003001 00006000>
Replace: <0600260a 01030202 00000002 00003001 00009000>

Comment: 0x0a260006 disable 0204 port, change 0105 DP port to 0204 HDMI (RehabMan)
Find: <01050900 00040000 87000000 02040900 00040000 87000000>
Replace: <02040900 00080000 87000000 FF000000 01000000 40000000>

Result: No more lag after login and wake from sleep.

(Solved)
Im find data frambuffer to eliminate port in internet and change HDMI port for 16260002 from rehabman

Hi @RehabMan
I have problem with not responsive and lag in log in screen too
I use ig platform id 16260002 broadwell, have two port 0105 and 0204 and HDMI in 0105
can you teach me how to find value to solve this issue??

This is dump of my device
 

Attachments

  • Send me macbook-pro.zip
    3.1 MB · Views: 89
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
(Solved)
Im find data frambuffer to eliminate port in internet and change HDMI port for 16260002 from rehabman

Hi @RehabMan
I have problem with not responsive and lag in log in screen too
I use ig platform id 16260002 broadwell, have two port 0105 and 0204 and HDMI in 0105
can you teach me how to find value to solve this issue??

This is dump of my device

To disable the @2 connector in ig-platform-id 0x16260002....
Find: 02 04 0A 00 00 04 00 00 07 05 00 00
Replace: FF 00 00 00 01 00 00 00 40 00 00 00
 
Joined
Jan 30, 2017
Messages
15
CPU
Intel Core i3-5005U
Graphics
intel HD 5500 + Nvidia Geforce GT 920M (disable in ssdt)
Mobile Phone
  1. Android
To disable the @2 connector in ig-platform-id 0x16260002....
Find: 02 04 0A 00 00 04 00 00 07 05 00 00
Replace: FF 00 00 00 01 00 00 00 40 00 00 00

yes @RehabMan I've found it yesterday and for HDMI I used from your config.plist HDMI audio
Thank you so much
 
Joined
Mar 13, 2018
Messages
4
Motherboard
HP Probook 450 G1 (HM87)
CPU
Intel Core i5-4200M
Graphics
Intel HD Graphics 4600
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey @RehabMan,
My hackintosh lagging when login and sleep
My OS version: 10.13.4
I use your tutorial to install: https://www.tonymacx86.com/threads/...book-zbook-using-clover-uefi-hotpatch.232948/
I have external display with HDMI port
Currently, my lap working good without audio HDMI and lagging. I only want lagging be go away (i dont need audio HMDI). Please help me
I attached ioreg and config.plist (plist file from guide)

P/s: Sorry for my bad english
 

Attachments

  • Nghia MacBook Pro.ioreg
    8.5 MB · Views: 169
  • config.plist
    20.6 KB · Views: 242
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hey @RehabMan,
My hackintosh lagging when login and sleep
My OS version: 10.13.4
I use your tutorial to install: https://www.tonymacx86.com/threads/...book-zbook-using-clover-uefi-hotpatch.232948/
I have external display with HDMI port
Currently, my lap working good without audio HDMI and lagging. I only want lagging be go away (i dont need audio HMDI). Please help me
I attached ioreg and config.plist (plist file from guide)

P/s: Sorry for my bad english

Since your laptop does not use the 0306 port, disable it:
Find: 03 06 03 00 00 08 00 00 06 00 00 00
Replace: FF 00 00 00 01 00 00 00 40 00 00 00

Make sure you remove the patch for 0306 DP (already present in your config.plist): "DP port 0306, 0x0d260007"

If still not fixed, add a patch to disable the 0204 connector...
Find: 02 04 0B 00 00 04 00 00 07 01 00 00
Replace: FF 00 00 00 01 00 00 00 40 00 00 00
 
Top