[README] Common (some unsolved) Problems in 10.12 Sierra

well I need the keyboard kext thats what makes it work
new USB port limit patch

A new patch is required. Keep in mind the port limit patch is for temporary use only. You should plan on creating a custom SSDT to configure USBInjectAll.kext such that the port limit patch is not needed.

eg. in KextsToPatch:
Comment: change 15 port limit to 26 in XHCI kext (100-series)
MatchOS: 10.12.x
Find: <83bd74ff ffff10>
Replace: <83bd74ff ffff1b>
I was able to edit my config.plist to re-enable the USB ports (*based on my config.plist from El Capitan). I have created a custom SSDT, but I do not know how to "configure USBInjectAll.kext such that the port limit patch is not needed". Please forgive my ignorance, but how does the custom SSDT configure USBInjectAll.kext? Do I need to modify the SSDT to do this, and if so, how do I do that? Thanks for all that you do!

*the blue items are what I had to change in my config.plist:
<string>change 15 port limit to 20 in XHCI kext (9-series)</string>
Re: Volume keys not working
USBOveride 3.3 works to restore volume control via the keyboard, however it kills my delete and spacebar......

Edit: Disabling "Any keyboard , Any application " and " Any Other , Any application" solved my issues completely (I only use USBOveride for the fwd/back mouse buttons anyway). Media keys, mute, and volume all work natively for my Corsair K70.

Last edited:
Clearly it is data for a KextsToPatch entry. Only use it if you need it (it depends on your patch codec id, and your target codec id).

Use Xcode or PlistEdit Pro to edit plist files.

Well I don't have sound at all. I do use PlistEdit Pro but still i can't find those lines to make the audio work.
I go even further with el Capitan.
Because the list of incompatible programs is long:

Adobe Dreamweaver CS5 (Crashes)
Adobe Dreamweaver CS6 (Crashes)
Adobe Illustrator CS6 (Works on the Java 6 Update)
Adobe InDesign CC (Assigns rendering errors when you drag-and-drop)
Adobe Photoshop CS5 (Crashes beim Schließen)
Adobe Photoshop CS6 (Installer error)
App Tamer
AVG AntiVirus (Does not open)
AVG Cleaner (Crashes)
BOX Sync
BusyCal (Crashes)
Carbon Copy Cloner 4.19 (Do not make backups), operational from current revisions
CCleaner (Does not open)
Kontakte (Can crash)
Disk Warrior (Crashes), operational from current revisions
EazyDraw 7 (Crashes when starting)
ESET Cyber Security Pro
EtreCheck (Crashes beim Scannen), operational from current revisions
Final Draft 9 (Stabil ab 9.0.9)
Freemacsoft LiteIcon 3.6.3 (Error message when you start, sogar wenn SIP aktiviert ist))
Greek Radio (Error message when you start)
Identify 551 (end of the development of the program)
Junos Pulse
Little Snitch 3.6.3, (operational from current revisions)
Logitech Control V3.93
Mail Act-On
Maintenance (Crashes)
Merlin 2
Movist (Crashes after a few minutes)
Online Bible 4.2.1 (Crashes with an error message)
Onyx (Crashes at startup)
Pages 09
Pulse Secure 5.2r2
Pyware Versionen 8.0.0, 7, 6,
Quicken Essentials for Mac 1.7.4
RapidWeaver 7 (Works version 7.0.4)
Razer Synapse 2.0.
Safari Technology Preview 9.1.2
SIMBL (SafariStand etc.)
Splashtop Streamer (Crashes after Clean Install, Update at El Capitan works)
SyncTwoFolders 2.19 (Crashes when selecting the destination folder)
Unlimited Connection Manager 4.5
Yosemite Disk Utility patched for El Capitan (Crashes at Start)
Western Digital Disk Tools
WhatsApp Desktop
WriteRoom 2.5.1 (Inkompatibel)
ZenMate (Can not the VPN network connecting)
Thanks for the writeup, it was invaluable, as usual.

I did everything but still my audio is not working. I was using the stock AppleHDA with clover patching, I added the 0000000 patch, but still no sound. This is what my KextsToPatch looks like.

What did I miss?

<string>Expect 2 matches</string>
<string>0x11d4198a to zero</string>
Okay guys I've done this:
cd ~/Projects/probook.git
git stash
git pull

and now in system i can see internal speakers showing but no audio at all. Mic is working. Any ideas ??