Contribute
Register

[README] Common Problems and Workarounds on 10.14 Mojave

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,311
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@Sniki I noticed you mentioned "black screen after wake from sleep issue" in your initial post. My EliteBook 850 G2 is affected by this issue if I try to run High Sierra or Mojave. I never found a fix and have been running stable on El Capitan for the time being but would like to be able to upgrade in the future if possible. Do you have any idea what causes this issue and can it be attributed to APFS by any chance?
Open a separate thread on the appropriate forum and make sure to attach all “Problem Reporting” files
 
Joined
Dec 12, 2017
Messages
126
Motherboard
HP EliteBook 840 G4
CPU
i7-7600U
Graphics
HD 620, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Open a separate thread on the appropriate forum and make sure to attach all “Problem Reporting” files

I already have multiple times and worked with @RehabMan to find a solution. To date nothing worked. Its not a hardware issue because as I mentioned El Capitan is flawless. I was hoping you could provide a very narrow list of general causes for black screen on wake and perhaps that will set me on a new path to a possible solution?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,093
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I already have multiple times and worked with @RehabMan to find a solution. To date nothing worked. Its not a hardware issue because as I mentioned El Capitan is flawless. I was hoping you could provide a very narrow list of general causes for black screen on wake and perhaps that will set me on a new path to a possible solution?

Open a separate thread. This is not a troubleshooting thread.
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,311
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@RehabMan
Post #1 Updated, more sections to be added, anything worth mentioning that is missing is always welcome.
This is just the bare minimum, i will gradually add more information to each section and cover what is missing that is important and needs to be listed.
I think i should add also a note about CoffeLake.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,093
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
@RehabMan
Post #1 Updated, more sections to be added, anything worth mentioning that is missing is always welcome.
This is just the bare minimum, i will gradually add more information to each section and cover what is missing that is important and needs to be listed.
I think i should add also a note about CoffeLake.

Thanks. I will try to review it when time allows.
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,311
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@RehabMan Off topic but do you have any idea for "common / usual" reasons why Ioregistryexplorer takes too long to load and when it does, it keeps refreshing like every 5 sec, also when you save the file its over / at least 20mb

Just some suggested common reasons for that ?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,093
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
@RehabMan Off topic but do you have any idea for "common / usual" reasons why Ioregistryexplorer takes too long to load and when it does, it keeps refreshing like every 5 sec, also when you save the file its over / at least 20mb

Just some suggested common reasons for that ?

No idea without PR files (because basically I just look for stupid/common mistakes).
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,311
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
No idea without PR files (because basically I just look for stupid/common mistakes).
Here are the problem reporting files collected from the script.
 

Attachments

  • debug_14137.zip
    2.5 MB · Views: 29

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,093
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Here are the problem reporting files collected from the script.

Comments/suggestions:
- eliminate all kexts that are not needed (for example FakeSMC sensor kexts)
- check Activity Monitor for excess CPU usage
- USB configuration is wrong/configuration not implemented
- no need for patch "change MUT0(0x0FFF to 0xFFFF)"
- probably "change HID(ABCDEFGH to PNP0C15)" not needed either
- H_EC->EC should not be used when you're already using SSDT-EC.aml
- ForceKextsToLoad is for pre-install only
- usually good idea to use config.plist/SMBIOS/Trust=true
- you're finding injecting PinConfigurations to actually do anything?
- why -uia_exclude_xhc?
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,311
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
- eliminate all kexts that are not needed (for example FakeSMC sensor kexts)
Done
- USB configuration is wrong/configuration not implemented
I did previously try but i had some issues with USB3 Ports not working, there was a Bios Update with USB Port fixes which i did update, seems that did fix that existing problem after all.
Successfully created custom usb port injector, after installing USBInjectall.kext (removed fakePCIID.kext & FakePCIID_XHCImux.kext) rebooted and:
4x front USB2 ports on EH02 > PR21:
- HP21
- HP22
- HP23
- HP24
2x back USB2 ports on EH02 > PR21:
- HP25
- HP26
Result: EH02 port completely used with all existing USB2 Ports on their proper place.
EH01 unused, disabled with SSDT-DEH01

XHC Port "8086_1e31", already complete on your SSDT-UIAC-ALL.dsl

4x USB 3 Ports on the back
HS01 - SS01,
HS02 - SS02,
HS03 - SS03,
HS04 - SS04
Each one with 2.0 and 3.0 device working.

USB problems solved.
- no need for patch "change MUT0(0x0FFF to 0xFFFF)"
Disabled the patch
- probably "change HID(ABCDEFGH to PNP0C15)" not needed either
Disabled the patch
- H_EC->EC should not be used when you're already using SSDT-EC.aml
Removed the patch
- ForceKextsToLoad is for pre-install only
Removed
- usually good idea to use config.plist/SMBIOS/Trust=true
Added
- you're finding injecting PinConfigurations to actually do anything?
Removed... no idea what i intended there, when i already have created correct SSDT-ALC221.dsl (forgot to remove the data from config.plist).
- why -uia_exclude_xhc?
Temporary workaround for USB3 Ports to work, now i corrected them.

The problem is, still the Ioreg does take time to load and now it does refresh while i try to save a copy (once or twice) only or if you plug a usb port or something that does change.
Also yes, it does raise the CPU Usage to 100-103%

Otherwise with IoregistryExplorer closed, the cpu usage is 0.0 if nothing opened.

Even though you mentioned that PluginType=1 Power management is not so good on Ivy Bridge, it does look ok on paper, frequency drops to 1600mhz on idle and also turbo boost to it's max turbo boost speed, same for IGPU, lot of stats on AppleIntelinfo.kext test so i assume it should be good ?

Another question, does the CPU fan have available code that can be enabled/tweaked to show fan rpm speed on HWmonitor ?
 

Attachments

  • debug_27929.zip
    2.5 MB · Views: 25
Top