Contribute
Register

Solved > Razer Blade Stealth Trackpad and Audio issues

Joined
Jan 13, 2019
Messages
16
Motherboard
HP Notebook 15-bs182nd
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
iOS
Hello! I just got my hands on a Razer Blade Stealth (don't know the exact year), and I'm having trouble with fixing the trackpad and audio issues, I tried using Clover files (DSDT, kexts etc) from various guides but problem still persists. I don't know what to do anymore so I hope u guys can help me out!

Laptop specs:
  • i7 7500u
  • 8GB RAM
  • Audio: ALC298 (checked on Windows)
  • Trackpad: Synaptics (checked on Windows)
I tried to follow this guide to fix the trackpad, it says on the guide
Its a multitouch I2C trackpad, so I simply used VoodooI2C plus VoodooI2CHID with an SSDT-XOSI to enable the I2C controller. All the native multitouch gestures work great, even three finger click-and-drag. Its not quite as sensitive as my MBP trackpad, but its better than I expected on a hackintosh. Right click is a little finnicky if you don't tap with two fingers.
I compiled SSDT-XOSI in maciasl as .aml file with ACPI Machine Language Binary and put it on patched folder. I also tried to patch the DSDT with i2c controllers but was getting an error, please check the pictures attached.

I also tried all layout ID's except the 0x100101, 0x100103 ones mentioned on AppleALC wiki page.
Realtek ALC298
0x100101, 0x100103 layout 3, 11, 13, 28, 29, 30, 47, 66, 72, 99
I've attached my EFI folder and problem reporting files. Hoping that someone can help me out. Thank you in advance!
 

Attachments

Joined
Apr 21, 2016
Messages
1,158
Motherboard
ASUS X556UA (Clover)
CPU
i5-6200U
Graphics
Intel HD 520, 15.6" 1366x768
Mobile Phone
iOS
Hello! I just got my hands on a Razer Blade Stealth (don't know the exact year), and I'm having trouble with fixing the trackpad and audio issues, I tried using Clover files (DSDT, kexts etc) from various guides but problem still persists. I don't know what to do anymore so I hope u guys can help me out!

Laptop specs:
  • i7 7500u
  • 8GB RAM
  • Audio: ALC298 (checked on Windows)
  • Trackpad: Synaptics (checked on Windows)
I tried to follow this guide to fix the trackpad, it says on the guide
I compiled SSDT-XOSI in maciasl as .aml file with ACPI Machine Language Binary and put it on patched folder. I also tried to patch the DSDT with i2c controllers but was getting an error, please check the pictures attached.

I also tried all layout ID's except the 0x100101, 0x100103 ones mentioned on AppleALC wiki page.


I've attached my EFI folder and problem reporting files. Hoping that someone can help me out. Thank you in advance!
Your SSDT-XOSI isn't suitable for your hardware (Simulates the old Windows 2012). Get it from here:
 
Joined
Jan 13, 2019
Messages
16
Motherboard
HP Notebook 15-bs182nd
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
iOS
Your SSDT-XOSI isn't suitable for your hardware (Simulates the old Windows 2012). Get it from here:
I replaced the SSDT-XOSI with the one u linked, it still doesn't work :/
 
Joined
Apr 21, 2016
Messages
1,158
Motherboard
ASUS X556UA (Clover)
CPU
i5-6200U
Graphics
Intel HD 520, 15.6" 1366x768
Mobile Phone
iOS
I replaced the SSDT-XOSI with the one u linked, it still doesn't work :/
Please attach a new troubleshooting archive, with the correct SSDT-XOSI.
 
Joined
Apr 21, 2016
Messages
1,158
Motherboard
ASUS X556UA (Clover)
CPU
i5-6200U
Graphics
Intel HD 520, 15.6" 1366x768
Mobile Phone
iOS
It's weird, i opened the .dsl file on maciasl, then saved as .aml (ACPI Machine Language Binary), but when i open the .aml file, the text changes.
It's fine, nothing to worry.
Please use quoted replies, so people can be notified when you reply to their messages.

Remove VoodooI2CSynaptics for now, use just VoodooI2C + VoodooI2CHID.
Once you get it working with HID, and if you don't have multitouch, you can try Syanptics.

You should definitely remove VoodooI2CUPDDEngine.kext, you have no use for it.

Clover's FixUSB is not recommended usually.

SortedOrder is not necessary, remove it from your config.plist. SSDT-XOSI will load just fine.

You cannot have both ACPIBatteryManager and SMCBatteryManager. I'd remove the former.
Notice you don't have VirtualSMC installed, just the sensor kexts. Remove FakeSMC and install VirtualSMC.
Make sure you remove SMCHelper-64.efi, as it conflicts with VirtualSMC.

Your config.plist is missing CoolStar's 2 patches for Apple's I2C kexts. Add them:
 
Joined
Jan 13, 2019
Messages
16
Motherboard
HP Notebook 15-bs182nd
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
iOS
Your config.plist is missing CoolStar's 2 patches for Apple's I2C kexts. Add them:
Hi, thanks a lot for ur reply, I copied and paste the patch with PlistEdit Pro (free version), Trackpad now works with only basic functionality, 2 fingers scrolling doesn't work and tapping doesn't work aswell, I tried using i2csynaptics.kext aswell, but still no multitouch / gestures.

Now just audio issue left, can u help me out with this? :D
 

Attachments

Last edited:
Joined
Apr 21, 2016
Messages
1,158
Motherboard
ASUS X556UA (Clover)
CPU
i5-6200U
Graphics
Intel HD 520, 15.6" 1366x768
Mobile Phone
iOS
Hi, thanks a lot for ur reply, I copied and paste the patch with PlistEdit Pro (free version), Trackpad now works with only basic functionality, 2 fingers scrolling doesn't work and tapping doesn't work aswell, I tried using i2csynaptics.kext aswell, but still no multitouch / gestures.

Now just audio issue left, can u help me out with this? :D
You need to change VoodooI2CSynaptic's IONameMatch to your trackpad's name before installing. In IOReg it shows as ''15320205".

Not sure about audio...
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
10,371
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
Hi, thanks a lot for ur reply, I copied and paste the patch with PlistEdit Pro (free version), Trackpad now works with only basic functionality, 2 fingers scrolling doesn't work and tapping doesn't work aswell, I tried using i2csynaptics.kext aswell, but still no multitouch / gestures.

Now just audio issue left, can u help me out with this? :D
audio:

config.plist, enable these:
Code:
<key>Fixes</key>
            <dict>
                <key>Comment-IRQ Fix</key>
                <string>The following fixes may be needed for onboard audio/USB/etc</string>
                <key>FixHPET</key>
                <false/>
                <key>FixIPIC</key>
                <false/>
                <key>FixRTC</key>
                <false/>
                <key>FixTMR</key>
                <false/>
                <key>FixUSB</key>
                <false/>
            </dict>
and:

Code:
<key>PciRoot(0)/Pci(0x1f,3)</key>
            <dict>
                <key>#PinConfigurations</key>
                <data>
                </data>
                <key>#hda-gfx</key>
                <string>onboard-1</string>
                <key>#layout-id</key>
                <integer>3</integer>
                <key>#no-controller-patch</key>
                <integer>1</integer>
            </dict>
 
Joined
Jan 13, 2019
Messages
16
Motherboard
HP Notebook 15-bs182nd
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
iOS
You need to change VoodooI2CSynaptic's IONameMatch to your trackpad's name before installing. In IOReg it shows as ''15320205".
How do I change the IONameMatch? I opened the Synaptic's kext on PlistEdit Pro but couldn't find IONameMatch.

audio:

config.plist, enable these:
Code:
<key>Fixes</key>
            <dict>
                <key>Comment-IRQ Fix</key>
                <string>The following fixes may be needed for onboard audio/USB/etc</string>
                <key>FixHPET</key>
                <false/>
                <key>FixIPIC</key>
                <false/>
                <key>FixRTC</key>
                <false/>
                <key>FixTMR</key>
                <false/>
                <key>FixUSB</key>
                <false/>
            </dict>
and:

Code:
<key>PciRoot(0)/Pci(0x1f,3)</key>
            <dict>
                <key>#PinConfigurations</key>
                <data>
                </data>
                <key>#hda-gfx</key>
                <string>onboard-1</string>
                <key>#layout-id</key>
                <integer>3</integer>
                <key>#no-controller-patch</key>
                <integer>1</integer>
            </dict>
I enabled the first one, and put layout ID 29 on the second one, changed 3 to 29, audio still doesn't show on System Preferences.
 
Top