Contribute
Register

Razer Blade 2016 OS X 10.11.5

Status
Not open for further replies.
Joined
Aug 17, 2010
Messages
199
Motherboard
Razer Blade 15 Mercury White
CPU
i7-8750H
Graphics
UHD 630 + GTX 1060
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Yep, it is a known issue. You have experienced one out of three. It happens when you shutdown while plugged in or if the battery is charged fully. To get back to battery state you have to plug in and restart (in macOS). When macOS has booted again, unplug the charger. See if you got the indicator back.

Remember always to unplug the charger before shutdown or under 100% (like 98% or something) of battery charge to avoid this issue.

(Of course things will have issues with a non-Apple computer!)

Ok, just wanted to confirm it's not just happening to me. I'm trying to figure out a dsdt patch to fix this.
 

uar

Joined
Jul 21, 2015
Messages
228
Motherboard
Razer Blade, Clover
CPU
i7-6700HQ
Graphics
HD 530 / GTX 1060, 1920x1080
Mobile Phone
  1. Android
Ok, just wanted to confirm it's not just happening to me. I'm trying to figure out a dsdt patch to fix this.
Great, notify me if you find something! :thumbup:
 
Joined
Aug 17, 2010
Messages
199
Motherboard
Razer Blade 15 Mercury White
CPU
i7-8750H
Graphics
UHD 630 + GTX 1060
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Great, notify me if you find something! :thumbup:

I'm surprised this ugly fix worked but from my brief testing it seems to be ok. There appears to be a bug either in the laptop's ACPI or ACPIBatteryManager which results in the currentStatus not being updated when the power is disconnected once the battery is fully charged and no longer charging (by this I mean battery has reached fMaxCapacityRaw).

My hack is stupid simple. If the currentRate > 0 (which means it's either charging or discharging) and currentStatus=0 (which it gets stuck at because of the bug I described above), I force _BST to report a currentStatus of 0x01 (discharging). Here's the change:

In method _BST, replace:

Store (B1B2(^^EC0.ST00,^^EC0.ST01), Index (BFB0, Zero))

with:

If (LEqual (B1B2(^^EC0.ST00,^^EC0.ST01), Zero))
{
If (LGreater (B1B2(^^EC0.ST10,^^EC0.ST11), Zero))
{
Store (One, Index (BFB0, Zero))​
}
Else
{
Store (B1B2(^^EC0.ST00,^^EC0.ST01), Index (BFB0, Zero))​
}​
}
Else
{
Store (B1B2(^^EC0.ST00,^^EC0.ST01), Index (BFB0, Zero))​
}​

It may take a few seconds for the status indicator to update but it will. Good luck and I hope it works for you as well.
 
Last edited:
Joined
Mar 29, 2011
Messages
61
Motherboard
Lenovo Thinkpad T480
CPU
i7-8550u
Graphics
UHD620
sorry to interject but how much of the razer blade is working currently under sierra? I'm thinking of buying one and giving it a go, thanks
 
Joined
Aug 17, 2010
Messages
199
Motherboard
Razer Blade 15 Mercury White
CPU
i7-8750H
Graphics
UHD 630 + GTX 1060
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
sorry to interject but how much of the razer blade is working currently under sierra? I'm thinking of buying one and giving it a go, thanks

I'm on Sierra. Will be posting a guide in the near future.

It's better if I list what doesn't work:
  • Multi-gesture trackpad (should be supported soon)
  • Discrete graphics
  • HDMI out (port is hard wired to discrete graphics)
  • Wifi (you can easily replace the wifi module with a supported one. I use the BCM94532Z)
  • HDMI via USB-C adapter (still working on this)
What doesn't work well:
  • Waking from sleep takes a long time when plugged (15-30 seconds). On battery it wakes in a few seconds.
  • Webcam doesn't turn off after using it
That's about it. Hope I didn't miss anything.
 
Last edited:

uar

Joined
Jul 21, 2015
Messages
228
Motherboard
Razer Blade, Clover
CPU
i7-6700HQ
Graphics
HD 530 / GTX 1060, 1920x1080
Mobile Phone
  1. Android
For that price, I recommend you pull the trigger for a 15-inch MacBook Pro, @mdub!
 
Joined
Aug 17, 2010
Messages
199
Motherboard
Razer Blade 15 Mercury White
CPU
i7-8750H
Graphics
UHD 630 + GTX 1060
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
For that price, I recommend you pull the trigger for a 15-inch MacBook Pro, @mdub!

I have the new mbp. It's a beautiful machine but very impractical. Like the blade a lot more and will probably return the mac.
 
Joined
Mar 29, 2011
Messages
61
Motherboard
Lenovo Thinkpad T480
CPU
i7-8550u
Graphics
UHD620
Wow that's not bad. HDMI over USB-C and 2 finger trackpad scrolling are the only essentials left for me. How's the battery life? Can you use MacBookPro13,3 SMBIOS + SSDTPrgen for full CPU acceleration?
And no thanks on the new MacBook Pro, keyboard is too clicky and I want to be able to upgrade storage.
 

uar

Joined
Jul 21, 2015
Messages
228
Motherboard
Razer Blade, Clover
CPU
i7-6700HQ
Graphics
HD 530 / GTX 1060, 1920x1080
Mobile Phone
  1. Android
I have the new mbp. It's a beautiful machine but very impractical. Like the blade a lot more and will probably return the mac.
I don't recommend to return it yet. It is locked, but that is the fun with it. Couple of days ago, I managed to get eGPU support. The Core works with Maxwell architecture under macOS, not Pascal do to the lack of web drivers. You need to do a bit more to get it work, due to dGPU, but it'll do..

See here:

https://github.com/KhaosT/tb3-enabler
https://github.com/goalque/automate-eGPU

You may also download drivers from NVIDIA's website...:clap:

(Display output works on 15-inch MacBook Pro, but not on our blades...)

I did test on external monitor, not sure about the internal one...
 
Last edited:
Joined
Aug 17, 2010
Messages
199
Motherboard
Razer Blade 15 Mercury White
CPU
i7-8750H
Graphics
UHD 630 + GTX 1060
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
I don't recommend to return it yet. It is locked, but that is the fun with it. Couple of days ago, I managed to get eGPU support. The Core works with Maxwell architecture under macOS, not Pascal do to the lack of web drivers. You need to do a bit more to get it work, due to dGPU, but it'll do..

See here:

https://github.com/KhaosT/tb3-enabler
https://github.com/goalque/automate-eGPU

You may also download drivers from NVIDIA's website...:clap:

(Display output works on 15-inch MacBook Pro, but not on our blades...)

I did test on external monitor, don't think it works on the internal one...

If I need an external display I can run in Windows and make use of this nice GTX 1060. I really don't see the point of carrying around a big eGPU. Might as well just get a micro atx form factor desktop ;)

@mdub MacBookPro13,2 and 13,3 causes kernel panic for me. 13,1 freezes the machine for about a minute after booting into OSX which is annoying and doesn't seem to provide any benefit over what I'm using now (MacBookAir6,2).
 
Status
Not open for further replies.
Top