Contribute
Register

Razer Blade 15 - High Sierra 10.13.6 - Success(-)

Status
Not open for further replies.
Joined
Oct 31, 2018
Messages
32
Motherboard
Razer Blade 2017
CPU
i7-7700HQ
Graphics
GTX 1060 - UHD 630
Mobile Phone
  1. Android
  2. iOS
That's not normal, but I'm not sure what's causing that...
Check if NVRAM is working, maybe try resetting mouse preferences (deleting the settings .plist?). Did you replace the prefpane somewhen?

Solved, it was the razer synapse software
 
Joined
Feb 6, 2011
Messages
22
Motherboard
Razer Blade 15 (2018) - Clover
CPU
i7-8750H
Graphics
UHD630 + GTX1070 (disabled)
Mobile Phone
  1. Android
  2. iOS
Has anyone been able to run with multiple monitors?

I have the GTX disabled and TB3 is outputting to an external monitor nicely, but both the HDMI and mDP are blank...Are they both connected to the GTX, so that is the reason or is it maybe just due to framebuffer patching for connectors being required?

If HDMI and mDP can't work without GTX, does anyone know if Razer is still connecting only one DP signal to TB3, or can multiple monitors be driven by TB3 now without MST?

Basically, I'd just want to be able to drive 2 external monitors for work...had no issues on my previous XPS 9560 :(

Thanks!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have the GTX disabled and TB3 is outputting to an external monitor nicely, but both the HDMI and mDP are blank...Are they both connected to the GTX, so that is the reason or is it maybe just due to framebuffer patching for connectors being required?

Check in Windows so you know for sure how each is connected.
 
Joined
Jul 24, 2013
Messages
124
Motherboard
Razer Blade 15 (2018)
CPU
I7-8750H
Graphics
GTX 1070HQ
Mac
  1. iMac
  2. MacBook
  3. Mac mini
Classic Mac
  1. iBook
  2. iMac
Mobile Phone
  1. iOS
Has anyone been able to run with multiple monitors?

I have the GTX disabled and TB3 is outputting to an external monitor nicely, but both the HDMI and mDP are blank...Are they both connected to the GTX, so that is the reason or is it maybe just due to framebuffer patching for connectors being required?

If HDMI and mDP can't work without GTX, does anyone know if Razer is still connecting only one DP signal to TB3, or can multiple monitors be driven by TB3 now without MST?

Basically, I'd just want to be able to drive 2 external monitors for work...had no issues on my previous XPS 9560 :(

Thanks!
Some people have mentioned above that the HDMI and mDP ports are connected to the Nvidia GPU. Not sure if it is only one DP signal to the TB3 port though.
 
Joined
Oct 31, 2013
Messages
78
Motherboard
Razer Blade 15, 2019
CPU
i7-8750H
Graphics
UHD 630, GTX 2070
Mac
  1. iMac
Mobile Phone
  1. iOS
So, if the problem of the 3 minutes of blacklight is because able the brightness natively in the laptop, it is not better do have it disable and use the Brightness control app? and with this would work the laptop without the 3 minutes and will have the sleep mode working too?

It is possible to install everything to have the sleep mode working and not have enable the brightness to avoid the 3 minutes of blacklight?
 
Last edited:
Joined
Dec 8, 2011
Messages
546
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
So, if the problem of the 3 minutes of blacklight is because able the brightness natively in the laptop, it is not better do have it disable and use the Brightness control app? and with this would work the laptop without the 3 minutes and will have the sleep mode working too?

It is possible to install everything to have the sleep mode working and not have enable the brightness to avoid the 3 minutes of blacklight?

Can't really answer this unless it's tried. But if I remember correctly, without brightness controls implemented properly, the laptop will sleep, but wakes up to a black screen that is only fixed with a reboot. Personally, I'd rather deal with the 3 minute back light issue and have native brightness and fully functioning sleep. The app that "mimics brightness control" doesn't really work all that well and certain things don't get dimmed, like the mouse cursor and certain system icons and messages.

Also it's really not a 3 minute bug because all you have to do is put the laptop to sleep right after booting it and wake it back up and brightness then works. So it's more like a 1 minute bug.

With working sleep, the back light bug really shouldn't be much of an issue for anyone. Since most of the time you will end up putting the laptop to sleep rather than shutting it down completely. The back light bug is only present on boot after rebooting or shutting down the laptop. It is not present when you put the laptop to sleep and wake it back up, or when the display shuts off from inactivity. It's only a boot up bug.
 
Joined
Nov 27, 2012
Messages
49
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 144hz 1080p display.
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I'm torn between this. The no backlight after sleep is def something I run into several times a day. I might go back and get the proper backlight controls working with the 3 minute bug. Which osx version are you all running now?
 
Joined
Dec 8, 2011
Messages
546
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
I'm torn between this. The no backlight after sleep is def something I run into several times a day. I might go back and get the proper backlight controls working with the 3 minute bug. Which osx version are you all running now?

I have my drive partitioned and bounce back and forth between High Sierra (Build 17G3025) and the latest version of Mojave. I've been favoring Mojave lately because I enjoy the dark theme. But functionality wise, they're the same.
 
Joined
Dec 8, 2011
Messages
546
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Has anyone here experienced random system freezes/crashes after a few hours of using the laptop?
 
Joined
Oct 31, 2013
Messages
78
Motherboard
Razer Blade 15, 2019
CPU
i7-8750H
Graphics
UHD 630, GTX 2070
Mac
  1. iMac
Mobile Phone
  1. iOS
Has anyone here experienced random system freezes/crashes after a few hours of using the laptop?
Mine it is working like rock, the only thing is that ometimes when I restart the loading bar doesnt load, and I have to restart, but the third time I restart works well, appart from this all great. I am not in the version that has the brightness native yet, still waiting to see if someone fix the 3 minutes backlight.
 
Status
Not open for further replies.
Top