Contribute
Register

Razer Blade 15 - High Sierra 10.13.6 - Success(-)

Status
Not open for further replies.
Joined
Aug 17, 2010
Messages
199
Motherboard
Razer Blade 15 Mercury White
CPU
i7-8750H
Graphics
UHD 630 + GTX 1060
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Thank you, same issue, did all you said, I don't know what's wrong, no gestures and when I move the cursor it doesn't stop to move until I do a click. Attached there's debug file

Looks like you have the 2017 blade which probably has a different I2C controller. You'll need to find out what that is for your laptop with IORegistryExplorer and make the changes vettz500 mentioned to the VoodooI2C.kext assuming it's compatible.
 
Joined
Oct 31, 2018
Messages
32
Motherboard
Razer Blade 2017
CPU
i7-7700HQ
Graphics
GTX 1060 - UHD 630
Mobile Phone
  1. Android
  2. iOS
Looks like you have the 2017 blade which probably has a different I2C controller. You'll need to find out what that is for your laptop with IORegistryExplorer and make the changes vettz500 mentioned to the VoodooI2C.kext assuming it's compatible.

Looking at IORegistryExplorer looks like it's. the pci8086,a160 .. I may be wrong, should be supported tho
 
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Looking at IORegistryExplorer looks like it's. the pci8086,a160 .. I may be wrong, should be supported tho

Didn't realize that you were using the 2017 version, my bad for not looking at that first. You have an entirely different trackpad, as it looks, you will only get basic functionality out of it, no gestures. Earlier you mentioned you got it working with basic functionality following an old guide and using those old modified kexts, that looks to be your only option at the moment.
But maybe the VoodooI2C thread can help you with adding some extra functionality.
See here: https://www.tonymacx86.com/threads/voodooi2c-help-and-support.243378/

That's about as far as any of us can help you get on this thread, as we don't have the same hardware, so we can't really test to help you out some. The guys on the VoodooI2C thread will have a lot more information that they can help you out with.
 
Joined
Oct 31, 2018
Messages
32
Motherboard
Razer Blade 2017
CPU
i7-7700HQ
Graphics
GTX 1060 - UHD 630
Mobile Phone
  1. Android
  2. iOS
Didn't realize that you were using the 2017 version, my bad for not looking at that first. You have an entirely different trackpad, as it looks, you will only get basic functionality out of it, no gestures. Earlier you mentioned you got it working with basic functionality following an old guide and using those old modified kexts, that looks to be your only option at the moment.
But maybe the VoodooI2C thread can help you with adding some extra functionality.
See here: https://www.tonymacx86.com/threads/voodooi2c-help-and-support.243378/

That's about as far as any of us can help you get on this thread, as we don't have the same hardware, so we can't really test to help you out some. The guys on the VoodooI2C thread will have a lot more information that they can help you out with.

thank you anyways :) another question, I tried also the Nvidia patch to disable gpu but it didn't work for me, do I have to edit also clover config file?

attached the file I made in order to disable gpu, maybe I did something wrong
 

Attachments

  • SSDT-10-OptTabl.aml.zip
    4.7 KB · Views: 51
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
thank you anyways :) another question, I tried also the Nvidia patch to disable gpu but it didn't work for me, do I have to edit also clover config file?

attached the file I made in order to disable gpu, maybe I did something wrong

I don't see either of the 2 patches that are needed to disable the Nvidia GPU in that SSDT file. You're missing both. Maybe you made one with the patches and accidentally added the original to your patched folder?
 
Joined
Oct 31, 2018
Messages
32
Motherboard
Razer Blade 2017
CPU
i7-7700HQ
Graphics
GTX 1060 - UHD 630
Mobile Phone
  1. Android
  2. iOS
I don't see either of the 2 patches that are needed to disable the Nvidia GPU in that SSDT file. You're missing both. Maybe you made one with the patches and accidentally added the original to your patched folder?
weird ... looks like MaciASL doesn't save edits.. well it removes "
External (_SB_.PCI0.PEG0.TGPC, IntObj) // (from opcode)" but looks like the patch part it's not saved
 
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
weird ... looks like MaciASL doesn't save edits.. well it removes "
External (_SB_.PCI0.PEG0.TGPC, IntObj) // (from opcode)" but looks like the patch part it's not saved
It does save edits. Something was missed or done incorrectly along the way.
 
Joined
Oct 31, 2018
Messages
32
Motherboard
Razer Blade 2017
CPU
i7-7700HQ
Graphics
GTX 1060 - UHD 630
Mobile Phone
  1. Android
  2. iOS
tried 4-5 times, I may try to redownload MaciASL, I also tried to save as a new file .. same.. if I search
"Method (_INI) {_OFF() } // added to call _OFF" after I close the file and reopen it's not there. weird because it deletes
"External (_SB_.PCI0.PEG0.TGPC, IntObj) // (from opcode)"
 
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
tried 4-5 times, I may try to redownload MaciASL, I also tried to save as a new file .. same.. if I search
"Method (_INI) {_OFF() } // added to call _OFF" after I close the file and reopen it's not there. weird because it deletes
"External (_SB_.PCI0.PEG0.TGPC, IntObj) // (from opcode)"
Did you disassemble the AML files?

If you're opening the SSDT-10-OptTabl.aml file, you are doing it wrong. It needs to be disassembled to a .dsl file in order to work with properly.
Once you do that and save it, the edits will take.
 
Joined
Oct 31, 2018
Messages
32
Motherboard
Razer Blade 2017
CPU
i7-7700HQ
Graphics
GTX 1060 - UHD 630
Mobile Phone
  1. Android
  2. iOS
Did you disassemble the AML files?

If you're opening the SSDT-10-OptTabl.aml file, you are doing it wrong. It needs to be disassembled to a .dsl file in order to work with properly.
Once you do that and save it, the edits will take.

Yes, if I save it as .dsl everything is fine.. when I save it as .aml it doesn't save changes
 
Status
Not open for further replies.
Top