Contribute
Register

Razer Blade 15 - High Sierra 10.13.6 - Success(-)

Status
Not open for further replies.
Joined
Sep 2, 2013
Messages
87
Motherboard
Lenovo Thinkpad X1 Yoga 20FQ
CPU
i7-6600U
Graphics
HD 520
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
  2. iOS
Now the only thing left to fix is brightness (backlight stops working during early boot using SSDT-PNLF and AppleBacklightInjector, probably need to change PWMMax) and sleep (immediate wake from sleep (possibly USB issue?) and no screen after sleep)
 

Attachments

  • CLOVER.zip
    2.8 MB · Views: 123
  • razerblade15.ioreg.zip
    766.1 KB · Views: 71
  • DSDT.dsl
    1.8 MB · Views: 169
Joined
Nov 27, 2012
Messages
49
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 144hz 1080p display.
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I've managed to get battery status working as well. The battery patch for razer blade 2014 needs to be applied as well as this patch:

Code:
into device label H_EC code_regex BIF0,\s+16, replace_matched begin IF00,8,IF01,8, end;

into method label _BIF code_regex \(\^\^EC0.BIF0, replaceall_matched begin (B1B2(\^\^EC0.IF00,\^\^EC0.IF01), end;

Good job man, I _almost_ had it working, but my patch for fixing BIF0 didn't work. I'll try all of this out and see how it works.
 
Last edited:
Joined
Nov 27, 2012
Messages
49
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 144hz 1080p display.
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Now the only thing left to fix is brightness (backlight stops working during early boot using SSDT-PNLF and AppleBacklightInjector, probably need to change PWMMax) and sleep (immediate wake from sleep (possibly USB issue?) and no screen after sleep)

This is my main problem now. When I switched to the 15,2 High Sierra version 17G2112 the backlight is turned off 90% of the time when I boot, then if I wait about 2-3 minutes it comes on. What is interesting is that the nvram value is correct when it boots. I patched out the ambient light sensor to see if that fixed it, but it didn't make any difference.

When I boot into the installer it has the same issue, so my high sierra install is not the reason. I might roll back to the older version of sierra.
 
Last edited:
Joined
Nov 27, 2012
Messages
49
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 144hz 1080p display.
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I assumed that gestures wouldn't work; they didn't on the older blade. Were you able to get basic functionality?

I did get HDMI working, however only through the Nvidia GPU. I think that having the Intel UHD control an external display isn't possible due to how it's hooked up internally.



I used the DW-1560. It works really well under macOS and only requires FakePCIID and FakePCIID_Broadcom_WiFi kexts


I got the DW-1560, it works great. Minus bluetooth, I haven't had time looking into that issue yet.
 
Joined
Nov 27, 2012
Messages
49
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 144hz 1080p display.
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Good news!

I've managed to get the touchpad working using the VoodooI2C and VoodooI2CHID kexts and by changing a few things in the DSDT:
First, make sure _STA in GPI0 device only returns 0x0F
Then, make sure _CRS in every TPD0 instance only returns
Code:
ConcatenateResTemplate (SBFB, SBFI)

For convenience I've created this DSDT patch (paste in MaciASL patch window):

Code:
into method label _STA parent_label GPI0 replace_content begin

Return (0x0F)

end;

into_all method label _CRS parent_label TPD0 replace_content begin

ConcatenateResTemplate (SBFB, SBFI)

end;



Also, the info.plist of the VoodooI2C needs to be edited so that it will load with the I2C controller. Under IOKitPersonalities > VoodooI2CPCIController > IONameMatch add a field with a string value of pci8086,a368 (Could probably be done with a clover kext patch / will probably be fixed in a later version of VoodooI2C)

P.S. scroll and some gestures seem to work as well, which is a nice bonus!

You are a wizard.
 
Joined
Nov 27, 2012
Messages
49
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 144hz 1080p display.
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I wanted to keep from updating the EFI on my main SSD so I boot from a USB. I think this is what is causing my NVRAM to behave somewhat strange because from what I can tell I get two nvram.plist files (one on my USB drive and one on my main SSD). sudo nvram -p shows that none of my changes are persisted between boots.

Basically the behavior I wanted was to have the laptop boot into windows when there is not a USB stick installed. I notice that you also have EmuVariable efi with Aptio.I had the laptop writing to my main NVRAM once (I would verify it in dmpstore), but I have not been able to get that working again.

My questions are;
a) Are you using APFS on your drive?
b) Did you extend your main EFI boot partition to install clover on your main SSD?
c) Is your nvram working properly?
d) Is EmuVariable needed?
e) Did you upgrade to 17G2112?
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,933
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I've managed to get battery status working as well. The battery patch for razer blade 2014 needs to be applied as well as this patch:

Code:
into device label H_EC code_regex BIF0,\s+16, replace_matched begin IF00,8,IF01,8, end;

into method label _BIF code_regex \(\^\^EC0.BIF0, replaceall_matched begin (B1B2(\^\^EC0.IF00,\^\^EC0.IF01), end;

You need to attach native DSDT.
The DSDT.aml you attached is already patched.
 
Joined
Nov 27, 2012
Messages
49
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 144hz 1080p display.
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Bluetooth working credit uar:

Bluetooth:
  • Download latest BrcmPatchRAM bundle from RehabMan's bitbucket page.
  • Take "BrcmPatchRAM2.kext" and "BrcmFirmwareRepo.kext" from the "Release" folder and install them in SLE.
  • Restart.
 
Joined
Nov 27, 2012
Messages
49
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 144hz 1080p display.
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I've managed to get battery status working as well. The battery patch for razer blade 2014 needs to be applied as well as this patch:

Code:
into device label H_EC code_regex BIF0,\s+16, replace_matched begin IF00,8,IF01,8, end;

into method label _BIF code_regex \(\^\^EC0.BIF0, replaceall_matched begin (B1B2(\^\^EC0.IF00,\^\^EC0.IF01), end;

This patch didn't work for me. The first line didn't match the replacement, so I just hand changed it to IF00, 8 IF01, 8
 
Status
Not open for further replies.
Top