Contribute
Register

Razer Blade 15 - High Sierra 10.13.6 - Success(-)

Status
Not open for further replies.
Joined
Nov 27, 2012
Messages
49
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 144hz 1080p display.
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hardware:
Razer Blade 15
32 GB Memory
1080p 144hz IPS panel
GTX 1070 max q

What works:
- UHD 630
- Wifi using a dongle (AC53 NANO)

What doesn't work
- Sound (I had it working at one point, but I prioritized iGPU and stable boot first)
- Track pad (use external mouse for now)
- Nvidia GFX card

This is going to be short, but I'll type up a more detailed report when it's all done (and I get some sleep). I spent several days on this (hundreds of reboots) and finally got a stable boot and most importantly UHD 630 working on the internal screen.

So, fear not, it is possible. No glitchy gfx and 2GB of memory reported on the iGFX card.
 
Joined
Mar 13, 2013
Messages
8
Motherboard
OS 8.2
CPU
i7 3730
Graphics
GT650M
Mac
Classic Mac
Mobile Phone
Hardware:
Razer Blade 15
32 GB Memory
1080p 144hz IPS panel
GTX 1070 max q

What works:
- UHD 630
- Wifi using a dongle (AC53 NANO)

What doesn't work
- Sound (I had it working at one point, but I prioritized iGPU and stable boot first)
- Track pad (use external mouse for now)
- Nvidia GFX card

This is going to be short, but I'll type up a more detailed report when it's all done (and I get some sleep). I spent several days on this (hundreds of reboots) and finally got a stable boot and most importantly UHD 630 working on the internal screen.

So, fear not, it is possible. No glitchy gfx and 2GB of memory reported on the iGFX card.

That's amazing!

I just received my Razer Blade 15 today, i created the usb key with unibeast and mac os x high sierra 10.13.6 -
After setting up some BIOS options i managed to launch the pre installer boot, and the Apple logo + progress bar arrives till the middle, but then suddenly the computer reboots.

I tried different bios options, and the ones i have set are the only one who lets me boot into mac os installer.

I guess you know more than me on that plan :))

Anymore details on how to go at least in the mac os x installer ?

Looking forward to your guide !
Best

Laurent
--
--
 
Joined
Nov 27, 2012
Messages
49
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 144hz 1080p display.
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
That's amazing!

I just received my Razer Blade 15 today, i created the usb key with unibeast and mac os x high sierra 10.13.6 -
After setting up some BIOS options i managed to launch the pre installer boot, and the Apple logo + progress bar arrives till the middle, but then suddenly the computer reboots.

I tried different bios options, and the ones i have set are the only one who lets me boot into mac os installer.

I guess you know more than me on that plan :))

Anymore details on how to go at least in the mac os x installer ?

Looking forward to your guide !
Best

Laurent
--
--

I created another 500GB partition on my main SSD. Then I created a bootable installed using unibeast on a usb stick. Using clover directly never worked as it would never show up as a bootable device.

My final setup is still to use a USB stick with the Clover EFI installer on it to prevent having Clover installed on my main ssd. This is just to keep things cleaner incase something messes up.

For boot:
- slide=0 is required if not you will get a stop sign (error allocating pages during boot). If you still have issues booting CrsActiveConfig should be 0x67
- do not inject any gfx drivers now (nvidia or intel or the 3rd option, forgot what it is)
- nv_disable=1
- dart=0

For BIOS - Disable fast boot and secure boot.

This should get you into installing osx and your gfx should show up with just 7mb of memory. The fun begins after that.
I just got sound working also.

FIY, I do not use apfs.efi, but I have it included. Not sure if it works or not. Attached is EFI folder. That would probably make your life easier AFTER you got OSX installed and an EFI partition created somewhere (I would recommend just using another USB stick for it)

I never installed the kext into s/l/e or l/e even though that's considered best practice. What is important to copy is the config.plist, kext/Other, drivers64UEFI, ACPI/patched.

I MIGHT work on getting the nvidia card to work, but afaik it will only work on external displays. One thing which doesn't work is the HDMI port. I haven't tried the DP. I suspect this has to to with wrong frame buffer mappings.
Roger
 

Attachments

  • EFI.zip
    4.2 MB · Views: 346
Joined
Nov 27, 2012
Messages
49
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 144hz 1080p display.
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
And do not make any changes on your bootable usb stick with the installer. That will become your lifesaver if you cannot boot any other way. Just remember the slide=0 etc to get it up and running again. That way you can just mount the EFI folder which is messed up and configure it to get it working again. Hopefully my EFI zip should work out for you.
 
Joined
Mar 13, 2013
Messages
8
Motherboard
OS 8.2
CPU
i7 3730
Graphics
GT650M
Mac
Classic Mac
Mobile Phone
I created another 500GB partition on my main SSD. Then I created a bootable installed using unibeast on a usb stick. Using clover directly never worked as it would never show up as a bootable device.

My final setup is still to use a USB stick with the Clover EFI installer on it to prevent having Clover installed on my main ssd. This is just to keep things cleaner incase something messes up.

For boot:
- slide=0 is required if not you will get a stop sign (error allocating pages during boot). If you still have issues booting CrsActiveConfig should be 0x67
- do not inject any gfx drivers now (nvidia or intel or the 3rd option, forgot what it is)
- nv_disable=1
- dart=0

For BIOS - Disable fast boot and secure boot.

This should get you into installing osx and your gfx should show up with just 7mb of memory. The fun begins after that.
I just got sound working also.

FIY, I do not use apfs.efi, but I have it included. Not sure if it works or not. Attached is EFI folder. That would probably make your life easier AFTER you got OSX installed and an EFI partition created somewhere (I would recommend just using another USB stick for it)

I never installed the kext into s/l/e or l/e even though that's considered best practice. What is important to copy is the config.plist, kext/Other, drivers64UEFI, ACPI/patched.

I MIGHT work on getting the nvidia card to work, but afaik it will only work on external displays. One thing which doesn't work is the HDMI port. I haven't tried the DP. I suspect this has to to with wrong frame buffer mappings.
Roger

Thank you for your help !

Maybe im a bit stupid, so i replaced my EFI folder on my usb installer with yours, and now it doesnt see any OS X external
to boot, is this normal ?

It only sees the internal NTFS partition, what did i do wrong ?
 
Joined
Nov 27, 2012
Messages
49
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 144hz 1080p display.
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I said: "And do not make any changes on your bootable usb stick with the installer".

:) You have to start over. Create a unibeast usb stick again. Have a separate one you make changes to AFTER you have installed the OSX.

So:
1) Create unibeast installer usb
2) Install osx (with the flags mentioned above)
3) Create another usb bootable stick and copy only the things I mentioned over to the EFI folder. Do NOT copy the entire EFI folder.
 
Joined
Mar 13, 2013
Messages
8
Motherboard
OS 8.2
CPU
i7 3730
Graphics
GT650M
Mac
Classic Mac
Mobile Phone
I said: "And do not make any changes on your bootable usb stick with the installer".

:) You have to start over. Create a unibeast usb stick again. Have a separate one you make changes to AFTER you have installed the OSX.

So:
1) Create unibeast installer usb
2) Install osx (with the flags mentioned above)
3) Create another usb bootable stick and copy only the things I mentioned over to the EFI folder. Do NOT copy the entire EFI folder.

Oh, ok will redo it then, no worries, thanks for explaining it in details.

Will come back here tmw i hope with that installation done !
 
Joined
Mar 13, 2013
Messages
8
Motherboard
OS 8.2
CPU
i7 3730
Graphics
GT650M
Mac
Classic Mac
Mobile Phone
I said: "And do not make any changes on your bootable usb stick with the installer".

:) You have to start over. Create a unibeast usb stick again. Have a separate one you make changes to AFTER you have installed the OSX.

So:
1) Create unibeast installer usb
2) Install osx (with the flags mentioned above)
3) Create another usb bootable stick and copy only the things I mentioned over to the EFI folder. Do NOT copy the entire EFI folder.
I Finally managed to boot into the installer and from there to install mac os x on a separate USB external SSD.
But im still hanging at getting Clover to work, and there are so many options to click on, with those drivers stuff
that i think the best is i sell the Razer Blade and buy a MacBook Pro 2018 instead, so that im avoiding 100 reboot and weeks of trial to install OS X.
An os x install should take no more than 20 min on a real MacBook Pro, that way no need to type line of script and
the internal dedicated graphic card will be recognised, i think if you have time to loose, hackintosh is great but if you want
to really use Mac OS X, its right now almost mission impossible on something else than a Mac.

They seem to have well protected their software.

I spent the night on it and another half of the day, no way im continuing further im packing the Razer Blade
bringin it back to the retailer and driving to the Apple Store to buy the mac instead.

Whishing you guys a great headache :)

Back from the Apple Store now, i wanted to say that in terms of screen gamut and quality, Apple beats from far the Razer Blade.
Check the MBPro 2018, the screen quality is just insain.
 
Joined
Sep 2, 2013
Messages
87
Motherboard
Lenovo Thinkpad X1 Yoga 20FQ
CPU
i7-6600U
Graphics
HD 520
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
  2. iOS
Hey I finally managed to boot with functioning graphics! I noticed however, when using SSDT-PNLF to add brightness control, it would boot to black screen again.

However, I've decided to prioritize trackpad (I2C). Has there been any progress here? I tried patching DSDT with different pin-list values (0x4C, 0x34, 0x94) for VoodooI2C but whatever I do I can't get the touchpad to work, and the VoodooI2C kext doesn't print any info or even load! (kextstat only shows VoodooI2CServices is loaded.)
 

Attachments

  • CLOVER.zip
    2.7 MB · Views: 202
Joined
Nov 27, 2012
Messages
49
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 144hz 1080p display.
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hey I finally managed to boot with functioning graphics! I noticed however, when using SSDT-PNLF to add brightness control, it would boot to black screen again.

However, I've decided to prioritize trackpad (I2C). Has there been any progress here? I tried patching DSDT with different pin-list values (0x4C, 0x34, 0x94) for VoodooI2C but whatever I do I can't get the touchpad to work, and the VoodooI2C kext doesn't print any info or even load! (kextstat only shows VoodooI2CServices is loaded.)

Awesome, I did some reading on getting this to work, and it almost seems like it's not worth it. You can get some basic functionality working, but gestures will not (because the synapse drivers have not been kept up to date).

I'm also moving over to whatevergreen, and my main issue now is the brightness control and being able to connect another display (using iGPU) to HDMI, that doesn't work at all at the moment. Were you able to get your HDMI working?
 
Status
Not open for further replies.
Top