Contribute
Register

Random usb and audio freeze but monitor still working

Joined
Aug 11, 2020
Messages
12
Motherboard
Intel DH67BL
CPU
Intel Core i7-3770
Graphics
Msi gaming-X RX 480 4gb
Mac
  1. iMac
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Oh sorry...i made a mistake.

I was speaking about appleALC... when i set the channel 1 for audio in my config.plist which i think is the correct one for my mobo but when i update it trought kextupdater the audio isn't working at all.
 

Edhawk

Moderator
Joined
Aug 2, 2013
Messages
2,493
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
HD 4600 / RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
What is this 'kextupdater' app you are using?

If your Audio worked with a previous version of AppleALC.kext, use the older version of the kext it is not mandatory to update the kexts, especially if they are working. All the new kext will bring is processes for new/additional audio codecs to work, which will add nothing for your old system.

Don't update the kext in the future, unless you are looking to run a major update for the OS, i.e. updating from Catalina to Big Sur. In which case it might be necessary to update a few of the kexts such as Lilu.kext and VirtualSMC.kext.

Have you checked your Sound preference pane to make sure your speakers are selected for audio output?
 
Last edited:
Joined
Aug 11, 2020
Messages
12
Motherboard
Intel DH67BL
CPU
Intel Core i7-3770
Graphics
Msi gaming-X RX 480 4gb
Mac
  1. iMac
Classic Mac
  1. iMac
Mobile Phone
  1. Android
What is this 'kextupdater' app you are using?

If your Audio worked with a previous version of AppleALC.kext, use the older version of the kext it is not mandatory to update the kexts, especially if they are working. All the new kext will bring is processes for new/additional audio codecs to work, which will add nothing for your old system.

Don't update the kext in the future, unless you are looking to run a major update for the OS, i.e. updating from Catalina to Big Sur. In which case it might be necessary to update a few of the kexts such as Lilu.kext and VirtualSMC.kext.

Have you checked your Sound preference pane to make sure your speakers are selected for audio output?
"Kext Updater" is an app which consent to you to update your kext automatically...it recognise which kexts are in your efi partition and search online for updates.

When a kext is an old version of it, the tool download the latest version of the kext and put it into a folder on desktop.

When you have that folder you can simply drag and drop the newer kext to your efi.


YESTERDAY I UPDATED AND PASTED THE KEXT INTO MY FOLDER AND REBOOTED MY COMPUTER IT SEEMS TO BE WORKING.
 
Top