Contribute
Register

Random Freezes When Plugging Charger Port

Joined
Mar 28, 2015
Messages
132
Motherboard
MSI GS65 8SE
CPU
i7-8750H
Graphics
UHD 630 + RTX 2060
Mac
MacBook Pro
Mobile Phone
Android
I have a MSI GE62 Apache Pro laptop.
Everything has been running great, which no major problems in my computer, all minor (like needing to remap brightness keys)
but one problem I have been facing is every once in a while, when I plug my charger, my laptop suddenly freezes.
I've been trying to see what is causing this issue and how can I fix it but I am having no luck.

Power management seems to be working fine since I used Rehabman's guide to stabilize the laptop.
Any help will be appreciated.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I have a MSI GE62 Apache Pro laptop.
Everything has been running great, which no major problems in my computer, all minor (like needing to remap brightness keys)
but one problem I have been facing is every once in a while, when I plug my charger, my laptop suddenly freezes.
I've been trying to see what is causing this issue and how can I fix it but I am having no luck.

Power management seems to be working fine since I used Rehabman's guide to stabilize the laptop.
Any help will be appreciated.
See ACPI patching guide:
https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/
 
Joined
Mar 28, 2015
Messages
132
Motherboard
MSI GS65 8SE
CPU
i7-8750H
Graphics
UHD 630 + RTX 2060
Mac
MacBook Pro
Mobile Phone
Android
Alright I read the patching guide and I assume you want me to make sure I have used the patches:
"Fix _WAK Arg0 v2"
"HPET Fix"
"SMBUS Fix"
"IRQ Fix"
"RTC Fix"
"OS Check Fix"
"Fix Mutex with non-zero SyncLevel"
"Fix PNOT/PPNT" (use only if you're dropping CPU related SSDTs)
"Add IMEI" (do not use if your DSDT or SSDTs already have IMEI/HECI/MEI device)
correct? or am I looking at the wrong section of the guide?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Alright I read the patching guide and I assume you want me to make sure I have used the patches:

correct? or am I looking at the wrong section of the guide?
Well, you need to read about each patch and decide if it for your hardware or not.
But an "OS Check Fix" patch is one of the more important ones and is almost always needed.
"RTC Fix" is usually required too.
As is disabling the Nvidia device (especially if it is Nvidia Optimus).
 
Joined
Mar 28, 2015
Messages
132
Motherboard
MSI GS65 8SE
CPU
i7-8750H
Graphics
UHD 630 + RTX 2060
Mac
MacBook Pro
Mobile Phone
Android
But an "OS Check Fix" patch is one of the more important ones and is almost always needed.
"RTC Fix" is usually required too.
I already have these patches. The "OS Fix" because I was trying to remap my keyboard brightness keys and I couldn't see the keyboard PS2 response. And I already implemented "RTC Fix" to disable Nvidia GPU properly. I will see if every other patch that corresponds my hardware is implemented and will let you know if the problem persist.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I already have these patches.
The files you attached in post #1 prove your assertion false (no handling of _OSI("Darwin") in patched/DSDT.aml).
 
Joined
Mar 28, 2015
Messages
132
Motherboard
MSI GS65 8SE
CPU
i7-8750H
Graphics
UHD 630 + RTX 2060
Mac
MacBook Pro
Mobile Phone
Android
The files you attached in post #1 prove your assertion false (no handling of _OSI("Darwin") in patched/DSDT.aml).
Okay. I repatched them and I the problem still persists. Usually on the third time plugging in the charger it freezes completely.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Okay. I repatched them and I the problem still persists. Usually on the third time plugging in the charger it freezes completely.
AppleAHCIPort.kext should not be patched. Restore by running the macOS installer.
Related, you forgot to install SATA-unsupported.kext.

Your drivers64UEFI is wrong. Refer to the guide:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Your USB configuration is wrong.
Refer to the guide:
https://www.tonymacx86.com/threads/guide-creating-a-custom-ssdt-for-usbinjectall-kext.211311/

ACPIDebug.kext is not for long term use. Remove when you're done analyzing ACPI. Also remove the RMDT code from patched/DSDT.aml.

FakeSMC sensor kexts are inefficient, not necessary. Remove.

Remove other third party software: com.displaylink.driver.DisplayLinkDriver

You need to cleanup ACPI/patched (it is full of files that don't apply). Keep backup/experimental ACPI files somewhere else.
 
Joined
Mar 28, 2015
Messages
132
Motherboard
MSI GS65 8SE
CPU
i7-8750H
Graphics
UHD 630 + RTX 2060
Mac
MacBook Pro
Mobile Phone
Android
AppleAHCIPort.kext should not be patched. Restore by running the macOS installer.
Related, you forgot to install SATA-unsupported.kext.

Your drivers64UEFI is wrong. Refer to the guide:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Your USB configuration is wrong.
Refer to the guide:
https://www.tonymacx86.com/threads/guide-creating-a-custom-ssdt-for-usbinjectall-kext.211311/

ACPIDebug.kext is not for long term use. Remove when you're done analyzing ACPI. Also remove the RMDT code from patched/DSDT.aml.

FakeSMC sensor kexts are inefficient, not necessary. Remove.

Remove other third party software: com.displaylink.driver.DisplayLinkDriver

You need to cleanup ACPI/patched (it is full of files that don't apply). Keep backup/experimental ACPI files somewhere else.
Will do. Once I have all of these steps done then I will let you know whether or not it freezes or not.
 
Joined
Mar 28, 2015
Messages
132
Motherboard
MSI GS65 8SE
CPU
i7-8750H
Graphics
UHD 630 + RTX 2060
Mac
MacBook Pro
Mobile Phone
Android
AppleAHCIPort.kext should not be patched. Restore by running the macOS installer.
AppleAHCIPort.kext is not patched. I accidentally deleted from /Library/Extensions and when I restored from trash I started getting the "Kext with invalid signature allowed" for that kext.

Your drivers64UEFI is wrong. Refer to the guide:
Okay. I followed this guide but now brightness does not recover from last position it was in. It goes back to full brightness.

I disabled the "15 port limit patch" that was in my config.plist file. Everything else is fine, the custom ssdt is in /ACPI/Patched/ and USBInjectAll.kext is in /Library/Extensions/.

ACPIDebug.kext is not for long term use. Remove when you're done analyzing ACPI. Also remove the RMDT code from patched/DSDT.aml.
I removed this too from dsdt and the kext.

FakeSMC sensor kexts are inefficient, not necessary. Remove.
Removed.

Remove other third party software: com.displaylink.driver.DisplayLinkDriver
Also removed.

You need to cleanup ACPI/patched (it is full of files that don't apply). Keep backup/experimental ACPI files somewhere else.
I removed them from Clover and is now in another folder.

The problem still persists. After plugging in the charger 3 times, it freezes.
 

Attachments

Top