Contribute
Register

Radeon VII +UHD630 = Random Freezes, Moving Cursor, Slowdown - 10.14.4 / 5

Joined
May 11, 2011
Messages
1,171
Motherboard
Asrock B365M Phantom Gaming
CPU
i5-9600KF
Graphics
RX 580
Mobile Phone
iOS
OK, last try, also use the lasted WEG.
Remember to use 128 mb for multi monitor, that's for IGPU and those errors.
 

Attachments

Joined
Jan 21, 2012
Messages
35
Motherboard
Asrock Fatal1ty Z370 Gaming-ITX/ac-Clover
CPU
i7-8700K
Graphics
Radeon VII + UHD 630
Well there’s good news and bad I guess.

Good news is it boots into macOS... bad news is that it still freezes. I’m not sure what else to do.... upon reboot it also locked up during boot (as it usually does the first reboot after a freeze). Another reset will get it to load back into macOS.

Again, thank you for your help. I will say that when it is running between freezes, subjectively it does feel faster and smoother.
 

Attachments

Joined
Jan 21, 2012
Messages
35
Motherboard
Asrock Fatal1ty Z370 Gaming-ITX/ac-Clover
CPU
i7-8700K
Graphics
Radeon VII + UHD 630
One other thing I just noticed - and not sure if this is related or not - but FakeSMC doesn't appear to be loaded. Could that be an issue? I seem to recall reading that FakeSMC is basically the only essential kext that must be loaded for a Hackintosh...
 

Attachments

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
23,271
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
FakeSMC doesn't appear to be loaded
That's because you have VirtualSMC.kext, the two do the same job and are mutually exclusive.
Use one or the other but not both.
 
Joined
Jan 21, 2012
Messages
35
Motherboard
Asrock Fatal1ty Z370 Gaming-ITX/ac-Clover
CPU
i7-8700K
Graphics
Radeon VII + UHD 630
I’m really confused by why virtualsmc is there because I deleted it to install Fakesmc literally before taking that screenshot and rebooting
 
Joined
May 11, 2011
Messages
1,171
Motherboard
Asrock B365M Phantom Gaming
CPU
i5-9600KF
Graphics
RX 580
Mobile Phone
iOS
I’m really confused by why virtualsmc is there because I deleted it to install Fakesmc literally before taking that screenshot and rebooting
Did you enable igpu in bios? PEG as first and IGPU as second, 128 mb.
Take a screen shoot with your desktop, do you have transparency? Fast animation ?
Also try in Bios to switch from UEFI to Legacy/CSM, I heard UEFI is causing problems to Radeon VII.
 
Joined
Jan 21, 2012
Messages
35
Motherboard
Asrock Fatal1ty Z370 Gaming-ITX/ac-Clover
CPU
i7-8700K
Graphics
Radeon VII + UHD 630
Yes IGPU is enabled, pEG is primary. 128mb is set. Transparency and fast animation both enabled. In Bios, CSM was active already and it was freezing so I tried it disabled and it still freezes. Bios for MOBO and Radeon VII are the latest. In the screenshot provided at the bottom, the comp had just frozen, however, the console was not showing the error thrown just before it froze.
 

Attachments

Joined
May 11, 2011
Messages
1,171
Motherboard
Asrock B365M Phantom Gaming
CPU
i5-9600KF
Graphics
RX 580
Mobile Phone
iOS
Yes IGPU is enabled, pEG is primary. 128mb is set. Transparency and fast animation both enabled. In Bios, CSM was active already and it was freezing so I tried it disabled and it still freezes. Bios for MOBO and Radeon VII are the latest. In the screenshot provided at the bottom, the comp had just frozen, however, the console was not showing the error thrown just before it froze.
I know how to help you.
Disable IGPU in bios.
Change SMBIOS to iMac PRO 1,1.
I will edit you clover config. file
 
Joined
Jan 21, 2012
Messages
35
Motherboard
Asrock Fatal1ty Z370 Gaming-ITX/ac-Clover
CPU
i7-8700K
Graphics
Radeon VII + UHD 630
Hmm that’s an interesting option. Would that affect Quicksync or HEVC / H.265 Encoding? I would imagine the Radeon VII could handle that on its own.
 
Joined
Jan 21, 2012
Messages
35
Motherboard
Asrock Fatal1ty Z370 Gaming-ITX/ac-Clover
CPU
i7-8700K
Graphics
Radeon VII + UHD 630
I hate to say, but I’ve switched to iMacPro1,1 and it is still freezing up on me. It seems slightly more stable but that is subjective. I removed whatvergreen at first because I was under the impression it wouldn’t be needed without IGPU but I had issues with HEVC so when I reinstalled it, HEVC worked, but the system still freezes up on me. One benefit I can say is that iTunes DRM works now as it didn’t before on iMac19,1.
 
Top