Contribute
Register

Radeon VII (and new AMD gpus) compatibility

Joined
Dec 6, 2016
Messages
24
Motherboard
Gigabyte Aorus Gaming 5
CPU
I7-8700k
Graphics
Sapphire Nitro+ RX580 OC
Mac
Mac Pro
I would love to see Vega vii support, but I don't think it'll happen. Vega vii is sold by AMD at a loss and is only there to bridge the gap (and somewhat compete with Nvidia in the high end) until NAVI is out later this year. Maybe the'll update the iMac Pro.. but I have my doubts.. And even if - it'll be very hard to get ones hands on the card. rumours have it there are around 5000 units around the world.. which makes sense.. AMD has no interest in selling those cards en mass.
So lets hope for NAVI not to be delayed too much.
 
Joined
Jul 13, 2016
Messages
2,080
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
I would love to see Vega vii support, but I don't think it'll happen. Vega vii is sold by AMD at a loss and is only there to bridge the gap (and somewhat compete with Nvidia in the high end) until NAVI is out later this year. Maybe the'll update the iMac Pro.. but I have my doubts.. And even if - it'll be very hard to get ones hands on the card. rumours have it there are around 5000 units around the world.. which makes sense.. AMD has no interest in selling those cards en mass.
So lets hope for NAVI not to be delayed too much.

You could get one from their site yesterday. Some have got it to work already.
 
Joined
Mar 25, 2011
Messages
29
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i9-9900K
Graphics
Vega 64 and Vega VII
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
I have the vii but haven't tried this yet. I will this evening but it looks like theitsage got it working on the latest 10.14.4 beta over at egpu.io

 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
5,995
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
iMac
Joined
Aug 24, 2012
Messages
24
Motherboard
Z370 AORUS Gaming 7
CPU
i7 8700K
Graphics
Radeon VII
I got my hands on Mojave 14.4 beta 3 today and I've made some progress. After changing the 5000kext info.plist, I can now get past the macOS loading screen (it would hang on it before). I now get a black screen after though. I think I might have something else that is causing the issue – possibly with my Clover kext setup.
 
Joined
Aug 24, 2012
Messages
24
Motherboard
Z370 AORUS Gaming 7
CPU
i7 8700K
Graphics
Radeon VII
Yes, you add it to the info.plist of the 5000kext.
As I mentioned in my above post, I think I might have something else that is causing the issue – possibly with my Clover kext setup. I have the following kexts enabled:
  • FakeSMC.kext
  • Lilu.kext
  • WhateverGreen.kext
I don't believe I have any other config, but maybe one of the above is conflicting – or maybe I'm missing a kext or boot param somewhere? Do you have anything specific to making the RVII work for you, other than the 5000kext info.plist change? I feel that I'm close to finally getting this card working properly :)
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
5,995
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
iMac
As I mentioned in my above post, I think I might have something else that is causing the issue – possibly with my Clover kext setup. I have the following kexts enabled:
  • FakeSMC.kext
  • Lilu.kext
  • WhateverGreen.kext
I don't believe I have any other config, but maybe one of the above is conflicting – or maybe I'm missing a kext or boot param somewhere? Do you have anything specific to making the RVII work for you, other than the 5000kext info.plist change? I feel that I'm close to finally getting this card working properly :)
Have you set PEG as primary output and not IGPU?
 
Top