Contribute
Register

Radeon RX 4XX/5XX standalone system, AMDRadeonX4250.kext (GVA support H264) does not support HEVC HW

Joined
Apr 27, 2017
Messages
5
Motherboard
Asrock X99 Extreme 3
CPU
i7-5820K
Graphics
RX 580
SMBIOS MacPro6,1 does not support hwe420, share as H264 will not work, add WEG boot flags to tell OS use iMacPro1,1 GVA properties

shikigva=32
shiki-id=Mac-7BA5B2D9E42DDD94
Thanks. Works fine Final Cut Pro with h264 :)
 
Joined
Oct 3, 2011
Messages
64
Motherboard
GA-H97-D3H
CPU
i5-4570
Graphics
HD4600, GIGABYTE Radeon RX 580 Gaming 8G
Mac
MacBook Pro
Mobile Phone
Android, iOS
No.



SMBIOS iMac14,1 does not have forceOfflineRenderer=Yes in AppleGVA info.plist, IQSV will not work when DGPU is installed, GVA is handled by DGPU not IGPU.

Edit: iMac14,1 GVA properties
View attachment 395424
This was the only solution to stream DRM movies in iTunes and play Netflix content in Safari.
 
Joined
Oct 26, 2013
Messages
930
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
This was the only solution to stream DRM movies in iTunes and play Netflix content in Safari.
Not sure about this, without correct frame ware IQSV does not have HW DRM / FairPlay 2.0 support.
In theory, stream DRM movies in iTunes and play Netflix content in Safari should not work. RX4XX/5XX/Vega are native support HW DRM and FairPlay 2.0, stream DRM movies in iTunes and play Netflix content in Safari should work without whatevergreen.
 
Joined
Oct 3, 2011
Messages
64
Motherboard
GA-H97-D3H
CPU
i5-4570
Graphics
HD4600, GIGABYTE Radeon RX 580 Gaming 8G
Mac
MacBook Pro
Mobile Phone
Android, iOS
Not sure about this, without correct frame ware IQSV does not have HW DRM / FairPlay 2.0 support.
In theory, stream DRM movies in iTunes and play Netflix content in Safari should not work. RX4XX/5XX/Vega are native support HW DRM and FairPlay 2.0, stream DRM movies in iTunes and play Netflix content in Safari should work without whatevergreen.
Do you have a suggestion to correctly configure my system. I have an I5 4570 with Intel HD4600 GPU and a RX580.
 
Joined
Oct 26, 2013
Messages
930
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
Do you have a suggestion to correctly configure my system. I have an I5 4570 with Intel HD4600 GPU and a RX580.
If use SMBIOS iMac14,1, enable or disable IGPU get same result, GVA is provided by DGPU, also it does hot have hwe420 support, RX4XX/5XX use hweBGRA SMBIOSs may cause system unstable.

If IQSV is disabled, for RX4XX/5XX GPUs, use SMBIOS iMacPro1,1 may be the best choice on 10.14.4.
 
Joined
Sep 9, 2017
Messages
25
Motherboard
ASUS Z97-A
CPU
i7-4970K
Graphics
RX580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
If use SMBIOS iMac14,1, enable or disable IGPU get same result, GVA is provided by DGPU, also it does hot have hwe420 support, RX4XX/5XX use hweBGRA SMBIOSs may cause system unstable.

If IQSV is disabled, for RX4XX/5XX GPUs, use SMBIOS iMacPro1,1 may be the best choice on 10.14.4.
Hi,
My build is 4790k+Z97-A+580 using iMac Pro 1.1 , with dummy141 in kexts/other folder, watching H264 HEVC videos smoothly and videopoc shows hardware accelerater enabled , everything works great, but I got ramdon freeze(only mouse could move)without any heavy duty on CPU or GPU.
do you know what the problem is?
 
Joined
Oct 26, 2013
Messages
930
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
Hi,
My build is 4790k+Z97-A+580 using iMac Pro 1.1 , with dummy141 in kexts/other folder, watching H264 HEVC videos smoothly and videopoc shows hardware accelerater enabled , everything works great, but I got ramdon freeze(only mouse could move)without any heavy duty on CPU or GPU.
do you know what the problem is?
May caused by ASPM, not sure, my HD7750 or RX460 + ASUS B150 have same issue when ASPM is set to Auto or enable, set ASPM to disable from BIOS, no random freeze.
Check pci-aspm-default value, if value is 0x2 or 0x3 equal to ASPM is enabled, try disable ASPM from BIOS
395859
 
Joined
Jul 23, 2012
Messages
526
Motherboard
GA-Z77N-WIFI - F3 - Clover UEFI
CPU
E3-1225 v2
Graphics
GT 640 | P4000
Mac
Mac mini
Hi,
My build is 4790k+Z97-A+580 using iMac Pro 1.1 , with dummy141 in kexts/other folder, watching H264 HEVC videos smoothly and videopoc shows hardware accelerater enabled , everything works great, but I got ramdon freeze(only mouse could move)without any heavy duty on CPU or GPU.
do you know what the problem is?
graphics related problem
enable remote login
when it freeze again next time, use another machine ssh into your mac
check the kernel messages : sudo dmesg
 
Joined
Oct 26, 2013
Messages
930
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
On my test drive, I switched the profile to iMacPro1,1. I removed WhateverGreen and placed dummy file in Other. When I restart the computer, it loses video signal at the login screen. How did you overcome this without WhateverGreen?
Need disable AGDP, see below patch
395867
 
Top