Contribute
Register

Radeon RX 4XX/5XX standalone system, AMDRadeonX4250.kext (GVA support H264) does not support HEVC HW

Status
Not open for further replies.
Yes, you're right. But using anoother sysdef Netflix stop working on Safari. So, I've added the param (key and value) into the AppleGVA.framework info.plist, until WEG include another way to inject GVA features.

Until now, everything works fine, without freezings.


Congrats! Do you have high fan speed( more than 2500rpm) problem on RX card? Here is how to replay:

1. Boot into macOS, Play some local video, or online streaming

2. Put macOS to sleep fully( power led turns off)

3. Wake up macOS, continue the video playing,

4. Listen to your RX card fan noise, or check with hwsensors3.

Note: You may need to play some heavy video, like 4k HEVC. Or playing H264, while trying fast forwarding/backwarding the video to reach this problem as fast as possible.
 
i add hwe420 parameter to AppleGVA.framework info.plist (Im using SMBIOS iMac15,1 as you) everything works, but exported h264 video files from FinalCut have many artifacts

Rename hweBRGA to hwe420, replace all GVA properties from iMacPro1,1 are the best.
 
Hello, if you add boot flags like this, Netflix will stop working on Safari.

There are other shikigva args for DRM problem. Try shikigva=256 shiki-id=7BA5B2D9E42DDD94
 
There are other shikigva args for DRM problem. Try shikigva=256 shiki-id=7BA5B2D9E42DDD94

Export using H264 raise error using shikigva=256. Copying all the settings from iMacPro1,1 below the def of iMac15,1 works but export has issues when export with H264 but less than if I only change the hwe420 param into AppleGVA.
Using the bootarg "shikigva=32 with shiki-id=7BA5B2D9E42DDD94" is the better option to export using FCPX, but still having too small glitches in the final video.

I'll try with another sysdefs.
 
Last edited:
It's ****ing beautiful guys.

Radeon RX 580 + 10.14.4-beta1 + dummy141.kext + (boot flags shikigva=32 shiki-id=Mac-7BA5B2D9E42DDD94)

I was able to export my movie from iMovies and use ffmpeg to convert with hardware acceleration.

/edit Hmm getting errors with Netflix/hulu/drm tho
/edit2 Really stable too, no more random video freezes


$ ./VDADecoderChecker
Hardware acceleration is fully supported

Screen Shot 2019-01-30 at 14.34.13.png
 
Last edited:
It's ****ing beautiful guys.

Radeon RX 580 + 10.14.4-beta1 + dummy141.kext + (boot flags shikigva=32 shiki-id=Mac-7BA5B2D9E42DDD94)

I was able to export my movie from iMovies and use ffmpeg to convert with hardware acceleration.

/edit Hmm getting errors with Netflix/hulu/drm tho
/edit2 Really stable too, no more random video freezes


$ ./VDADecoderChecker
Hardware acceleration is fully supported

View attachment 383564

Png show IGPU is enabled, video acceleration seems to be provided by IQSV.
 
I'm with 10.14.3, System Z77 / i5-2500 / Sapphire RX 560-4GB. So My IGUP are Disable from bios. I use Waterver + Lilu + Dummy141.
I try SMBIOS 14.2 / 18.3 , right now I'm on 18.3 Graphics are OK but can not understand HEVC / H264 are work or not.
So Video confer show this

In IOReg not show AMDRadeonX4250.
So Is it OK or not ?

Wen I play VLC h264 or HEVC . CPU are load 60W and max freq
 

Attachments

  • Screenshot 2019-01-31 at 12.19.24.png
    Screenshot 2019-01-31 at 12.19.24.png
    364.1 KB · Views: 205
  • Screenshot 2019-01-31 at 12.32.30.png
    Screenshot 2019-01-31 at 12.32.30.png
    276.8 KB · Views: 206
  • Screenshot 2019-01-31 at 12.32.42.png
    Screenshot 2019-01-31 at 12.32.42.png
    235.9 KB · Views: 193
Last edited:
Status
Not open for further replies.
Back
Top