Contribute
Register

Radeon RX 4XX/5XX standalone system, AMDRadeonX4250.kext (GVA support H264) does not support HEVC HW

Joined
Jun 23, 2010
Messages
64
Motherboard
GA-Z370XP-SLI
CPU
I7-8700K
Graphics
RX 580
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
No there's no way to export H.264 through RX 580.
Only way to get H.264 encode is by the CPU+IGPU.
So on the Ivybridge, e.g. you have to enable the RX 580 as primary GPU and enable IGPU in the BIOS.
Then, set the ig-platform-id to 0x01620007 (connector-less).
You will then be able to export H.264 in FCPX and VideoProc Apps.
But, with the IGPU enabled, you will NOT be able to export HEVC (H.265) at all.

If you only use HEVC, then you have to disable the IGPU in the BIOS and then RX 580 will be utilised and it's quite fast.
Quality is not too bad.

It's a case of one or the other (H.264 or HEVC) but not both.
This is the case even if have the latest CPU with IGPU (e.g. i7-8700k) !
In fact with the latest i7 and i9's, WITHOUT the cost of a dGPU, will give the ability to do BOTH codecs (with encode AND decode) without any hassle.

Currently 10.14.1 is even worst as the HEVC is disabled for RX 580 !

In effect, the RX 580 is useless for the current mainstream codec.
is this still same case with 10.14.2?
 
Joined
Nov 4, 2018
Messages
20
Motherboard
GIGABYTE Z370 AORUS Gaming 7
CPU
i7-8700K OC 5.0
Graphics
Vega 56
Mac
Mac Pro
Last edited:
Joined
Nov 4, 2018
Messages
20
Motherboard
GIGABYTE Z370 AORUS Gaming 7
CPU
i7-8700K OC 5.0
Graphics
Vega 56
Mac
Mac Pro
No there's no way to export H.264 through RX 580.
Currently 10.14.1 is even worst as the HEVC is disabled for RX 580 !
In effect, the RX 580 is useless for the current mainstream codec.
I'm on Mojave 10.14.2 and am now able to render mp4 in Premiere IGPU+RX580 (sapphire Nitro+ LE) using H.264 and HEVC using Mercury Playback Engine GPU Acceleration (OpenCL or Metal).

According to XRG both GPUs max out, but fan speed is 0 on RX 580. It is also very slow (same render if i boot into Windows 10 is about 40% faster).

I broke down and ordered the MSI Radeon RX Vega 56 AIR Boost 8G OC and hope to get comparable results between Mac/PC -- will report back.

Adon
 
Joined
Jun 15, 2014
Messages
73
Motherboard
Gigabyte Z87MX-D3H
CPU
i7 4770K
Graphics
VEGA 56
Mobile Phone
Android
Hi All,

So i'm having slower than expected speed issues since installing my Vega 56 Pulse. I purchased this in the hope of improving my fcpx performance. I wonder if it has something to do with my Haswell CPU and utilizing the iGPU h.264 over the VEGAs render engine?

Originally i had dual 270X which would get me a bruce x score of 30sec with a LuxMark speed of 15000 approx.

I then purchased a RX580 and didn't see substantial gains (BruceX - 22Sec, Luxmark still around 15000).

With my Vega 56 I am getting a great Luxmark score of 27000 but Bruce X is down to 35 Sec. Kinda wish i'd stuck with the RX580 as this is solely for FCPX use.

I have iGPU enabled but have heard people getting BruceX scores of less than 15sec with the VEGAs. What are your people thoughts?

I have followed the full guide using Hackintool on Luli and WG and have updated platform ID's and am running now running system definitions 18,3. If i use the correct 15,3 to match my CPU i get the problem of FCPX crashing and no H.264 exports. iGPU appears to be fully working for h.264 & HEVC now via Hardware info. Do i need to run the shiki boot flag shikigva=32 or is this irrelevant?

Any thoughts, Would love to get better speeds on my VEGA 56? Not sure I will be even able to achieve these speeds if am I restricted with my older Haswell CPU?

Many Thanks,

Alex
 

Attachments

Ellybz

Retired
Joined
Apr 16, 2017
Messages
300
Motherboard
X299 GA AORUS GAMING 7
CPU
I9-7980Xe
Graphics
RX 580
Mac
iMac
Mobile Phone
Android
Anyone aware if update 10.14.3 has brought back H264 /HEVC to RX580?
 
Joined
Nov 3, 2018
Messages
304
Motherboard
ASRock B360-HDV
CPU
i5-8400
Graphics
RX 470
Mobile Phone
iOS
What's the current fix (if there is one) for 10.14.2 using RX580. I'm gathering that AppleGVA from 10.14.0 was good and can be patched to include support? Can anyone summerize what we know?
What i know is that it is possible to enable RX 580 hardware decoding and encoding, but it is very unstable which causes system random freeze. In a word, RX 5xx is useless on that purpose.
 
Joined
Jun 16, 2014
Messages
29
Motherboard
Huanan Deluxe X79
CPU
E5-2680 v2
Graphics
RX 580
Mobile Phone
iOS
I don´t understand, this config.plist with smbios MacPro1.1 works perfectly, but if I change for smbios iMacPro1.1 not works keyboard and mouse, but clock run and all work. Can someone check my attach files and say me if my Xeon works with iMacPro1.1 or other smbios? Thanks

PD: My RX580 with iMacPro1.1 works better than MacPro6.1 with OpenCL, but now not left me use.

 

Attachments

Last edited:
Joined
Oct 26, 2013
Messages
936
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
Mojave 10.14.4 (18E174f) update

Still no native GVA support for AMD RX4XX/5XX, need dummy141 kext to enable AMD GVA support.

AMD GVA H264 export work, as fast as IQSV, need SMBIOS support hwe420 like iMacPro1,1, still have bug but stable, output H264 video may sometime discolouring.

QT screen recording work with AMD GVA H264 acceleration.

VideoProc detect HW acceleration correctly, no longer freeze.

AMD GVA HEVC work, fast and stable.

Tested with RX570 + i3-7100 and RX460 + Pentium G4560 on Mojave 10.14.4 18E174f
1548399003915.png
 

Attachments

Top