Contribute
Register

Radeon RX 4XX/5XX standalone system, AMDRadeonX4250.kext (GVA support H264) does not support HEVC HW

Joined
Oct 26, 2013
Messages
912
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
Hi Shuhung,

Your EFI folder works, I can play HEVC 8-bit video's without stutter. Great. I can hopefully adapt your EFI folder for my purposes.
But: I get an error about iCloud credentials/login with your folder. I tried pasting in my SMBIOS settings, but that doesn't stick. Hm. I vaguely remember this being a problem with NVRAM and Skylake mobo's...
If my EFI folder work fine with your mobo, then most probably cause should be on CPU PM, may related to BIOS PM ssdt sub-tables.

Some mobos may have stuttering issue while high bitrate 4K HEVC video playback.

My Giga H110M-H+ SKL IQSV have above issue when using native XCPM or Apple HWP for CPU PM.
The only way to resolve this issue for me, completely disable native XCPM control and use Clover HWP instead for CPU PM.

My others mobos ASUS B150, MSI B150M/B250M, do not have this issue.
 
Joined
Nov 3, 2018
Messages
115
Motherboard
ASRock B360-HDV
CPU
i7-8700T
Graphics
RX 470
Hi Shuhung,

Your EFI folder works, I can play HEVC 8-bit video's without stutter. Great. I can hopefully adapt your EFI folder for my purposes.
But: I get an error about iCloud credentials/login with your folder. I tried pasting in my SMBIOS settings, but that doesn't stick. Hm. I vaguely remember this being a problem with NVRAM and Skylake mobo's...
It is suggested to logout icloud imessage facetime app store before you try new EFI/SMBIOS
 
Joined
Sep 19, 2010
Messages
546
Motherboard
Asus Z87 Maximus Gene VI
CPU
i7 4790K
Graphics
RX 480
Mac
iMac
Mobile Phone
iOS
So I had to enable iGPU in order to stop crashes from occurring when using Photos app and viewing videos (most recently, system froze when viewing a video sent on WhatsApp on the computer). Previously, when I was enabling iGPU, Netflix would not work but for some reason, it's working this time around.

Thought I'd share this if anyone else had disabled iGPU for to get Netflix to work. I am using all the latest kexts (WhateverGreen, Lilu, and AppleALC).
 
Joined
Aug 25, 2012
Messages
597
Motherboard
Gigabyte Z170X-UD5-TH
CPU
Intel i7 6700K
Graphics
MSI AMD RX480/8GB
Mac
MacBook Pro
Classic Mac
Performa, Power Mac, PowerBook
I think I found the right combination between my old EFI and that of Shuhung. Geekbench is good, USB works, sound is fine and I can play 8-bit HEVC movies without stuttering in 10.14.2. Really nice.

Thank you very much for the help, Shuhung! Much appreciated.

Leaves TB3 and USB3.1 as the final frontier... Sleep doesn't work well either, probably because of lack of a proper implementation of TB/USB3.1...
 
Joined
Aug 25, 2012
Messages
597
Motherboard
Gigabyte Z170X-UD5-TH
CPU
Intel i7 6700K
Graphics
MSI AMD RX480/8GB
Mac
MacBook Pro
Classic Mac
Performa, Power Mac, PowerBook
It is suggested to logout icloud imessage facetime app store before you try new EFI/SMBIOS
Any idea what Apple is tracking? I now have all the essential/unique SMBIOS info copied exactly. So it looks the same in 10.13 and 10.14 AFAIK.
Still, when I boot in 10.13 all is fine, and booting in 10.14 give me the iMessage/iCloud error. What alerts Apple?
 
Joined
Apr 6, 2014
Messages
14
Motherboard
Intel DZ87KLT-75K
CPU
i7-4770K
Graphics
RX 570
Mac
MacBook
Mobile Phone
iOS
So I had to enable iGPU in order to stop crashes from occurring when using Photos app and viewing videos (most recently, system froze when viewing a video sent on WhatsApp on the computer). Previously, when I was enabling iGPU, Netflix would not work but for some reason, it's working this time around.

Thought I'd share this if anyone else had disabled iGPU for to get Netflix to work. I am using all the latest kexts (WhateverGreen, Lilu, and AppleALC).
Interesting...i've been chasing this same issue for a while now. Just updated Lilu and WhateverGreen to recheck and still no Netflix in Safari. Could you please share what SMBIOS and platform id are you using? Are you running Mojave?
 
Joined
Sep 19, 2010
Messages
546
Motherboard
Asus Z87 Maximus Gene VI
CPU
i7 4790K
Graphics
RX 480
Mac
iMac
Mobile Phone
iOS
Interesting...i've been chasing this same issue for a while now. Just updated Lilu and WhateverGreen to recheck and still no Netflix in Safari. Could you please share what SMBIOS and platform id are you using? Are you running Mojave?
I changed to iMac15,1 SMBIOS. I am running the latest version of Mojave.
 
Joined
May 11, 2011
Messages
420
Motherboard
MSI B360 A-Pro
CPU
i5-8400
Graphics
UHD 630 + RX 580
Mobile Phone
iOS
Found another way to have both IGPU + DGPU enabled with Netflix working : rename IGPU to GFX2 . PEGP to GFX0

I have working intel UHD 630 and rx 560 in the same time, preview movies,pictures works with spacebar and force touch.

I can use the new app called screenshot to take pics and record.

The problem is that I can't open pictures downloaded from the web, just preview them with spacebar or force touch, have to use NoVPAJpeg.kext......
 
Joined
Apr 6, 2014
Messages
14
Motherboard
Intel DZ87KLT-75K
CPU
i7-4770K
Graphics
RX 570
Mac
MacBook
Mobile Phone
iOS
Found another way to have both IGPU + DGPU enabled with Netflix working : rename IGPU to GFX2 . PEGP to GFX0

I have working intel UHD 630 and rx 560 in the same time, preview movies,pictures works with spacebar and force touch.

I can use the new app called screenshot to take pics and record.

The problem is that I can't open pictures downloaded from the web, just preview them with spacebar or force touch, have to use NoVPAJpeg.kext......
Very interesting...so are you using lilu+whatevergreen and then renaming?
 
Joined
Sep 27, 2016
Messages
72
Motherboard
Dell Inspiron 7559-Clover
CPU
i7-6700HQ
Graphics
HD530, 960M, 3840x2160
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android
Found another way to have both IGPU + DGPU enabled with Netflix working : rename IGPU to GFX2 . PEGP to GFX0

I have working intel UHD 630 and rx 560 in the same time, preview movies,pictures works with spacebar and force touch.

I can use the new app called screenshot to take pics and record.

The problem is that I can't open pictures downloaded from the web, just preview them with spacebar or force touch, have to use NoVPAJpeg.kext......
What "Find and Replace HEX" are you using for IGPU to GFX2?
 
Top