Contribute
Register

Radeon RX 4XX/5XX standalone system, AMDRadeonX4250.kext (GVA support H264) does not support HEVC HW

Joined
Oct 26, 2013
Messages
922
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
Hi Shuhung,

That's very kind/ .Here's my EFI folder:

And my iojones output....

Thanks for your time & insights.
kexts are up to date and ioreg file seems to be OK, config.plist is corrupt.
upload_2018-12-30_0-58-20.png


check for ReportCrash service usage from Activity Monitor, if present or usage is high, video playback may be choppy.
 
Joined
Aug 25, 2012
Messages
616
Motherboard
Gigabyte Z170X-UD5-TH
CPU
Intel i7 6700K
Graphics
MSI AMD RX480/8GB
Mac
MacBook Pro
Classic Mac
Performa, Power Mac, PowerBook
kexts are up to date and ioreg file seems to be OK, config.plist is corrupt.
View attachment 375688

check for ReportCrash service usage from Activity Monitor, if present or usage is high, video playback may be choppy.
I cut out my privacy sensitive info, so it's no longer a well formed xml file, I guess. I use a plain text editor to read and write my config.plist. Do you want a plist editor readable config.plist?
 
Joined
Oct 26, 2013
Messages
922
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
I cut out my privacy sensitive info, so it's no longer a well formed xml file, I guess. I use a plain text editor to read and write my config.plist. Do you want a plist editor readable config.plist?
Better fix config.plist as readable, did you find ReportCrash service usage from Activity Monitor.
 
Joined
Oct 26, 2013
Messages
922
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
Here you go.
Repeat tested your config.plist, 4k HEVC playback not OK, choppy, I change my config.plist SMBIOS to iMac17,1, everything OK, try generate now config.plist.
 
Joined
Aug 25, 2012
Messages
616
Motherboard
Gigabyte Z170X-UD5-TH
CPU
Intel i7 6700K
Graphics
MSI AMD RX480/8GB
Mac
MacBook Pro
Classic Mac
Performa, Power Mac, PowerBook
Repeat tested your config.plist, 4k HEVC playback not OK, choppy, I change my config.plist SMBIOS to iMac17,1, everything OK, try generate now config.plist.
My SMBIOS has always been iMac17,1. You want me to generate a new config.plist? Starting from scratch?

Best,

Zip
 
Joined
Oct 26, 2013
Messages
922
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
I just generated a new config.plist from Clover Configurator. Still choppy 8-bit HEVC playback...
Try my USB EFI folder for SKL/KBL IQSV, copy to your usb flash drive and boot from it, for 4K HEVC test.

Tested with 4 mobos, Asus B150, MSI B150M, Asrock H110M, Giga H110M, + RX560 + IQSV, all work.
 

Attachments

Joined
Aug 25, 2012
Messages
616
Motherboard
Gigabyte Z170X-UD5-TH
CPU
Intel i7 6700K
Graphics
MSI AMD RX480/8GB
Mac
MacBook Pro
Classic Mac
Performa, Power Mac, PowerBook
Hi Shuhung,

Your EFI folder works, I can play HEVC 8-bit video's without stutter. Great. I can hopefully adapt your EFI folder for my purposes.
But: I get an error about iCloud credentials/login with your folder. I tried pasting in my SMBIOS settings, but that doesn't stick. Hm. I vaguely remember this being a problem with NVRAM and Skylake mobo's...
 
Top