Contribute
Register

Radeon RX 4XX/5XX standalone system, AMDRadeonX4250.kext (GVA support H264) does not support HEVC HW

Joined
Mar 3, 2011
Messages
108
Motherboard
Gigabyte GA-Z77 DS3H
CPU
i5-3570K
Graphics
AMD RX 460 2 GB
I used the (very nice) Mitch tool while encoding and it says that VideoProc is using the encoding of my RX580.
View attachment 440437
Updated AMD GPU Menue (RX 4xx/4xx only!) to V0.8
- now shows also GPU HW Decoding aktiv = YES oder NO
- Max Temp / Max Clk Values (Shown if you click on AMD Menue = are resetable - simple click in this max Values line

PS: Davinci Resolve ( i use Mojave) shows both (Dec=YES on playing, Dec+Enc=YES on export) - FCP didnt shows Dec on play - FCP handles the GPU litte different case of HW dec - not used - but uses the gpu also.
Bildschirmfoto 2019-12-15 um 12.11.10.jpg

I am sure you will see changes in the Redering Speeds xxx FPS encoding h265 if HW Enc is not used / not working . At least if you have not an ultra high speed 12 Cores+ CPU ;)


PS2: You can change refresh rate of the values by setting lower refresh time as default 2 sec. Use the slide to measure faster /less refresh time) after you click on the AMD menue line.
 

Attachments

Last edited:
Joined
Sep 20, 2012
Messages
15
Motherboard
GA-Z87MX-D3H
CPU
i5-4440
Graphics
RX 580
Mac
Mac Pro
What ig-platform-id are you using for hd4600&iMacPro1,1?

II have tried using no ig-platform-id, the regular for iGPU and the headless one. iMacPro1,1 with RX580 but no hevc.

Regarding you netflix-problem, I read at github that drm-playback did not work yet.
I don't use any ig-platform-id in my config.plist.
However here is what's detected by hackintool.
Capture d’écran 2019-12-15 à 16.54.25.png


I use WhateverGreen 1.3.5 and Lilu 1.4.0 with no shiki boot args.

If I don't disable iGPU, videoproc reports that HEVC is enabled but DaVinci does not hardware encode. To get Hardware encoding in DaVinci I need to disable iGPU in the bios.

I can read DRM protected content in apple TV and Itunes. I can hardware encode in HEVC with DaVinci. The only problem is netflix in Safari (which is not really a problem since I have chrome).
 

Attachments

Joined
Jun 15, 2013
Messages
23
Motherboard
Z87-UD3H
CPU
i7-4770K
Graphics
RX 580
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
I don't use any ig-platform-id in my config.plist.
However here is what's detected by hackintool.
View attachment 440584

I use WhateverGreen 1.3.5 and Lilu 1.4.0 with no shiki boot args.

If I don't disable iGPU, videoproc reports that HEVC is enabled but DaVinci does not hardware encode. To get Hardware encoding in DaVinci I need to disable iGPU in the bios.

I can read DRM protected content in apple TV and Itunes. I can hardware encode in HEVC with DaVinci. The only problem is netflix in Safari (which is not really a problem since I have chrome).
This is what I am doing. Are you on 10.15.2?

What’s your boot arguments?

Thanks
 
Joined
Apr 17, 2017
Messages
14
Motherboard
Gigabyte GA-H170N-WIFI
CPU
i5-6600
Graphics
RX 570
Mac
iMac
Mobile Phone
iOS
I compiled the new WEG but is it working for anyone?
10.15.2 + RX 580 + iMacPro1,1 with same config I had in Mojave (where it all worked) and nada. If I even navigate to Netflix.com in Safari my computer freezes hard.
I had the same issue : when browsing in Netflix big hard freeze. I was afraid because after shutdown, I even got a boot loop during about 5 min. Computer rebooted during POST right after UEFI screen.
 
Joined
Jul 16, 2011
Messages
81
Motherboard
Lenovo Y540-15IRH (Opencore)
CPU
I7 9750H/HM370
Graphics
UHD 630 1920x1080
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Well it works well with the last version 1.3.6 of whatevergreen

you have to compile yourself as it was not released

SMBIOS 1.1 Mac Pro with RX 580 and full HW accel (DRM, HEVC...) and iGPU disabled
 
Joined
Jun 15, 2013
Messages
23
Motherboard
Z87-UD3H
CPU
i7-4770K
Graphics
RX 580
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
Well it works well with the last version 1.3.6 of whatevergreen

you have to compile yourself as it was not released

SMBIOS 1.1 Mac Pro with RX 580 and full HW accel (DRM, HEVC...) and iGPU disabled
Is it your graphic card or quicksync doing the work?
 
Joined
Nov 19, 2011
Messages
61
Motherboard
Gigabyte GA-Z170X Gaming G1-F22i-Clover
CPU
i7-6700K
Graphics
HD 530/Vega 64
Mac
MacBook Pro
Mobile Phone
Android
I don't use any ig-platform-id in my config.plist.
However here is what's detected by hackintool.
View attachment 440584

I use WhateverGreen 1.3.5 and Lilu 1.4.0 with no shiki boot args.

If I don't disable iGPU, videoproc reports that HEVC is enabled but DaVinci does not hardware encode. To get Hardware encoding in DaVinci I need to disable iGPU in the bios.

I can read DRM protected content in apple TV and Itunes. I can hardware encode in HEVC with DaVinci. The only problem is netflix in Safari (which is not really a problem since I have chrome).
Once I had that error in Hackintool and it was because I had the IGPU set to auto instead of enable. Try setting it to enable and then try again.
 
Joined
Jul 29, 2013
Messages
37
Motherboard
Gigabyte GA-z97x-ud7 TH
CPU
i5 4690k
Graphics
Sapphire RX 590 Nitro+
Hi guys, I have successfully used OC with iMacPro1,1 with a few exceptions:

1. Given that I have a Haswell processor and using iMacPro1,1 do I need any/all of these boot-args lilucpu=10 agdpmod=pikera shikigva=96 shiki-id=Mac-7BA5B2D9E42DDD94.

2. I have IX2790 5K display but under About this Mac > Displays, it shows 4K resolution. If this were just cosmetic it would have been fine but when I reboot with apps open, on login they shift upwards making the top bar of each app inaccessible. This tells me that the system starts in 4K but then quickly switches to 5K.

Just one note: I have a NVMe SSD installed using PCIe card as my mother board doesn't have an NVMe slot. This results in RX 590 getting 8 lanes instead of 16. Not sure if this is the cause of the 5K vs 4K issue.

Thanks!
 
Top