Contribute
Register

Radeon RX 4XX/5XX standalone system, AMDRadeonX4250.kext (GVA support H264) does not support HEVC HW

Joined
Oct 26, 2013
Messages
935
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
AMD GVA H264/HEVC acceleration work correctly on latest 10.14.6 beta.

414171
 
Joined
Jun 14, 2011
Messages
30
Motherboard
ASRock Fatal1ty Z370 Gaming-ITX
CPU
i7-9700k
Graphics
Vega 56
Does anyone actually have their AMD GPU hardware doing the encoding???
Ive tried imac pro smbios as well.
 

Attachments

Joined
Jun 14, 2011
Messages
30
Motherboard
ASRock Fatal1ty Z370 Gaming-ITX
CPU
i7-9700k
Graphics
Vega 56
Turned off IGPU in bios with imacPro smbios.
I guess its just a bug in the software since gpu history window shows Vega doing the work.
Can anyone confirm???
 

Attachments

pastrychef

Moderator
Joined
May 29, 2013
Messages
9,594
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Turned off IGPU in bios with imacPro smbios.
I guess its just a bug in the software since gpu history window shows Vega doing the work.
Can anyone confirm???
Yes, I think it's a cosmetic error.

Edit:
I did a little more testing. I think VideoProc uses different hardware depending on what you ask the app to do. For example, I tried to rotate a video and add the greyscale filter before converting to HEVC and only the CPU was used.

When I did an HEVC to H.264 conversion without any filters, it used GPU and CPU.
 
Last edited:
Joined
Jun 14, 2011
Messages
30
Motherboard
ASRock Fatal1ty Z370 Gaming-ITX
CPU
i7-9700k
Graphics
Vega 56
Yes, I think it's a cosmetic error.

Edit:
I did a little more testing. I think VideoProc uses different hardware depending on what you ask the app to do. For example, I tried to rotate a video and add the greyscale filter before converting to HEVC and only the CPU was used.

When I did an HEVC to H.264 conversion without any filters, it used GPU and CPU.
Thanks for checking
 
Joined
Dec 11, 2013
Messages
19
Motherboard
Gigabyte Z370M-D3H
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Pro, Mac mini
AMD GVA H264/HEVC acceleration work correctly on latest 10.14.6 beta.

View attachment 414171
Hey Shuhung, do you think this update will solve the DumpGPURestart freezes on the RX580?

Just bought a RX580 to upgrade my Haswell (4770k on 14,2) rig to Mojave and am getting the annoying freezes. Was looking at changing SMbios to iPad Pro and use the dummy kext etc but if the new version of Mojave fixes it, I'll download the beta and install.

If you have any ideas on how to solve the freezes (I don't do any video work so HEVC is secondary) that would be great. Thanks.
 
Joined
May 11, 2011
Messages
571
Motherboard
MSI B360 A-Pro
CPU
i5-8400
Graphics
UHD 630 + RX 580
Mobile Phone
iOS
Hey Shuhung, do you think this update will solve the DumpGPURestart freezes on the RX580?

Just bought a RX580 to upgrade my Haswell (4770k on 14,2) rig to Mojave and am getting the annoying freezes. Was looking at changing SMbios to iPad Pro and use the dummy kext etc but if the new version of Mojave fixes it, I'll download the beta and install.

If you have any ideas on how to solve the freezes (I don't do any video work so HEVC is secondary) that would be great. Thanks.
iPad Pro SMBios :think: ??!
 
Top