Contribute
Register

Radeon RX 4XX/5XX standalone system, AMDRadeonX4250.kext (GVA support H264) does not support HEVC HW

Joined
Mar 5, 2019
Messages
19
Motherboard
Asrock z370
CPU
i7-8700
Graphics
RX 580
Mac
iMac
I

I’m not at the computer for now, will see the file later.

With the latest EFI folder I posted and with IGPU + DGPU boot with -wegoff (will disable whatevergreen and use the clover settings).
At the clover boot menu add -wegoff
Hello! I tried all configurations. It seemed to me that Wegoff solves the problem. But it was not the case. I tried everything you suggested, but FCPX hangs. This hangs the Rafeon 580. If I use igpu, then I don’t get enough playback speed for multicam shot. I even went back to OS version 10.14.5 Maybe someone found a solution for a similar configuration?
 
Joined
Jul 26, 2016
Messages
24
Motherboard
GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
RX 580
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Classic, iMac
Mobile Phone
iOS
Hi everyone!
I updated my system to Mojave 10.14.5 and would love to encode h264 videos in Davinci Resolve with RX580.
What kext should I install to make it happen?
Thanks,
 

Attachments

Joined
Nov 3, 2018
Messages
304
Motherboard
ASRock B360-HDV
CPU
i5-8400
Graphics
RX 470
Mobile Phone
iOS
Hi everyone!
I updated my system to Mojave 10.14.5 and would love to encode h264 videos in Davinci Resolve with RX580.
What kext should I install to make it happen?
Thanks,
add boot args:
shikigva=32
shiki-id=Mac-7BA5B2D9E42DDD94
 
Joined
Jul 20, 2018
Messages
22
Motherboard
msi e3 v5
CPU
e3 1230 v5
Graphics
rx470
Does anyone can solve this Panic?
Fri Jun 14 22:24:33 2019



*** Panic Report ***

panic(cpu 0 caller 0xffffff7f96cd1c0c): nvme: "Fatal error occurred. CSTS=0x1 US[1]=0x0 US[0]=0x1f VID/DID=0xf1a68086

. FW Revision=001C\n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/IONVMeFamily/IONVMeFamily-387.260.15/IONVMeController.cpp:5334

Backtrace (CPU 0), Frame : Return Address

0xffffff9150d63a10 : 0xffffff80135aea2d

0xffffff9150d63a60 : 0xffffff80136e9e95

0xffffff9150d63aa0 : 0xffffff80136db70a

0xffffff9150d63b10 : 0xffffff801355bb40

0xffffff9150d63b30 : 0xffffff80135ae447

0xffffff9150d63c50 : 0xffffff80135ae293

0xffffff9150d63cc0 : 0xffffff7f96cd1c0c

0xffffff9150d63e20 : 0xffffff8013c5e877

0xffffff9150d63e90 : 0xffffff8013c5e799

0xffffff9150d63ec0 : 0xffffff80135ed9b5

0xffffff9150d63f40 : 0xffffff80135ed555

0xffffff9150d63fa0 : 0xffffff801355b0ce

Kernel Extensions in backtrace:

com.apple.iokit.IONVMeFamily(2.1)[FAFF8EA6-B8EF-314D-886A-DEAB39FF3EA9]@0xffffff7f96cc4000->0xffffff7f96d03fff

dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[A367CF6B-B3EA-36FE-86E6-03B771CA8A69]@0xffffff7f9438f000

dependency: com.apple.iokit.IOPCIFamily(2.9)[CC6A465F-5A24-304D-B9DF-8C27819CC214]@0xffffff7f93e95000

dependency: com.apple.driver.AppleEFINVRAM(2.1)[C3C74D36-E06B-3753-A373-5BC9D486DD9C]@0xffffff7f94565000

dependency: com.apple.iokit.IOStorageFamily(2.1)[D43332F2-2D40-3DF1-8F77-D633BCDAE660]@0xffffff7f94185000

dependency: com.apple.iokit.IOReportFamily(47)[5772C11C-ED28-322A-910F-874583B23101]@0xffffff7f94d0f000



BSD process name corresponding to current thread: kernel_task



Mac OS version:

18F132



Kernel version:

Darwin Kernel Version 18.6.0: Thu Apr 25 23:16:27 PDT 2019; root:xnu-4903.261.4~2/RELEASE_X86_64
 
Joined
Feb 27, 2016
Messages
19
Motherboard
GA-Z97X-Gaming 3
CPU
i5-4460
Graphics
RX 570
Mac
iMac
  1. Copy and replace EFI folder
  2. Disable IGPU from BIOS
  3. If you will see a black screen, remove the boot args -wegoff at the clover boot screen.
  4. :think:
So with video encoding working great but I got already the 5th system freeze while maximizing social media videos. Even the Apple Release video kicked me. It's not just making them full screen. this normally works. but when you fuzz around with the controls, try to go back some minutes, or pause and play - it freezes completely.

Does anybody knows about the problem? Is this maybe a dual-GPU issue maybe I have?

Example Link: http://apple.co/live
 
Joined
May 11, 2011
Messages
579
Motherboard
MSI B360 A-Pro
CPU
i5-8400
Graphics
UHD 630 + RX 580
Mobile Phone
iOS
So with video encoding working great but I got already the 5th system freeze while maximizing social media videos. Even the Apple Release video kicked me. It's not just making them full screen. this normally works. but when you fuzz around with the controls, try to go back some minutes, or pause and play - it freezes completely.

Does anybody knows about the problem? Is this maybe a dual-GPU issue maybe I have?

Example Link: http://apple.co/live
You might try SMBios 18,3 and enable IGPU back.
 
Joined
Mar 28, 2011
Messages
181
Motherboard
Asus Tuf X299 Mark 1
CPU
i9-7900X
Graphics
EVGA Gtx 980Ti SC+
Mobile Phone
iOS
Hello, I have a system x299 with i97900x 32gbs and 980ti , to change 980ti for rx580 8 gbs saphire pulse and ramdon crash in FCPX ..... I tried with a swapid.kext and no stable 100% , how to fix this.

I use High Sierra 10.13.6 .
 

Attachments

Top