Contribute
Register

Radeon RX 4XX/5XX standalone system, AMDRadeonX4250.kext (GVA support H264) does not support HEVC HW

Joined
Oct 26, 2013
Messages
947
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
Any idea why this command is no longer working in 10.14.5:

Code:
com.apple.driver.AppleGraphicsDevicePolicy

Find: BA050000 00
Replace: BA000000 00
I have to use WhateverGreen to get past the black screen at Desktop on boot.
Still work on 10.14.5, no issue for RX460 and RX570.
 
Joined
May 13, 2019
Messages
2
Motherboard
Gigabyte G1 Sniper B5
CPU
i5-4670
Graphics
RX 580
I am running 10.14.4 with SMBIOS iMac15,1. Boot flags are keepsyms=1,dart=0,debug=0x100,shikigva=1. kexts are FakeSMC.kext,IntelMausiEthernet.kext,Lilu.kext,WhateverGreen.kext

I have 2 issues:
- cannot play videos in safari in netflix (Error Code: S7363-1260-FFFFD089)
- cannot launch iMovie


If I update to 10.14.5, turn off the Intel igpu, iMacPro1,1, will these 2 issues be resolved?
 
Joined
Sep 19, 2010
Messages
577
Motherboard
Asus Z87 Maximus Gene VI
CPU
i7-4790K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
I am running 10.14.4 with SMBIOS iMac15,1. Boot flags are keepsyms=1,dart=0,debug=0x100,shikigva=1. kexts are FakeSMC.kext,IntelMausiEthernet.kext,Lilu.kext,WhateverGreen.kext

I have 2 issues:
- cannot play videos in safari in netflix (Error Code: S7363-1260-FFFFD089)
- cannot launch iMovie


If I update to 10.14.5, turn off the Intel igpu, iMacPro1,1, will these 2 issues be resolved?
First issue will definitely get fixed. For the second issue, do you get any error messages? If you go with the iMacPro1,1 route, WhatEverGreen is not needed and also shikigva=1 flag.

You can just back up your current CLOVER folder and try the new SMBIOS. If anything stops working, you cna always revert back to the original CLOVER folder.
 
Joined
Mar 9, 2011
Messages
626
Motherboard
Gigabyte Z390 UD
CPU
i9-9900K
Graphics
Vega 56
Mac
iMac, MacBook Pro, Mac Pro
Classic Mac
iMac
Mobile Phone
iOS
First issue will definitely get fixed. For the second issue, do you get any error messages? If you go with the iMacPro1,1 route, WhatEverGreen is not needed and also shikigva=1 flag.

You can just back up your current CLOVER folder and try the new SMBIOS. If anything stops working, you cna always revert back to the original CLOVER folder.
WhatEverGreen is needed for me or HEVC will not be enabled. I am on iMac Pro 1,1 with Vega 56
 
Joined
Sep 19, 2010
Messages
577
Motherboard
Asus Z87 Maximus Gene VI
CPU
i7-4790K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
WhatEverGreen is needed for me or HEVC will not be enabled. I am on iMac Pro 1,1 with Vega 56
Here's a screenshoot of VideoProc on my system. It shows support for both HEVC and H.264. I am not using WhatEverGreen and don't have the iGPU enabled.
 

Attachments

Joined
Mar 9, 2011
Messages
626
Motherboard
Gigabyte Z390 UD
CPU
i9-9900K
Graphics
Vega 56
Mac
iMac, MacBook Pro, Mac Pro
Classic Mac
iMac
Mobile Phone
iOS
Here's a screenshoot of VideoProc on my system. It shows support for both HEVC and H.264. I am not using WhatEverGreen and don't have the iGPU enabled.
I believe you. It must be because you have an RX 480, on my Vega it is definitely needed. That was the first thing I tried when I changed to this SMBIOS.

How did you get your graphics card name to appear at the top? Are you specifying a framebuffer?

Mine just says N/A despite H264 and HEVC being fully supported
 

Attachments

Joined
Oct 26, 2013
Messages
947
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
It must be because you have an RX 480, on my Vega it is definitely needed. That was the first thing I tried when I changed to this SMBIOS.
No relevant to RX480 or Vega, in order to make AMD HEVC encoding/decoding functional, DGPU must attached to device GFX0, WEG will auto rename device XXXX to GFX0.

How did you get your graphics card name to appear at the top? Are you specifying a framebuffer?

Mine just says N/A despite H264 and HEVC being fully supported
Inject FBName will show graphics card name on VideoProc but easy cause black screen issue, if FB not perfect match your connectors layout, some ports may not functional.
 
Joined
Aug 25, 2012
Messages
729
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900k
Graphics
RX480
Mac
MacBook Pro
Classic Mac
Performa, Power Mac, PowerBook
Mobile Phone
iOS
So. Now that 10.14.5 is out with better AMD support, can I keep my iMac 17,1 SMBIOS and have my RX480 decode 10-bit HEVC?
What do I gain(if anything) by switching to RX480 only?(using connectorless HD530 & RX480 now with some success)
What do I have to do exactly to have my RX480 do all the H264 & HEVC encoding/decoding?
 
Joined
Mar 9, 2011
Messages
626
Motherboard
Gigabyte Z390 UD
CPU
i9-9900K
Graphics
Vega 56
Mac
iMac, MacBook Pro, Mac Pro
Classic Mac
iMac
Mobile Phone
iOS
No relevant to RX480 or Vega, in order to make AMD HEVC encoding/decoding functional, DGPU must attached to device GFX0, WEG will auto rename device XXXX to GFX0.



Inject FBName will show graphics card name on VideoProc but easy cause black screen issue, if FB not perfect match your connectors layout, some ports may not functional.
Thats what I thought about the FBname Inject is not as easy as it looks. Yes, you are correct, by renaming DSDT PEGP to GFX0 and disabling WEG everything is back to normal apart from some screen tearing at boot. It's like its switching resolutions mid boot?
 
Joined
May 27, 2013
Messages
140
Motherboard
GA-Z97X-GAMING 3
CPU
i7-4790K
Graphics
RX 580
Mac
MacBook
Mobile Phone
iOS
No relevant to RX480 or Vega, in order to make AMD HEVC encoding/decoding functional, DGPU must attached to device GFX0, WEG will auto rename device XXXX to GFX0.



Inject FBName will show graphics card name on VideoProc but easy cause black screen issue, if FB not perfect match your connectors layout, some ports may not functional.
I tried to inject the FBName but without success. How do you did it?
 
Top