Not open for further replies.
Oct 19, 2011
Asus X99 Deluxe
2x R9 280X
  1. MacBook Pro
Classic Mac
  1. 128K
  2. 512K
  3. Centris
  4. iBook
  5. LC
  6. Performa
  7. Plus
  8. PowerBook
Mobile Phone
  1. iOS
My GPU’s were behaving in High Sierra but have gone awry since I finally got Mojave installed.

  • web pages in Chrome load/display only partially, there was some improvement after I disabled the hardware acceleration option in Chrome preferences;.
  • Safari is much better but still has artifacts (tones in tab bars are inverted, cursor trails appear on screen)
  • Geekbench can’t run a GPU compute test, it says the device is unrecognized
  • can’t type quickly in TextEdit
  • display calibration software (Spectraview) doesn’t work
  • display isn’t properly identified in System Preferences
  • Finder operations are mostly ok although sometimes I see rippling when I move a window.
  • no problems in Windows 10 (other than using Windows ;)) so I assume it’s not a hardware issue
  • both gpu’s are correctly identified by System Profiler

Mojave 10.14.4​
Latest Clover​
MacPro6,1 system definition​
config.plist & EFI folder (with vBIOS) attached​
Hardware listed in my profile​

I see the following issues but don’t know which one to attack first.
  • black screen at boot or else restarting before reaching the Apple logo and progress bar
  • possible need for a framebuffer (if that helps with the glitches). Otherwise DisplayPort is working
  • no GPU acceleration
The dual gpu setup makes it possible for me to boot. My understanding is that one of the gpu’s is unloaded when the boot process is completed. From then on, is it doing nothing or does it help out with computational tasks? A few OS’s ago, I recall getting a signal from both GPU’s. I was using only one in High Sierra and am ok with that. I tried AGDPFix without any luck. I also tried patching the AMD7000Controller.kext with a custom framebuffer. It seems that the current approach is to let WhateverGreen take over graphics configuration from Clover but it wasn’t clear which ig-platform-id to use with only dGPU's. I tried enabling dGPU power management by renaming GFX0 & GFX1 to GFX1 & GFX2. Maybe I need separate SSDT’s for each GPU?


  • config.plist
    10.3 KB · Views: 298
    22.2 MB · Views: 301
Last edited:
Oct 24, 2017
Jingsha and Gigabyte H22M
Xeon E5-2687W V1 and Core i5-3770
AMD 280x
  1. Mac Pro
Having similar issues after getting to Mojave from High Sierra on my second machine. Weirdest thing is my first machine (Typing on now) Has a 280x and been on Mojave since release and yet it works without any issues what so ever. Did you happen to find a fix to this?
Not open for further replies.