Contribute
Register

Radeon R7 360 is seen as R9 360 with 7 mb of memory

Joined
Jul 25, 2016
Messages
12
Hi, I installed os x 10.11.6 on my pc with:
Motherboard: asrock p67 pro3
Cpu: Intel i5-2500
Ram: 4gb
Gpu: Radeon R7 360 2048 mb vram

The main problem is I can't make it to fully recognize the gpu. I can see the os animations, but slow and bugged and, as topic, only 7 mb of vram.
I spoofed the id with 0x66581002, injected ATI, FixDisplay setted to true and I also added the id in the AMD8000Controller.kext.
No success at all, I'm 3 days fighting but I can't come up with a solution.
I'm new to this, every information (even those which might seems very little to you) will be very appreciated.
Thanks
 
Last edited:

Fl0r!an

Moderator
Joined
Jul 6, 2010
Messages
2,683
Motherboard
Asus Z170M-Plus
CPU
i5-6600K
Graphics
R9 280
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
First restore the original AMD8000Controller by (re-)installing the latest OS X Combo Update. This will ensure that the kext isn't corrupt, which can easily happen if one forgets to fix permissions after applying a patch.

Then spoof your device ID to 0x665C1002 and set "FBName = Radeon" (or any other random string). Verify in System Profiler -> Graphics that your device ID has actually changed. You should have full acceleration now.
 
Joined
Jul 25, 2016
Messages
12
First off, thanks very much for having the time to answer me.
I did what you asked me to do, and the result is the boot stucks at this screen (attached).
The only way i have to finish the boot without problems is to change the id to 0x66581002 from clover options.
The steps I did are:
-installing the combo package;
-spoofing id to 0x665C1002 enabling FixDisplay and Injecting ATI with FBName=Radeon.

Thanks
 

Attachments

Joined
Jul 25, 2016
Messages
12
Make: XFX R7 360, the one with dual vents cooler.
Ok I will check the boot without monitor plugged and screen sharing as soon as I can (I'm gonna be out of home all the day), for now I can already tell you that yesterday I've tried booting without monitor at all, and it didn't boot.
Thanks
 

Fl0r!an

Moderator
Joined
Jul 6, 2010
Messages
2,683
Motherboard
Asus Z170M-Plus
CPU
i5-6600K
Graphics
R9 280
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Okay... XFX is known for making graphics cards which are incompatible with OS X due to VBIOS problems. I don't know if the R 7 360 is affected, too, but it's quite likely.

I'd try to use Clover to dynamically load the VBIOS from another R7 360 made by a different vendor. You can use Radeon_bios_decode and redsock_bios_decoder to verify that the hardware (= port mapping) is the same.
 
Joined
Jul 25, 2016
Messages
12
I tried to run radeon_bios_decode and i have this output:

rhdAtomGetDataTable: No AtomBios signature found​

logout

Saving session...

...copying shared history...

...saving history...truncating history files...

...completed.

Deleting expired sessions...none found.​
 
Top