Contribute
Register

Radeon Compatibility Guide - ATI/AMD Graphics Cards

beelzebozo

Super Moderator
Joined
Mar 31, 2010
Messages
3,807
Motherboard
Main Build: ASUS z170-Deluxe
CPU
i7 - 6700K
Graphics
GTX 1080
Mac
MacBook Pro
Classic Mac
Power Mac
Mobile Phone
iOS
Joined
Sep 30, 2019
Messages
7
Motherboard
up4 x79
CPU
i7
Graphics
660ti
I cant find much information on this but why cant we fakeid a nivida card to act as an amd card?
such as a gtx660ti which is native supported and works out the box, is there a way to make the cpu think its an amd? I was looking into headless platformid etc but whew im blown away.
 
Joined
Jan 20, 2016
Messages
36
Motherboard
Asus Maximus VIII Ranger
CPU
i7-6700K
Graphics
VEGA 64
Mac
Mac Pro
Mobile Phone
Android
guys i have recently got a rx 5700 (not xt), is there any kexts etc to make it work in high sierra or mojave?
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,209
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
I cant find much information on this but why cant we fakeid a nivida card to act as an amd card?such as a gtx660ti which is native supported and works out the box, is there a way to make the cpu think its an amd?

@Jkraze,

The whole concept around faking device id's is to force MacOS to load a driver against a device that it is not natively supported. The method is used most commonly with Intel IGPU's and works because when it comes down to it most Intel IGPU's are very similar so a unsupported IGPU can use a supported IGPU driver stack with just a few patches applied to the appropriate frame buffer.

Nvidia GPU's are totally different to AMD GPU's, different architecture, different drivers so faking a Nvidia GPU as a AMD GPU would not work as the drivers are totally incompatible, it simply would not work.

I was looking into headless platformid etc but whew im blown away.

Have a look at the section titled "Headless PlatformID's" in Chapter 4 of this guide :-



If your new to Lilu + WhatEverGreen then you should read the whole guide.

Cheers
Jay
 
Joined
Mar 5, 2019
Messages
25
Motherboard
Asrock z370
CPU
i7-8700
Graphics
Radeon VII
Mac
iMac
Mobile Phone
iOS
Hi! Anyone have Radeon VII. Try to set my folder I Have everything working on the latest beta version of Catalina! Only generate new serial!
 

Attachments

Joined
Sep 1, 2016
Messages
35
Motherboard
Asus X-99 DeluxeII
CPU
E5-2696 v4
Graphics
2* Radeon VII
Mac
MacBook Pro, Mac Pro
Classic Mac
iMac
Mobile Phone
iOS
Can some one help me out or have a suggestion for comment 2988

As I need the second Radeon VII GPU for my wacom cintiq+ stats screen..
Or have somebody experience with a eGPU like the Akitio Node Pro to put in the second GPU

With iMacPro 1.1 SMBIOS and a Gigabyte GC-Titan Ridge PCIe card?
 
Joined
Sep 1, 2016
Messages
35
Motherboard
Asus X-99 DeluxeII
CPU
E5-2696 v4
Graphics
2* Radeon VII
Mac
MacBook Pro, Mac Pro
Classic Mac
iMac
Mobile Phone
iOS
Thank you for the reply and the suggestion, but its offbeat the second GPU dont show any video feed..
Even with Whatevergeen v1.3.3 & Lilu v1.3.8 the boot flags "agdpmod=pikera" / "agdpmod=vit9696"
Or even using a SSDT with the data from IORegistryExplorer.

When activating the TB3 trough Windows the second GPU gives on all ports a video feed.. So it's not broken..
And in 10.14 in the monitor tab in this "about this mac" + System overview shows exactly the monitor details attached to second GPU.

I have also tried to changed the SMBIOS to a 6.1 version for testing , but also the same problem.. :problem:
If needed I have to purchase a eGPU for the Radeon VII if that works hopefully !

The benefit of this is then, I can also put the FW PCIe card back for my external soundcard..
Otherwise I need also to upgrade my motu 828 FW to a TB3 soundcard :lol:
 
Joined
Nov 7, 2012
Messages
63
Motherboard
Z68-MX-UD2H-B3
CPU
i5-2500K
Graphics
RX 580
Mobile Phone
Android, iOS
Hello, I just reasently installed Catalina 10.15.1 into my system, using default product name of iMac 14,2 model name, have Lilu and Whatevergeen kexts installed into Clover bootloader folder. In about my mac Graphics: Radeon RX 580 8 GB looks okay
Under system report is
Radeon RX 580:

Chipset Model: Radeon RX 580
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 8 GB
Vendor: AMD (0x1002)
Device ID: 0x67df
Revision ID: 0x00e7
Metal: Supported, feature set macOS GPUFamily2 v1
Displays:
LG ULTRAWIDE:
Resolution: 3840x1600 (Ultra-wide 4K)
UI Looks like: 3840 x 1600 @ 60 Hz
Framebuffer Depth: 30-Bit Colour (ARGB2101010)
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported
Automatically Adjust Brightness: No
Connection Type: DisplayPort
Television: Yes
Also looks good, but when I'm using Davinci Resolve 16 the CPU is max loaded and GPU slightly touched. In Mojave Davinci Resolve 16 GPU used about 60-70%, what can I say rom activity monitor, also Davinci Resolve crashing a lot.

Is any way to check is my GPU is fully working?
 
Top