Contribute
Register

Radeon Compatibility Guide - ATI/AMD Graphics Cards

Joined
Sep 3, 2014
Messages
6
Motherboard
Dell T7500
CPU
2x X5660
Graphics
RX 570
Mobile Phone
iOS
Hi all
I update to Mojave 10.14.1, and replaced my graphics card from GTX 750 Ti to Gigabyte Aorus RX 570. When I boot with RX 570, the system completely boot but with black screen. When I hit any keyboard button, I hear (frog sound) but with no video shows. I'm trying to change other DisplayPort but no changes. Same thing with USB boot. If I hold power button, system went to sleep. I press it again to wake up monitor comes up.
I'm using Lilu WEG with no changes.
Any fixes for this?
(Sorry for My English)
 

Attachments

Joined
Nov 17, 2018
Messages
8
Motherboard
Asus Rog GL702VM
CPU
i7-6700HQ
Graphics
GTX 1060
Mac
MacBook Pro
Mobile Phone
iOS
Fixed my HD 7870 2GB Sapphire GHz Edition using an adapter from mini display port to HDMI.
Well, I couldn't follow the guides to patch the hdmi and the ports, but after hours of searching, I discovered that a LOT of people had working GPUs using DVI or Mini DisplayPort.
My settings for AMD on Clover are totally EMPTY, in case you wanna know.
 
Joined
May 15, 2016
Messages
5,000
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
Hi all
I update to Mojave 10.14.1, and replaced my graphics card from GTX 750 Ti to Gigabyte Aorus RX 570. When I boot with RX 570, the system completely boot but with black screen. When I hit any keyboard button, I hear (frog sound) but with no video shows. I'm trying to change other DisplayPort but no changes. Same thing with USB boot. If I hold power button, system went to sleep. I press it again to wake up monitor comes up.
I'm using Lilu WEG with no changes.
Any fixes for this?
(Sorry for My English)
Erase the ACPI/Origins entries. Have you tested without the DSDT in ACPI/Patched?
 
Joined
Nov 23, 2013
Messages
6
Motherboard
z97-d3h
CPU
i7 4970
Graphics
GTX 970
Mobile Phone
Android
I was living a dream, with my GTX 970 in the High Sierra. Then I had an opportunity to buy a RX 580. Thinking it would be even more compatible with the macos. Until I get home, and I install it on my machine.

I use a 4k UHD Philips monitor. But in RX 580 it does not work on macos, only on windows. The strange thing is that on windows works 100%, 4k in 60hz on HDMI 2.0. If I put in my old Samsung fullhd 27, it works normally. 1080p 60hz

Video with the problem ...

As you can see in the video, Mojave recognizes it as a RX 570. And then I discovered this ... https://www.extremetech.com/gaming/279010-amd-launches-new-rx-580-with-fewer-stream-processors

The monitor is...
https://www.philips.com.br/c-p/288P6LJEB_57/brilliance-monitor-lcd-ultra-hd-4k

After I discovered this guide, it's working now.

In Clover, I have to set:
- FakeID / ATI = full ID (here: 0x67DF1002)
- Inject / ATI = true
- FBName = framebuffer name Orinoco
- FixDisplay = true
- RadeonDeInit = True


Taking the start of it, which is on the black screen at the beginning and only when I unplug and plug the HDMI that appears the video. Do you have any idea what that might be?

Screen Shot 2018-11-26 at 12.14.35.png

Screen Shot 2018-11-26 at 12.14.50.png

Screen Shot 2018-11-26 at 12.15.07.png
 
Last edited:

Adrian B

Moderator
Joined
Mar 18, 2012
Messages
7,578
Motherboard
Gigabyte GA-B75M-HD3
CPU
i7-3770
Graphics
HD 5570
Mac
iMac, MacBook Pro
Mobile Phone
Other
You don't say which RX 580 that you own - if it is an RX 580 22048 - then it is a re-badged RX570 for Chinese market.

For 4K 60Hz use an "active Displayport adaptor"from your GPU to the HDMI port on your monitor.

Apple have only just released an HDMI 2.0 supported device, with the newest Mac Mini, which was released with a factory release of the OS to support the HDMI 2.0 port. It is not yet known, which Apple models that we may be able use to run macOS in the CustoMac/hackintosh world - would a iMac system definition support HDMI 2.0? We will probably start finding out once 10.14.2 has a public release
 
Joined
Aug 9, 2015
Messages
284
Motherboard
GA-Z170M-D3H
CPU
i5-6600
Graphics
RX 580
Mac
iMac, MacBook, Mac Pro
Classic Mac
iMac
Mobile Phone
Android
My monitor runs at 4K 60Hz with RX 580 using HDMI 2.0, Mojave 14.1, iMac 17 SMBIOS selected in Clover. the RX 580 is from Gigabyte, 8GB Gaming model.
No settings in config.plist, just Lilu and WhatEverGreen in /other.
 
Joined
Nov 23, 2013
Messages
6
Motherboard
z97-d3h
CPU
i7 4970
Graphics
GTX 970
Mobile Phone
Android
My monitor runs at 4K 60Hz with RX 580 using HDMI 2.0, Mojave 14.1, iMac 17 SMBIOS selected in Clover. the RX 580 is from Gigabyte, 8GB Gaming model.
No settings in config.plist, just Lilu and WhatEverGreen in /other.
My computer also ran on the HighSierra with a GTX 970 ... but I managed to solve with this RX 580, configuring the Clover. Thanks
 
Joined
Nov 2, 2011
Messages
6
Motherboard
Asus Prime Z370-A II
CPU
i7-8700K
Graphics
RX 570
Hi all
I update to Mojave 10.14.1, and replaced my graphics card from GTX 750 Ti to Gigabyte Aorus RX 570. When I boot with RX 570, the system completely boot but with black screen. When I hit any keyboard button, I hear (frog sound) but with no video shows. I'm trying to change other DisplayPort but no changes. Same thing with USB boot. If I hold power button, system went to sleep. I press it again to wake up monitor comes up.
I'm using Lilu WEG with no changes.
Any fixes for this?
(Sorry for My English)
I had a similar problem with an RX 570 nitro+ then I reinstalled Mojave with internal graphics enabled and monitor plugged to the Radeon dp with no issue except for low color depth. In graphics section of clover configuration I have only set injectIntel and ig-device-Id
 
Top