Contribute
Register

Radeon Compatibility Guide - ATI/AMD Graphics Cards

Joined
Mar 13, 2011
Messages
17
Motherboard
Gigabyte GA-Z77X-UD5H-WB
CPU
E3-1245 V2
Graphics
P4000 + RX 570X
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
i've bought a MSI ARMOR RX570 4GB OC, but with lilu+whatevergreen or RadeondeInit i can't reach the desktop. The system boot to black screen.

Where is the issue?

I've tried also with -x but system don't start
 
Joined
Jun 8, 2014
Messages
18
CPU
i7-3770
Graphics
RX 460 4GB
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Post your efi folder, you're doing something wrong.
Yep, Currently in EFI i config with RadeonInit and remove Whatevergreen because when i test it is the same and i really like use config in config.plist.
Below is my EFI folder.
 

Attachments

  • EFI.zip
    35.8 MB · Views: 288
Joined
May 11, 2011
Messages
1,157
Motherboard
Asrock B365M Phantom Gaming
CPU
i5-9600KF
Graphics
RX 580
Mobile Phone
  1. iOS
Yep, Currently in EFI i config with RadeonInit and remove Whatevergreen because when i test it is the same and i really like use config in config.plist.
Below is my EFI folder.

Replace EFI with this one. Come back and report.
 

Attachments

  • EFI 2.zip
    35.6 MB · Views: 276
Joined
Jun 8, 2014
Messages
18
CPU
i7-3770
Graphics
RX 460 4GB
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Replace EFI with this one. Come back and report.
Thanks so much for ur response.
I replace my EFI folder with EFI provide by you. Currently MacXvideo can detect and decode by hardware but not detect name of my card is correct. It is a problem or not. Thanks. And in Geenkbench 4 detect my card is Pro 555 also.
I attach sendme folder for you.
Ps: I have one question to ask: Can we convert RX560.kext to a path in config.plist ?
Thanks,
 

Attachments

  • Screen Shot 2018-07-14 at 2.08.12 PM.png
    Screen Shot 2018-07-14 at 2.08.12 PM.png
    229.2 KB · Views: 374
  • Screen Shot 2018-07-14 at 2.10.27 PM.png
    Screen Shot 2018-07-14 at 2.10.27 PM.png
    151.9 KB · Views: 342
  • Send me Phucs-iMac.zip
    3 MB · Views: 103
Last edited:
Joined
May 11, 2011
Messages
1,157
Motherboard
Asrock B365M Phantom Gaming
CPU
i5-9600KF
Graphics
RX 580
Mobile Phone
  1. iOS
Thanks so much for ur response.
I replace my EFI folder with EFI provide by you. Currently MacXvideo can detect and decode by hardware but not detect name of my card is correct. It is a problem or not. Thanks. And in Geenkbench 4 detect my card is Pro 555 also.
I attach sendme folder for you.
Ps: I have one question to ask: Can we convert RX560.kext to a path in config.plist ?
Thanks,

You changed the settings in clover with RadeonDeInit. leave'it uncheck to see RX460.
I removed Hibernation fix kext because it's already an option in clover.
Do you use APFS ? Replace Clover folder with the one from here.
 

Attachments

  • Send me Phucs-iMac.zip
    3 MB · Views: 138
Joined
Jun 8, 2014
Messages
18
CPU
i7-3770
Graphics
RX 460 4GB
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
You changed the settings in clover with RadeonDeInit. leave'it uncheck to see RX460.
I removed Hibernation fix kext because it's already an option in clover.
Do you use APFS ? Replace Clover folder with the one from here.
Thanks u again. :). But notthing happen, my system, keep receive Pro 555 in Geenkbench 4 and in MacXVideo it is a N/A.
I use apfs for install my hack.
 
Joined
May 11, 2011
Messages
1,157
Motherboard
Asrock B365M Phantom Gaming
CPU
i5-9600KF
Graphics
RX 580
Mobile Phone
  1. iOS
Thanks u again. :). But notthing happen, my system, keep receive Pro 555 in Geenkbench 4 and in MacXVideo it is a N/A.
I use apfs for install my hack.

What About This Mac shows? Disable the trim patch from clover, its working better when you have APFS.
 
Joined
Jun 8, 2014
Messages
18
CPU
i7-3770
Graphics
RX 460 4GB
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
What About This Mac shows? Disable the trim patch from clover, its working better when you have APFS.
My About mac is correct. Oh, i don't know that, now i disable the Trim path in Clover. :).
I tested again and i got 2 point:
1. APFS with TRIM enable: boot startup ~30second
2. APFS without TRIM enable: boot startup ~20second

But i don't find any thread about turn off TRIM for APFS. Trim status also still happen in info. In my macbook pro( real mac) trim status is enable. Any different?

Thanks,
 

Attachments

  • Screen Shot 2018-07-15 at 9.20.38 AM.png
    Screen Shot 2018-07-15 at 9.20.38 AM.png
    327 KB · Views: 490
  • Screen Shot 2018-07-15 at 10.34.37 AM.png
    Screen Shot 2018-07-15 at 10.34.37 AM.png
    107.6 KB · Views: 417
Last edited:
Top