Contribute
Register

Radeon Compatibility Guide - ATI/AMD Graphics Cards

Joined
Jun 29, 2017
Messages
45
Motherboard
Gigabyte 170x SOC Force
CPU
i7-7700k
Graphics
Sapphire RX Vega 64 8GB
Mac
  1. Mac mini
  2. Mac Pro
Installed a Gigabyte RX 560 gaming OC 2GB on 10.13. It works fine with Lilu & Whatevergreen.
Geekbench opencl at 81000, BruceX at 27sec, no black screen while booting.
 
Joined
Oct 16, 2015
Messages
97
Motherboard
Gigabyte GA-Z370N-Wifi
CPU
i7-8700K
Graphics
Vega 56
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. eMac
Mobile Phone
  1. iOS
Hey guys can we can an update as to what is working? Im looking to upgrade my dual 280x for fcpx, still on el capitan also.

I too am curious about the state of AMD cards now with High Sierra. Have been hoping that the new Vega cards would work OOB and that their performance in FCPX would be a huge leap. Haven't seen anything about it though :-/

Maybe when the new iMac Pro comes out in a few months???
 
Joined
Aug 12, 2016
Messages
41
Motherboard
Gigabyte Z170MX-GAMING 5
CPU
I7-6700K
Graphics
SAPHIRE VEGA 64 LC
@khriswithak
They work OOTB! Use by myself one and bought already a second one for Video Editing.
its not just about working, what are they benchmarks? my open cl score with dual 280x and an i7 6700 is 117869. Were looking for performance improvements not just to see if it works.
 
Joined
Oct 13, 2017
Messages
19
Motherboard
Asus Z97-A
CPU
i7 4790k CPU
Graphics
ATI Radeon HD 5670
Have anyone managed to get ATI Radeon HD 5670 to work with Clover?

I am getting black screen after Apple Logo..

Advice please?
 
Joined
Oct 16, 2015
Messages
97
Motherboard
Gigabyte GA-Z370N-Wifi
CPU
i7-8700K
Graphics
Vega 56
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. eMac
Mobile Phone
  1. iOS
@khriswithak : What ??? You haven't seen anything about it? Sorry but then you are blind!
They work OOTB! Use by myself one and bought already a second one for Video Editing.

If you could kindly post some benchmarks / BruceX times, that would be great. I'm currently on El Capitan with a GTX 960 and I get 26 sec on BruceX. I haven't seen any scores with the AMD 560/580 on High Sierra that seem much better than that. Curious how the Vega cards do.
 
Joined
Sep 10, 2012
Messages
113
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KS
Graphics
RX Vega 64
RX560 4GB (Gigabyte) works fine here too, with Lilu and WEgreen, gets recognised as "Radeon Pro 560 4GB" in High Sierra. No helper card needed. BruceX is 30 secs with my ageing 4.6 GHz 3770K.

Geekbench OpenCL: 78982
 
Last edited:
Joined
Jan 20, 2016
Messages
66
Motherboard
Asus Strix 390-F
CPU
i9-9900kf
Graphics
Rx 570
Mac
  1. Mac Pro
Mobile Phone
  1. Android
guys I have rx 550 booting up no problem with 17,2 definition and lilu and whatever green kext

however I dont seem to have any acceleration. its only showing as 14mb and everything is laggy and flickering.
 
Joined
Dec 6, 2015
Messages
19
Motherboard
Asus Z170-A
CPU
i5-6600k
Graphics
Sapphire Radeon R9 380X
Mobile Phone
  1. Android
Hello Guys,

So, I had a really good installation in Sierra with everything running, but by the time I updated to High Sierra i cannot connect my second monitor! Mac recognizes it but it still has a black screen. My setup is:

Monitor 1 = Main monitor. Connected via HDMI - HDMI.
Monitor 2 = Second monitor. Connected via DVI - VGA.

I have the LiLu and Whatevergreen kexts installed, and I even tried a suggestion from here: https://www.tonymacx86.com/threads/dual-monitor-setup-not-working.232966/#post-1592088

I have tried to modify my framebuffer, and I face two problems.
1. If I select to inject the Lagotto Framebuffer to Clover, it does nothing when I connect a second monitor. It doesn't recognise the second one at all.
2. If i do not select to inject the framebuffer but I just add the patch info for my card to the AMD9000Controller, it recognizes the second monitor and it switches my main screen into the second one, but the physical second screen does nothing.

My card is the 4GB Sapphire Nitro Version of R9 380X.

Thank you in advance
 
Top