Contribute
Register

Radeon Compatibility Guide - ATI/AMD Graphics Cards

Joined
Aug 15, 2011
Messages
71
Motherboard
EVGA-Z370 FTW
CPU
i7-8700K
Graphics
PowerColor 5600 XT
Mac
  1. iMac
Mobile Phone
  1. Android
Thanks anyway for the info, I don't understand what need to do. I don't know how to enable lilu and whatevergreen. Thank you in advance for the help. I will try to read slowly and try to understand it.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,658
Motherboard
Asus ProArt Z490 Creator
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Thanks anyway for the info, I don't understand what need to do. I don't know how to enable lilu and whatevergreen. Thank you in advance for the help. I will try to read slowly and try to understand it.
You can use MultiBeast v9.2.1 to load those two kexts (makes it easier). Run MultiBeast v9.2.1 and just select the following:

Customize > Graphics Configuration > AMD Graphics Fixup AKA WhateverGreen
Build
Install
Reboot​

See Page 7 & 8 in the MultiBeast Features document that comes with MultiBeast.
 
Joined
Aug 15, 2011
Messages
71
Motherboard
EVGA-Z370 FTW
CPU
i7-8700K
Graphics
PowerColor 5600 XT
Mac
  1. iMac
Mobile Phone
  1. Android
I will do now. I'm very interested to enable it. Thank you in advance.

I just done it. Installed lilu.kext, and whatevergreen.kext, and now I have whatevername app in apps folder.

What Do I need to do now? I'm very lost at this momment.
 
Last edited:
Joined
Dec 25, 2015
Messages
162
Motherboard
Asus Maximus X Code Z-370
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
In my case only one DP is working. Thats why I am not getting the second display. Anyone else seeing the issue?
 
Joined
Dec 25, 2015
Messages
162
Motherboard
Asus Maximus X Code Z-370
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
What I am noticing is that the radeon and redsock decoder are giving a partial out put on Vega ROM.
 

Attachments

  • Screen Shot 2017-09-26 at 5.49.54 PM.png
    Screen Shot 2017-09-26 at 5.49.54 PM.png
    66.4 KB · Views: 169
  • c0000.bin.zip
    128 KB · Views: 112
Joined
Jul 14, 2012
Messages
42
Motherboard
ASUS ROG Z270-E
CPU
i7-8700K
Graphics
GTX 1080 TI
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
I have the raedon r9 280x as well, and can't get to the installer - it did book with IGPU enabled in bios, but then with inject intel, I only get 512 MB of video ram :(
 
Joined
Aug 1, 2016
Messages
4
Motherboard
HP Elitebook 8460P
CPU
i5 2540M
Graphics
Intel HD3000
Mac
  1. Mac Pro
Mobile Phone
  1. Android
  2. iOS
are there any news on HD7870 and HighSierra?
 
Joined
Jul 6, 2011
Messages
16
Motherboard
Gigabyte GA-EG45M-DS2H (rev. 1.0) Intel®G45 + ICH10R Chipset Socket 755
CPU
Intel® Core™2 Quad Processor Q9550 (12M Cache, 2.83 GHz, 1333 MHz FSB)
Graphics
ASUS AMD ATI Radeon HD 5670 1024 MB
Mac
  1. iMac
Mobile Phone
  1. Android
After upgrade from Sierra to High Sierra I just get a black screen after boot. I have a AMD Radeon HD5670 graphic card native supported by macOS until now. What could be wrong?
 
Joined
Jun 16, 2014
Messages
101
Motherboard
Gigabyte Z97M-D3H
CPU
Intel Core i7 4790K@4.7
Graphics
Sapphire RX480 Nitro 8gb +VEGA 56
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I have the VEGA 56 up and running on High Sierra everything works, except when I open (Visual Studio Code) graphic card goes crazy and system becomes unresponsive until I reboot! I replaced the VEGA with RX480 and everything works!
 
Top