Contribute
Register

Quick Fix: Z370/200/X299/ Series Kaby Lake Audio, Onboard and/or HD 6x0 HDMI

Status
Not open for further replies.
Joined
May 6, 2017
Messages
13
Motherboard
ASUS PRIME Z270-A
CPU
Intel Core i7-7700K (4.2 GHz)
Graphics
ASUS STRIX GeForce GTX 1080 Ti GAMING
Also I started on verbose mode, and it noticed me in the 5 last lines that:
 

Attachments

  • Verbose Mode2.jpg
    Verbose Mode2.jpg
    535.4 KB · Views: 216
Joined
Nov 17, 2013
Messages
7
Motherboard
Gigabyte GA-Z270XP-SLI
CPU
i5 > Need model # > See Rules!
Graphics
Intel version # > See Rules!
Mac
  1. iMac
Classic Mac
  1. Apple
Mobile Phone
  1. Android
2787035531_066ba1ee85.jpeg

Quick Fix: 200 Series/Kaby Lake Audio
Onboard and/or HD 6x0 HDMI Audio


The 200 Series/Kaby Lake HD Audio Controller is currently not supported in released versions of macOS (developer builds. excepted). Symptoms are audio devices present, iTunes not playing and no sound.

Fix: Patch the Skylake Audio Controller (0xa170) for Kaby Lake (0xa2fo)
This fix is temporary, required until macOS/AppleHDA.kext natively supports 200 Series Audio.

Supports 10.12.5 and 10.12.4.

Solutions (select and install one solution only)
  1. RehabMan/OS-X-Fake-PCI-ID - No issues expected with native 200 Series Audio supported/AppleHDA.kext
    • Download: OS-X-Fake-PCI-ID / Downloads
      • Install (use kext installer)
        • FakePCIID.kext (if not installed previously)
        • FakePCIID_Intel_HDMI_Audio.kext
  2. Edit config.plist - Must be removed before installing/updating native 200 Series Audio supported/AppleHDA.kext (one choice or the other)
  3. Patched AppleHDA.kext - Software Update removes patch (install one choice only)
    • A. Patch AppleHDA.kext/audio_200_Series_hda-124_v1.0.command
      • Download: audio_200_Series_hda-124_v1.0.command.zip
      • Double click Downloads/audio_200_Series_hda-124_v1.0.command
      • Enter Password
      • Copies installed AppleHDA.kext to Desktop/audio_10.12.x/AppleHDA-orig.kext
      • Verifies:
        • 10.12
        • SIP disabled
        • 200 Series motherboard
        • Installed AppleHDA.kext does not support 200 Series Audio
      • Rebuilds kernel cache
    • B. Patch AppleHDA.kext (use hex editor)
      • Copy System/System/Library/Extensions/AppleHDA.kext to Desktop
      • Edit Desktop/AppleHDA.kext/Contents/Plugins/AppleHDAController.kext/Contents/MacOS
        • Find: 3d70a1 (3x)
        • Rplc: 3df0a2
      • Save
      • Install (use kext installer)
        • Desktop/AppleHDA.kext
    • C. Patched AppleHDA.kext
      • AppleHDA.kext (10.12.5)
        • See attachment (below)
        • Install (use kext installer)
          • Downloads/200 Series Audio/AppleHDA/10.12.45

      • AppleHDA.kext (10.12.4)
        • See attachment (below)
        • Install (use kext installer)
          • Downloads/200 Series Audio/AppleHDA/10.12.4
Not working/Post to thread linked with requested files attached:
  1. No Audio Devices - Realtek ALC AppleHDA/Post #1/II. Problem Reporting.
  2. No Sound - Realtek ALC AppleHDA/Post #1/Problem Reporting.
Credit: dgsga/Native ALC1220 audio for 200-series motherboards




Is it a folder, and where can I find it?
KernelAndKextPatches/KextsToPatch/Item 17
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,921
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
religiously followed the quick fixes from here
Post #1/Solutions (select and install one solution only)
What part of the instruction is not clear?

System is not repairable. UniBeast install over corrupt system.
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,921
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
where can I find it?
Rules: • Profiles need to contain at least your primary system to assist others with helping you.
Click on the Download link
See Downloads/config-audio_cloverALC-120.plist
 
Joined
May 6, 2017
Messages
13
Motherboard
ASUS PRIME Z270-A
CPU
Intel Core i7-7700K (4.2 GHz)
Graphics
ASUS STRIX GeForce GTX 1080 Ti GAMING
Post #1/Solutions (select and install one solution only)
What part of the instruction is not clear?

System is not repairable. UniBeast install over corrupt system.

Hi @toleda , So I need to reinstall Unibeast?

As I will need to fix the sound anyway, how do I know which sound fix is the right one, if I have to choose one? Depends on my config?

Thanks
 
Joined
Jan 23, 2016
Messages
4
Motherboard
GB-BKi5HA-7200
CPU
I5-7200U
Graphics
HD620
Tried each 3 methods and no luck...
My platform is BRIX7,7200U,HD620.
Problem is I don't know the series of the chipset,AIDA shows 'Intel Kaby Lake-U IMC'.
 
Joined
May 12, 2017
Messages
9
Motherboard
GA-Z270X-Gaming K5
CPU
i7-7700
Graphics
GeForce GTX 1070 Xtreme 8G
Hi all,

I have been having the following issue since installing the ALC1220 audio drivers. I now get some audio devices show up in my sound preferences however no sound will play; YouTube videos constantly buffer and media files immediately stop playing after clicking play.

LOChujOzH3.gif


The original steps I took were to install the "100 / 200 Series Audio" and "ALC1220" drivers via multibeast. I have then tried steps 1 and 3A of this thread but I am still having the same problems. Has anyone else had these issue or know what is causing this?

Thanks,
 
Status
Not open for further replies.
Top