Contribute
Register

Quick Fix for Onboard Audio on 9 Series Motherboards

Joined
Sep 11, 2012
Messages
21
Motherboard
Gigabyte GA-Z77P-D3 - CloverUEFI
CPU
i5-3570K
Graphics
HD 7850
Mac
  1. iMac
Mobile Phone
  1. iOS
Friends, what "layout ID" I can use for ALC 887 codec? I am using a "AppleHDA" patched for my codec and using the "Layout ID" 4 but the front microphone and headphone does not sound come out. This "kext" will run these front "doors"?
Thanks.
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,235
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I am using a "AppleHDA" patched for my codec and using the "Layout ID" 4
You are not using an AppleHDA.kext from this site. Contact the author for support.

This solution is only for 9 Series motherboards.
 
Joined
Feb 7, 2010
Messages
48
Motherboard
Acer E15 ( E5-571-33AC
CPU
i3 4005U@ 1.7Ghz
Graphics
HD4400@1366*768
Mac
  1. MacBook Pro
Classic Mac
  1. Performa
Mobile Phone
  1. iOS
Do not use Audio ID:2. The Post #1 patched ALC1150 is not installed. Try again.

:) :)
Toleda,

I speak English very badly, and I think we do not understand :)

I have the first post installed AppleHDA (AppleHDA-1150-9-series.zip)

if I use the ID-1 in the DSDT I have no sound on any jack: (

If you use the ID-2 have sound from the pink and blue connector

-------------

I'm out now (here are the 4:50 p.m.) :)

as soon as I get home and taste more,

but I tried several times and always the same result: (

I'll have to modify the Device (HDEF)??

I have the patch ALC1150 of Pjalm :)
 

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,720
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
Just re-tested on the Z97-D3H- ALC 1150 is working fine with manual installation of OP kext. Unfortuntately Green rear audio port is not working. All other inputs and outputs are working. Headphone front case works as main output.
 

Attachments

  • 1150.iojones
    606.8 KB · Views: 301

toleda

Moderator
Joined
May 20, 2010
Messages
24,235
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Unfortunately Green rear audio port is not working.
Confirmed: 1150 Green Rear working and 1150 Front Green working (non Gigabyte 9 Series)
Two issues:
1. 10.9.3 AppleHDA.kext_v2.6.1, Speaker/Headphone switching does not work after wake. Means if Headphones are plugged in when sleep starts, settings stays headphones after wake even with Headphones removed.
2. Gigabyte 9 Series 1150 audio implementation. Request codec dump to confirm.
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,235
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
if I use the ID-1 in the DSDT I have no sound on any jack: (

If you use the ID-2 have sound from the pink and blue connector
ID:1 orange and black same as ID:2 pink and blue.
ID:1, dsdt/HDEF/layout-id/0x01, 0x00, 0x00, 0x00
ID:2, dsdt/HDEF/layout-id/0x02, 0x00, 0x00, 0x00
 
Joined
Feb 7, 2010
Messages
48
Motherboard
Acer E15 ( E5-571-33AC
CPU
i3 4005U@ 1.7Ghz
Graphics
HD4400@1366*768
Mac
  1. MacBook Pro
Classic Mac
  1. Performa
Mobile Phone
  1. iOS
ID:1 orange and black same as ID:2 pink and blue.
ID:1, dsdt/HDEF/layout-id/0x01, 0x00, 0x00, 0x00
ID:2, dsdt/HDEF/layout-id/0x02, 0x00, 0x00, 0x00

Thanks Toleda :)

my Device (HDEF) :

Code:
Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
            {
                Store (Package (0x0E)
                    {
                        "AAPL,slot-name", 
                        "Built In", 
                        "name", 
                        "Realtek Audio Controller", 
                        "model", 
                        Buffer (0x21)
                        {
                            "Realtek ALC1150 Audio Controller"
                        }, 

                        "device_type", 
                        Buffer (0x11)
                        {
                            "Audio Controller"
                        }, 

                        "layout-id", 
                        Buffer (0x04)
                        {
                             0x01, 0x00, 0x00, 0x00
                        }, 

                        "PinConfigurations", 
                        Buffer (Zero) {}, 
                        "hda-gfx", 
                        Buffer (0x0A)
                        {
                            "onboard-1"
                        }
                    }, Local0)
                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                Return (Local0)
            }

and does not work any connector

I'll try again and reinstall the AppleHDA and confirm if it sounds xD :)

one moment please

EDIT:

I have reinstalled the AppleHDA and: ( DSDT-HDEF on ID:1 )

Code:
-chmod -R 755 /System/library/Extensions/AppleHDA.kext
-chown -R root:wheel /System/library/Extensions/AppleHDA.kext
-Repairpermissions /
-Touch /System/library/Extensions
-Reboot

and work only orange and black connector, and nVidia HDMI of course xD

is that correct??

green not work, and it was where I had connected the speakers


Many thanks :)
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,235
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
and work only orange and black connector, and nVidia HDMI of course xD
ID: 1 is working. Green not working is consistent with other 1150/9 series reports. Use black or orange as a temporary fix. Attach an 1150 codec dump.
 
Top