Quick Fix: 200/X299/300 Series Kaby Lake Audio, Onboard and/or HD 6x0 HDMI

Discussion in 'Audio' started by toleda, May 10, 2017.

  1. zebrum

    zebrum

    Joined:
    Sep 9, 2016
    Messages:
    42
    Aug 18, 2017 at 5:03 PM #71
    zebrum

    zebrum

    Joined:
    Sep 9, 2016
    Messages:
    42
    Apologies the crackling I was hearing was with Apple headphones (with mic pin) in front port and might be hardware issue like something specific to the ALC1220 120DB in GA-H270-Gaming 3.

    I got HDMI audio working but it was a manual process.

    First post should be edited to say 200 audio is natively supported now. Apologies, meant ALC1220 is native in AppleHDA now guess that's different.
     
    Last edited: Aug 19, 2017
  2. toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,159
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    Aug 19, 2017 at 3:05 AM #72
    toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,159
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    Not native in Sierra, purpose of the fix.
     
  3. federico883

    federico883

    Joined:
    Jun 12, 2015
    Messages:
    9
    Mobo:
    Gigabyte GA-H170-HD3
    CPU:
    Intel Core i5-7600 3.5GHz 6MB
    Graphics:
    Asus 710-2-SL GeForce
    Mobile Phone:
    iOS
    Aug 22, 2017 at 9:45 AM #73
    federico883

    federico883

    Joined:
    Jun 12, 2015
    Messages:
    9
    Mobo:
    Gigabyte GA-H170-HD3
    CPU:
    Intel Core i5-7600 3.5GHz 6MB
    Graphics:
    Asus 710-2-SL GeForce
    Mobile Phone:
    iOS
    Hi,
    i have a gigabyte ga Z270-Hd3p. My audio device is found, but sound not work.
    What can I try?

    Thanks

    The report of terminal:

    Agreement

    The audio_cloverALC script is for personal use only. Do not distribute

    the patch, any or all of the files or the resulting patched AppleHDA.kext

    for any reason without permission. The audio_cloverALC script is

    provided as is and without any kind of warranty.


    File: audio_cloverALC-120.command_v1.0f3

    Release Mode

    Password:

    EFI partition is mounted

    System Integrity Protection status: enabled (Custom Configuration).


    Configuration:

    Apple Internal: disabled

    Kext Signing: disabled

    Filesystem Protections: disabled

    Debugging Restrictions: enabled

    DTrace Restrictions: enabled

    NVRAM Protections: enabled

    BaseSystem Verification: enabled


    This is an unsupported configuration, likely to break in the future and leave your machine in an unknown state.


    OK to patch

    Confirm Realtek ALC887 (y/n): y

    ALC887 v_0x100302 (Current)

    Clover Audio ID Injection (y/n): y

    Use Audio ID: 1 (y/n): y


    Download ALC887 files ...

    % Total % Received % Xferd Average Speed Time Time Time Current

    Dload Upload Total Spent Left Speed

    100 24502 100 24502 0 0 65774 0 --:--:-- --:--:-- --:--:-- 65865

    Edit config.plist/Devices/Audio/Inject/1

    Edit config.plist/SystemParameters/InjectKexts/YES

    Download kext patches

    % Total % Received % Xferd Average Speed Time Time Time Current

    Dload Upload Total Spent Left Speed

    100 1855 100 1855 0 0 6883 0 --:--:-- --:--:-- --:--:-- 6870

    Download config kext and install ...

    % Total % Received % Xferd Average Speed Time Time Time Current

    Dload Upload Total Spent Left Speed

    100 4223 100 4223 0 0 16316 0 --:--:-- --:--:-- --:--:-- 16368

    Install /Volumes/EFI/EFI/CLOVER/kexts/10.12/realtekALC.kext

    Install System/Library/Extensions/AppleHDA.kext/ALC887 zml files

    Fix permissions ...

    Kernel cache...

    rebuilding //System/Library/PrelinkedKernels/prelinkedkernel

    kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext Shiki.kext

    kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext Lilu.kext

    kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext IntelMausiEthernet.kext

    FakeSMC_LPCSensors.kext - dependency 'org.netkas.driver.FakeSMC' not found.

    FakeSMC_LPCSensors.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)

    kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC_LPCSensors.kext

    FakeSMC_GPUSensors.kext - dependency 'org.netkas.driver.FakeSMC' not found.

    FakeSMC_GPUSensors.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)

    kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC_GPUSensors.kext

    FakeSMC_CPUSensors.kext - dependency 'org.netkas.driver.FakeSMC' not found.

    FakeSMC_CPUSensors.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)

    kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC_CPUSensors.kext

    FakeSMC_ACPISensors.kext - dependency 'org.netkas.driver.FakeSMC' not found.

    FakeSMC_ACPISensors.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)

    kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC_ACPISensors.kext

    kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_XHCIMux.kext

    kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_Intel_HDMI_Audio.kext

    kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_Intel_HD_Graphics.kext

    kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID.kext

    kext-dev-mode allowing invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext AppleHDAController.kext

    kext-dev-mode allowing invalid signature -67054 0xFFFFFFFFFFFEFA12 for kext AppleHDA.kext

    FakeSMC_LPCSensors.kext - dependency 'org.netkas.driver.FakeSMC' not found.

    FakeSMC_GPUSensors.kext - dependency 'org.netkas.driver.FakeSMC' not found.

    FakeSMC_CPUSensors.kext - dependency 'org.netkas.driver.FakeSMC' not found.

    FakeSMC_ACPISensors.kext - dependency 'org.netkas.driver.FakeSMC' not found.

    FakeSMC_LPCSensors.kext - dependency 'org.netkas.driver.FakeSMC' not found.

    Prelink failed for org.hwsensors.driver.LPCSensors; omitting from prelinked kernel.

    FakeSMC_GPUSensors.kext - dependency 'org.netkas.driver.FakeSMC' not found.

    Prelink failed for org.hwsensors.driver.GPUSensors; omitting from prelinked kernel.

    FakeSMC_CPUSensors.kext - dependency 'org.netkas.driver.FakeSMC' not found.

    Prelink failed for org.hwsensors.driver.CPUSensors; omitting from prelinked kernel.

    FakeSMC_ACPISensors.kext - dependency 'org.netkas.driver.FakeSMC' not found.

    Prelink failed for org.hwsensors.driver.ACPISensors; omitting from prelinked kernel.

    KernelCache ID: F8AE8896EBF255908411402BAE7EE2A6

    symlink("/System/Library/PrelinkedKernels/prelinkedkernel", "/System/Library/Caches/com.apple.kext.caches/Startup/kernelcache") failed 17 (File exists) <createPrelinkedKernel 2795>

    kextcache updated critical boot files, requesting launchd reboot


    Install finished, restart required.

    To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...

    logout

    Saving session...

    ...copying shared history...

    ...saving history...truncating history files...

    ...completed.
     

    Attached Files:

    • Schermata 2017-08-22 alle 10.41.14.png  (73.1 KB, 114 views)
    • Schermata 2017-08-22 alle 10.41.36.png  (65.3 KB, 127 views)
    • Schermata 2017-08-22 alle 10.44.20.png  (55.7 KB, 129 views)
    • Schermata 2017-08-22 alle 10.44.35.png  (207.9 KB, 118 views)
    • Schermata 2017-08-22 alle 10.44.48.png  (226.9 KB, 103 views)
  4. toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,159
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    Aug 22, 2017 at 1:25 PM #74
    toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,159
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    No problen solving on this thread.
    See Post #1, Not working ... Off topic.
    Note method used.
     
    Last edited: Aug 22, 2017
  5. jeffcarrera

    jeffcarrera

    Joined:
    Sep 3, 2012
    Messages:
    132
    Mobo:
    Ga B250M HD3
    CPU:
    i5 7500
    Graphics:
    HD 630
    Mac:
    MacBook Air, MacBook Pro
    Mobile Phone:
    Android
    Aug 25, 2017 at 11:12 AM #75
    jeffcarrera

    jeffcarrera

    Joined:
    Sep 3, 2012
    Messages:
    132
    Mobo:
    Ga B250M HD3
    CPU:
    i5 7500
    Graphics:
    HD 630
    Mac:
    MacBook Air, MacBook Pro
    Mobile Phone:
    Android
    Solution 3A fixed my ALC 887 Audio, Thanks Toleda!!
     
  6. clarklak11

    clarklak11

    Joined:
    Jul 19, 2017
    Messages:
    30
    Mobo:
    MSI H270 Gaming M3
    CPU:
    Core i5-7500
    Graphics:
    GTX 1050 TI
    Mobile Phone:
    Android, iOS, Other
    Sep 1, 2017 at 8:06 AM #76
    clarklak11

    clarklak11

    Joined:
    Jul 19, 2017
    Messages:
    30
    Mobo:
    MSI H270 Gaming M3
    CPU:
    Core i5-7500
    Graphics:
    GTX 1050 TI
    Mobile Phone:
    Android, iOS, Other
    Should I have "AppleHDA.kext" on my System/Library/Extension?
     
  7. toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,159
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    Sep 1, 2017 at 2:22 PM #77
    toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,159
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    Yes, the directory is hidden. Search: Finder show hidden files
     
  8. j4v3l

    j4v3l

    Joined:
    Jul 8, 2017
    Messages:
    18
    Mobo:
    GA-Z270X-Gaming K7
    CPU:
    Intel I7-7700k
    Graphics:
    Gigabyte GTX 960 G1 Gaming 2GB GDDR5
    Mac:
    iMac
    Mobile Phone:
    Android, iOS
    Sep 10, 2017 at 2:38 AM #78
    j4v3l

    j4v3l

    Joined:
    Jul 8, 2017
    Messages:
    18
    Mobo:
    GA-Z270X-Gaming K7
    CPU:
    Intel I7-7700k
    Graphics:
    Gigabyte GTX 960 G1 Gaming 2GB GDDR5
    Mac:
    iMac
    Mobile Phone:
    Android, iOS
    Front audio jack doesn't work.
     
  9. toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,159
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    Sep 10, 2017 at 2:55 AM #79
    toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,159
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    See Post #1, Not working ...
    Off topic
     
  10. sopadesicomoro

    sopadesicomoro

    Joined:
    Jul 1, 2017
    Messages:
    16
    Mobo:
    GA-Z97M-D3H
    CPU:
    i7-4790 Hashwell
    Graphics:
    NVIDIA GeForce GTX 960
    Mac:
    iMac, Mac Pro
    Oct 6, 2017 at 10:27 PM #80
    sopadesicomoro

    sopadesicomoro

    Joined:
    Jul 1, 2017
    Messages:
    16
    Mobo:
    GA-Z97M-D3H
    CPU:
    i7-4790 Hashwell
    Graphics:
    NVIDIA GeForce GTX 960
    Mac:
    iMac, Mac Pro
    Hello.

    I got audio working on 10.12.6 with Realtek 892 drivers. Normally works but sometimes audio drops and I have to either unplug and plug or I have to restart the computer. This is not a problem with sleep mode. It happens randomly.

    1. Audio suddenly stops working. Device is shown. Have to restart. Normally works.
    2. macOS Sierra 10.12.6 / mobo GA-H270m-D3H / BIOS v.F6 / Intel i7 7700 / nVidia Geforce 1050 Ti
    3. Method Used:Before You Install Audio - Desktop/Realtek/AppleHDA [Guide]
    1. Drivers on Multibeast -> RealtekALC892 + 100 / 200 Series Audio​
    4. Cant use audio_codecdetect.command because permissions
    5. Adjunting copy of IOReg
    9. Screenshots
    1. Adjunting DPCIManager Status Screenshot
    2. Adjunting Intel High Definition Audio screenshot
    3 Adjunting Sound Outputs on Sys Prefs screenshot​
    12. Adjunting config.plist

    With this configuration audio works mostly fine. But again. It suddenly stops working. Any ideas? Also dropping frames on premiere. Trying to solve that issue too.

    Please help.
     

    Attached Files:

    • no ioreg.ioreg   (3.1 MB, 8 views)
    • DPCIManager Status Screenshot.png  (108.5 KB, 44 views)
    • Intel High Definiton Audio Screenshot.png  (141.9 KB, 41 views)
    • Sound Output Prefs Screenshot.png  (77.7 KB, 41 views)
    • config.plist   (0 bytes, 7 views)
    • CLOVER APCI screenshot.png  (229.2 KB, 44 views)
    • Extensions screenshot.png  (185.4 KB, 41 views)

Share This Page