Contribute
Register

Qualcomm Atheros Killer Ethernet E2400

Status
Not open for further replies.
Joined
Sep 3, 2015
Messages
169
Motherboard
MSI X99A GODlike Gaming LGA 2011-v3 Intel X99
CPU
i7-5820K Haswell-E 6-Core 3.3 GHz LGA 2011-v3 140W
Graphics
MSI GeForce GTX 980Ti 6GD5T OC 6GB 384-Bit GDDR5
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Or it could mean it was a lower case 'e'.

Better to look at system.log in Console.app.

Thank you for all of your help. I was able to get the following kext downloaded and it just worked perfectly for the first time in months. I have been reformatting and reinstalling OS El Capitan several times and now it looks like it is working perfectly.

If anyone else has E2400 NIC i suggest they install this kext and hope it works. http://www.insanelymac.com/forum/to...ros-ar816x-ar817x-and-killer-e220x/?p=2192549

Mac App Store works perfect and didn't have to make any changes at all. Getting perfect speeds and was able to download the XCode app from MAS (which is over 4gbs) in under a minute.

Super stoked:headbang:
 
Joined
Mar 23, 2013
Messages
30
Motherboard
GA-Z170MX
CPU
i7-6700K
Graphics
Vega 56 OC
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
Hi guys,

I've installed the kext shakakoa suggested above (2.1.0.d1) and cannot get my system to show the ethernet in System Prference > Network.

I've searched console for e2200, and it appears it is finding it. Here is all of the info console gives me:

Mar 19 18:41:36 Theos-Mac-Pro com.apple.kextd[51]: kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext "/System/Library/Extensions/AtherosE2200Ethernet.kext"
Mar 19 18:41:37 Theos-Mac-Pro com.apple.kextd[51]: kext signature failure override allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext "/System/Library/Extensions/AtherosE2200Ethernet.kext"
Mar 19 18:41:37 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: Found Killer E2400.
Mar 19 18:41:37 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: PCI power management capabilities: 0xf9c3.
Mar 19 18:41:37 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: PME# from D3 (cold/hot) supported.
Mar 19 18:41:37 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: PCIe link capabilities: 0x0007fc11, link control: 0x0140.
Mar 19 18:41:37 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: PCIe ASPM enabled.
Mar 19 18:41:37 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: TCP/IPv4 segmentation offload enabled.
Mar 19 18:41:37 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: TCP/IPv6 segmentation offload enabled.
Mar 19 18:41:37 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: TCP/IPv6 checksum offload enabled.
Mar 19 18:41:37 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: Got MAC address from efuse.
Mar 19 18:41:37 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: Killer E2400: (Rev. 16) at 0x<ptr>, 1c:1b: d:68:26:a9
Mar 19 18:41:37 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: Version 2.1.0d1 using max interrupt rate 5000. Please don't support tonymacx86.com!
Mar 19 18:41:37 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: MSI interrupt index: 1
Mar 19 18:41:37 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: kIOEthernetWakeOnMagicPacket added to filters.
Mar 19 18:41:37 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: Already in power state 1.
Mar 19 18:42:46 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: No medium selected. Falling back to autonegotiation.
Mar 19 18:42:46 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: Link down on en5
Mar 19 18:42:46 Theos-Mac-Pro kernel[0]: Ethernet [AtherosE2200]: Restored PCI command register.
Mar 19 18:43:01 Theos-Mac-Pro kernel[0]: Sandbox: chown(2200) System Policy: allow(0) file-write-owner /System/Library/Extensions/AppleEFIRuntime.kext/Contents/MacOS
Mar 19 18:46:29 localhost kernel[0]: Ethernet [AtherosE2200]: Found Killer E2400.
Mar 19 18:46:29 localhost kernel[0]: Ethernet [AtherosE2200]: PCI power management capabilities: 0xf9c3.
Mar 19 18:46:29 localhost kernel[0]: Ethernet [AtherosE2200]: PME# from D3 (cold/hot) supported.
Mar 19 18:46:29 localhost kernel[0]: Ethernet [AtherosE2200]: PCIe link capabilities: 0x0007fc11, link control: 0x0140.
Mar 19 18:46:29 localhost kernel[0]: Ethernet [AtherosE2200]: PCIe ASPM enabled.
Mar 19 18:46:29 localhost kernel[0]: Ethernet [AtherosE2200]: TCP/IPv4 segmentation offload enabled.
Mar 19 18:46:29 localhost kernel[0]: Ethernet [AtherosE2200]: TCP/IPv6 segmentation offload enabled.
Mar 19 18:46:29 localhost kernel[0]: Ethernet [AtherosE2200]: TCP/IPv6 checksum offload enabled.
Mar 19 18:46:29 localhost kernel[0]: Ethernet [AtherosE2200]: Got MAC address from efuse.
Mar 19 18:46:29 localhost kernel[0]: Ethernet [AtherosE2200]: Killer E2400: (Rev. 16) at 0x<ptr>, 1c:1b: d:68:26:a9
Mar 19 18:46:29 localhost kernel[0]: Ethernet [AtherosE2200]: Version 2.1.0d1 using max interrupt rate 5000. Please don't support tonymacx86.com!
Mar 19 18:46:29 localhost kernel[0]: Ethernet [AtherosE2200]: MSI interrupt index: 1
Mar 19 18:46:29 localhost kernel[0]: Ethernet [AtherosE2200]: kIOEthernetWakeOnMagicPacket added to filters.
Mar 19 18:46:29 localhost kernel[0]: Ethernet [AtherosE2200]: Already in power state 1.
Mar 19 18:46:30 localhost kernel[0]: Ethernet [AtherosE2200]: No medium selected. Falling back to autonegotiation.
Mar 19 18:46:30 localhost kernel[0]: Ethernet [AtherosE2200]: Link down on en5
Mar 19 18:46:30 localhost kernel[0]: Ethernet [AtherosE2200]: Restored PCI command register.
Mar 19 18:46:33 Theos-Mac-Pro kernel[0]: **** [IOBluetoothFamily][ProcessBluetoothTransportShowsUpActionWL] -- calling IOBluetoothFamily's registerService() -- 0x6e20 -- 0x2200 -- 0x0800 ****
Mar 19 18:46:33 Theos-Mac-Pro kernel[0]: **** [IOBluetoothFamily][ProcessBluetoothTransportShowsUpActionWL] -- Connected to the transport successfully -- 0x6e20 -- 0x2200 -- 0x0800 ****
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: Found Killer E2400.
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: PCI power management capabilities: 0xf9c3.
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: PME# from D3 (cold/hot) supported.
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: PCIe link capabilities: 0x0007fc11, link control: 0x0140.
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: PCIe ASPM enabled.
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: TCP/IPv4 segmentation offload enabled.
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: TCP/IPv6 segmentation offload enabled.
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: TCP/IPv6 checksum offload enabled.
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: Got MAC address from efuse.
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: Killer E2400: (Rev. 16) at 0x<ptr>, 1c:1b: d:68:26:a9
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: Version 2.1.0d1 using max interrupt rate 5000. Please don't support tonymacx86.com!
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: MSI interrupt index: 1
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: kIOEthernetWakeOnMagicPacket added to filters.
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: Already in power state 1.
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: No medium selected. Falling back to autonegotiation.
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: Link down on en5
Mar 19 18:54:09 localhost kernel[0]: Ethernet [AtherosE2200]: Restored PCI command register.



ANY ideas why this is not working for me?

My apologies in advance if the answer to my question is obvious/already stated/etc. Never had any problems with ethernet kexts in the past and this is my first Skylake build.
 
Joined
Oct 1, 2016
Messages
8
Motherboard
MSI Z270 M5
CPU
i7 7700K
Graphics
GTX 1080
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
And to take advantage of the post....

Anyone knows how to do it for E2500?

Thanks a lot
Alvaro
 
Joined
May 2, 2017
Messages
21
Motherboard
GA-Z270MX Gaming 5
CPU
i7-7700K
Graphics
RX-580
Mac
  1. iMac
  2. MacBook
Mobile Phone
  1. iOS
I used Multibeast and selected the Atheros E2200 for networking. It "works" for E2500 with the downside that I am experiencing whereby the ethernet won't be there when you boot, then it will start (go from red to green) when you go to networking preferences before dropping out again at some point. Rinse, cycle, repeat. Guess it'll need someone in the know to tweak the code. One of the issues of being an early adopter of more recent chipsets.
 
Status
Not open for further replies.
Top