Contribute
Register

Psedog's Mod Pro. i7-8700K, Vega64, Gigabyte Z390 Aorus Pro Wifi

Joined
Nov 28, 2018
Messages
75
Motherboard
Gigabyte Aorus Z390 Pro
CPU
i7-8700
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Ill try re-give it a shot but I'm using the non-wifi version, will it still work? I went over to apple insider and found what was being dubbed as a "bullet proof" EFI for the non-wifi version but I was still getting a myriad of issues/couldn't even get it to boot.

Even now re-installing under the original EFI I'm find thing that my bluetooth is no longer seen by the system even though its always worked out of the box (BCM94360CS2).

I keep on reading about open core, have you explored that avenue yet @psedog? I think maybe when it comes out of beta (who knows when) I'll give it a run, but sounds like its the way to go.

Edit: Perhaps I can just switch out the DSDT on the other site for the one that you are currently using, and everything will be kosher?
 
Last edited:
Joined
Nov 27, 2018
Messages
355
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
Ill try re-give it a shot but I'm using the non-wifi version, will it still work? I went over to apple insider and found what was being dubbed as a "bullet proof" EFI for the non-wifi version but I was still getting a myriad of issues/couldn't even get it to boot.

Even now re-installing under the original EFI I'm find thing that my bluetooth is no longer seen by the system even though its always worked out of the box (BCM94360CS2).

I keep on reading about open core, have you explored that avenue yet @psedog? I think maybe when it comes out of beta (who knows when) I'll give it a run, but sounds like its the way to go.

Edit: Perhaps I can just switch out the DSDT on the other site for the one that you are currently using, and everything will be kosher?
I have an opencore efi in my Catalina thread. My problem with it is I can't get it to work with Messages and Keychain. Those are deal breakers for me.
You'll have to map your usb ports. I have hs12 blocked, which is the one for the onboard Bluetooth /wifi. Use hackintool. If makes mapping your USB ports super simple.
 
Joined
Oct 28, 2012
Messages
9
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hey @psedog thanks for the new EFI, however in my case nothing has changed. I still need to hit enter in order to boot the macOS (still the only bootable drive in my machine) and still have pretty bad NVMe speeds (when i compared config.plist i presumed nothing will change but decided to give it a go anyway ;)).

As i said it's really just an annoyance so thanks again for all the hard work man!
 
Joined
Oct 28, 2012
Messages
9
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
OK so I resolved the auto-boot issue... Not sure why "last booted volume" didn't work but I've disabled the mouse in Clover (probably irrelevant) and put the actual drive label as the default boot volume and not everything works as it should. The only thing now is the poor NVMe performance but i can really live with that as it's plenty fast as is anyway xD.
 
Joined
Nov 28, 2018
Messages
75
Motherboard
Gigabyte Aorus Z390 Pro
CPU
i7-8700
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@psedog THANKS! And to think I just wasted over 20 hrs trying to get this thing back up and running.

I'm still having a weird issue where my bluetooth isn't even recognized in the system (i.e the wifi portion of the card is working perfect but bluetooth even recognized?) Any ideas, I saw your version is the same but with an AX so maybe you encountered a weird issue somewhere as well

Edit: In windows bluetooth isn't working either which makes me suspect either 1). BIOS settings is causing this 2). Bios Firmware 3). Hardware malefunction (it worked for a time being on the original Catalina build so I can't imagine that's the issues?

Any ideas off the top of your head what BIOS settings could cause this?
 
Last edited:
Joined
Nov 27, 2018
Messages
355
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
@psedog THANKS! And to think I just wasted over 20 hrs trying to get this thing back up and running.

I'm still having a weird issue where my bluetooth isn't even recognized in the system (i.e the wifi portion of the card is working perfect but bluetooth even recognized?) Any ideas, I saw your version is the same but with an AX so maybe you encountered a weird issue somewhere as well

Edit: In windows bluetooth isn't working either which makes me suspect either 1). BIOS settings is causing this 2). Bios Firmware 3). Hardware malefunction (it worked for a time being on the original Catalina build so I can't imagine that's the issues?
So, one thing that was pointed out in my other thread was that Bluetooth and Wifi are using two different USB addresses.
HS12 and HS14.

You will have to modify yours to work how you need it. As I'm not using those and don't have them enabled.

Also, for Windows, I can't connect any new bluetooth devices. Whatever I address in Mac will show up in Windows, but I cannot pair new devices for some reason :crazy:

Z390 Aorus Pro Board USB Addresses.png

Z390 Aorus Pro Rear USB Addresses.png
 
Last edited:
Joined
Nov 28, 2018
Messages
75
Motherboard
Gigabyte Aorus Z390 Pro
CPU
i7-8700
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
So, one thing that was pointed out in my other thread was that Bluetooth and Wifi are using two different USB addresses.
HS12 and HS14.

You will have to modify yours to work how you need it. As I'm not using those and don't have them enabled.

Also, for Windows, I can't connect any new bluetooth devices. Whatever I address in Mac will show up in Windows, but I cannot pair new devices for some reason :crazy:



View attachment 438338
View attachment 432931

Yea HS12 and HS14 won't affect me as I don't have the wifi version, my PCI wifi/bluetooth adaptor is plugged into one of the HS11 ports (I believe its just for power but can't remember if it uses any data as well).


Hmm, well I attached the windows bluetooth drivers for my card if you wan't to try update the driver (there is a readme in there that tells you what to do, not sure if your version is similar enough to mine
yours -BCM94360CSAX
mine - BCM94360CS)?

I just tried to reinstall them on my windows build but no such luck, not sure bluetooth is being recognized their either, which again makes me wonder if its a bios thing. I did read I think from a credit form the opposite was true for a user, where bluetooth devices that were connected to his windows machine showed up in OS X. Very Odd.

I might try pull out the card and try a different PCI slot to see if that re engages something but I have my graphics card vertically mounted, and it behind it, so its a process...
 

Attachments

  • Broadcom_BCM94360CS_Driver_Win_78_10-Minihere.zip
    34.9 MB · Views: 42
Joined
Nov 27, 2018
Messages
355
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
... the opposite was true for a user, where bluetooth devices that were connected to his windows machine showed up in OS X. Very Odd.
It's not odd because of EFI. The OS passed the pairing info to EFI that way you can for example, use a Bluetooth keyboard in Bios or the OS selection screen.

My theory is that which ever OS you used first for Bluetooth will stay in control while the other pulls from EFI. I could be way off though, lol.
 
Joined
Nov 27, 2018
Messages
355
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
... graphics card vertically mounted, and it behind it, so its a process...
Oh, I know the pain :lol:

And I'm planning on going hard tube one day :eek:

20200209_231611.jpg
 
Top