Contribute
Register

Psedog's Mod Pro. i7-8700K, Vega64, Gigabyte Z390 Aorus Pro Wifi

Joined
Nov 2, 2011
Messages
47
Motherboard
Gigabyte Z390 Aorus Pro Wifi
CPU
i7-8700K
Graphics
UHD 630
I don't think I am doing the same thing with the USB port limit patch. How do I apply them? Thanks.
 
Joined
Nov 27, 2018
Messages
215
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
I don't think I am doing the same thing with the USB port limit patch. How do I apply them? Thanks.
Under Kernel and Kext Patches add it to KextstoPatch.
Also, go under Kext Installer and add USBInjectAll.
 
Joined
Feb 18, 2019
Messages
2
Motherboard
Gigabyte Z390 AORUS PRO WiFi
CPU
Intel Core i7-8700K
Graphics
Sapphire 11265-05-20G Radeon Pulse RX 580 8GB
Mac
Mac Pro
Mobile Phone
iOS
Thanks for posting SSDT, saved time getting USB 3.0 working on Mojave 10.14.5
 
Joined
Nov 2, 2011
Messages
47
Motherboard
Gigabyte Z390 Aorus Pro Wifi
CPU
i7-8700K
Graphics
UHD 630
Under Kernel and Kext Patches add it to KextstoPatch.
Also, go under Kext Installer and add USBInjectAll.
Can you please check this for me? My USB is pausing every few seconds now.

405870
Screen Shot 2019-05-15 at 9.39.17 AM.png
 
Joined
Mar 22, 2019
Messages
8
Motherboard
Gigabyte Z390 Aorus Pro Wifi
CPU
i9-9900K
Graphics
Vega 64
That is to setup the Vega64. It adjusts the fan profile as well as provide a slight overclock. Now that I've identified updated OSX to build 18E2034 and set my Mac to iMac 19,1. I want to test it without this fix as I've heard the new build supports Vega graphics cards (but the system is stable, so I'm hesitant as well ;) ).

I'm still running my SSDT with the USB port patches that are included with the latest Clover Configurator.

View attachment 404133
First thank you for this thread - it has been invaluable in getting my near identical system set up and working like a dream!

I have done the 10.14.5 update and have had no issues so far.

1) Updated Clover, Lilu and Whatevergreen to the latest versions before the update.
2) Removed the line in config.plist that was previously setting up and controlling the Vega 64
3) Reboot

Once I was satisfied that everything was still working (now with a noisy Vega 64) I then

4) Downloaded the 10.14.5 update directly from the apple website and started the installer
5) Two reboots during the install before booting into the OS with everything still working and a quiet Vega 64 again.
 
Joined
Nov 27, 2018
Messages
215
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Can you please check this for me? My USB is pausing every few seconds now.

View attachment 405870
I would remove the first com.apple.iokit. I don't have that one and mine is working flawlessly.
Also, make sure you have OsxAptioFix3Drv-64.efi in your "drivers64UEFI" folder in Clover. I was using 2000 before, but 3 seems to be working well for me.
 
Joined
Dec 28, 2013
Messages
137
Motherboard
Z390 I AORUS PRO WIFI
CPU
i7-8700
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
@psedog hi, The correct temperatures of your vega radeon 64 are not yet displayed? I am shown 127 degrees and it is constant, which is why I am not reading correctly. I'm trying a vega 56
 
Joined
Nov 27, 2018
Messages
215
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
@psedog hi, The correct temperatures of your vega radeon 64 are not yet displayed? I am shown 127 degrees and it is constant, which is why I am not reading correctly. I'm trying a vega 56
HWMonitor and iStat don't show it properly for some reason. The system is registering the temperature correctly, though. Their is a script that you can run in terminal to show it, but I can't recall what it is right now.
 
Joined
Nov 27, 2018
Messages
215
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
@psedog hi, The correct temperatures of your vega radeon 64 are not yet displayed? I am shown 127 degrees and it is constant, which is why I am not reading correctly. I'm trying a vega 56
Ok, you guys always make me fix the issues that I didn't want to worry about, lol.

All sensors are now working with HWSensors3. Make sure when you install it to do custom. Have all the checkmarks that I have checked before installing. HWMonitor App 1 or 2 doesn't matter. Depends on what you prefer.



Screen Shot 2019-05-18 at 7.49.27 PM.png
Screen Shot 2019-05-18 at 7.50.51 PM.png
Screen Shot 2019-05-18 at 7.51.12 PM.png
Screen Shot 2019-05-18 at 7.51.18 PM.png

 
Last edited:
Joined
Nov 27, 2018
Messages
215
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Updated the first post.
Added Clover folder for OSX 10.14.5 added.
Updated config for new USB 3 tricks.​
Updated config for iMac19,1.​
Kext for HWSensors3 added.​
 

Attachments


Top